How to set up a true "alias" in Gmail
January 18, 2016 6:34 PM   Subscribe

I have my main gmail inbox as mainemail@gmail.com, for example. Then I have a work email that I have added as a user for this account, called workemail@gmail.com.

This workemail@gmail.com is actually my default email address, so whenever I go to compose a new message, it defaults to sending it from that email. When people send me email at that address, it all shows up in my mainemail@gmail.com box, and I can reply to them as workemail@gmail.com.

However, if they then reply to me again, I see in the history, it shows that my previous email was sent from "mainemail@gmail.com." Is there a way for me to only show up as workemail@gmail.com?
posted by madonna of the unloved to Technology (6 answers total) 8 users marked this as a favorite
 
In Settings -> Accounts and Import, scroll down to "Send Mail As", where there's an option like this:
When replying to a message:
- Reply from the same address the message was sent to
- Always reply from default address
The first option should do what you want (since it sounds like you have the send-as part configured already).
posted by dorque at 6:50 PM on January 18, 2016 [2 favorites]


Oh, except that I think that still makes you show up as mainemail@ in the "Sender:" field, it just adjusts the "From:" field. Hmm. I think that might actually be part of the RFC for email (that "Sender" is supposed to for-reals identify the source of the message).
posted by dorque at 6:53 PM on January 18, 2016


madonna of the unloved: "I have a work email that I have added as a user for this account"

Can you be a little more specific in terms of what you mean by "added as a user for this account"?
posted by Conrad Cornelius o'Donald o'Dell at 8:37 PM on January 18, 2016


Yes, by default GMail adds "send as" email addesses as a 'From' alias with a 'Sender' of the current account. But you can use your main GMail inbox essentially as a mail client for another email account, if you know how to ask.

Settings -> Accounts -> Add another email address you own

When the "Add another email address" window pops up, uncheck the "Treat as an alias" option. This unlocks additional workflow steps that configure full SMTP, which should work automagically for another gmail.com address. (These steps legitimately require the work email password, fyi. And if workemail@gmail.com is actually hosted by someone else, you'll also need their email server web address.) When you've done this correctly, the listing in "Send mail as" list should be marked as "Not an alias."

With this set up, email sent as workemail@gmail.com is relayed through the actual workemail@gmail.com account on its way out and all of the 'From', 'Sender', and 'x-on-behalf-of' headers will read workemail@gmail.com as if you had logged into that account separately.

As a bonus, that sent email is also recorded in your work email account. Which means you've got a full record of the email conversations in the workemail@gmail.com account in case you want to search it specifically or hand it over to someone else.
posted by QuixoticGambit at 8:43 PM on January 18, 2016 [2 favorites]


So what I have set up is exactly as described by QuixoticGambit, and it's what I meant by "add a user for this account." Everything works good in theory, but when I look back on a reply chain of emails, I'll see my mainemail address pop up in this context:

From: mainemail@gmail.com [mailto:mainemail@gmail.com] On Behalf of [my full name]
Sent: Monday, January 18th, 11:00 AM
To: blah blah

So in the above example, my mainemail is showing up, even though I've been corresponding with the person through workemail. And I do have "not an alias" checked, and my workemail is also picked as my default.
posted by madonna of the unloved at 9:48 PM on January 18, 2016


I have a similar set up to yours. I sign into myname@gmail.com and send and receive messages to/from an email@mydomain.com address which is hosted by Google domains and is to all intents and purposes another gmail address. I have set up email@mydomain.com to forward all mail to myname@gmail.com

When you go into Accounts and Import in gmail, does it have both email addresses listed under Send Mail As? The second email address might have all the SMTP stuff listed too. Under that, is there a radio button like so:

When replying to a message:
( o )Reply from the same address to which the message was sent
( )Always reply from default address (currently email@mydomain.com)
posted by fatfrank at 5:41 AM on January 19, 2016


« Older Age, the unknown quantity   |   Workshops and classes in cool places Newer »
This thread is closed to new comments.