Android phone not reconnecting to mobile data
September 8, 2015 7:56 AM   Subscribe

I have a Sony Xperia Z3 Compact running Android 5.1.1 that has developed the annoying habit of not reconnecting to mobile data after going through a dead zone. (So if I go through a tunnel and come out the other end, even though the 4G icon appears next to the signal, the phone will return a "no connection" error.) Switching airplane mode on and off always fixes this, but there's no functional airplane mode widget I can find, so it's a pain. Is there any known fix for this issue?
posted by ndg to Technology (4 answers total) 3 users marked this as a favorite
 
Dunno about a specific fix, but something like Widgetsoid will give you a toggle switch for it.

Pretty sure you could also set up Tasker to check and set it automatically.
posted by quinndexter at 9:26 AM on September 8, 2015


I assume you mean it's cumbersome to go through the settings menu to switch airplane mode on and off? If you pull the screen down from the top, an additional menu comes up. In the list of icons is airplane mode and mobile data. Have you tried switching these on and off?

It's called the quick settings menu and looks like this. If you don't have the right options showing, I believe you can edit what shows up.
posted by apcmwh at 9:31 AM on September 8, 2015


Best answer: Hi there, another Xperia Z3 Compact user here. This issue popped up after the latest update to the OS and is hugely frustrating especially when paired with the stamina mode.

I googled around and found this fix.

"As posted in the other thread, there is now a fix/workaround:

From reddit user FishStik5: Going into the APN settings and changing the APN protocol to iPv4 only (it was iPv6 before) seems to fix the problem.
How to find the setting: Settings-> Wirelessa and Network / more -> Mobile networks -> APN -> T-mobile data -> APN protocol -> Set to IPv4."

This worked for me and I haven't had to toggle Airplane mode on and off anymore.
posted by viramamunivar at 9:52 AM on September 8, 2015 [1 favorite]


Response by poster: vieamamunivar, thank you so much. I will test on my commute home and I'm optimistic I'll be able to mark as resolved.
posted by ndg at 10:07 AM on September 8, 2015


« Older How can a physics postdoc transition to climate...   |   How to ease access to outdoor spigot beneath deck? Newer »
This thread is closed to new comments.