Why am I having to sign in again and again on Gmail, Facebook, Twitter?
July 6, 2015 6:32 PM   Subscribe

I am constantly having to sign in again on Gmail, Facebook, and Twitter on my laptop (2014 Macbook running Yosemite and generally using Safari browser, but same issue occurs when I use Chrome too) even though I select the option for the browser to remember to stay signed in and to remember my laptop & browser.

I experience this unevenly on my laptop - sometimes its OK, other times its really bad (like signing in, doing email or social media for a few minutes, then going away from the computer and returning after 20 mins to find myself having to sign in again and to give permission to remember my computer/browser again).

I have 2 step verification switched on for all these services. When the above problems happen (which is almost every day) , it eats up my text message limit on my smartphone (I know, I could use other ways of getting the verification code message, but this is usually the most convenient, and that workaround doesn't solve the basic problem.)

Thanks for any tips!!!
posted by zresearch to Computers & Internet (5 answers total) 2 users marked this as a favorite
 
Two thoughts:

-What are your cookie settings? If you have any non-default settings, check your whitelist.

-Is there any chance you're somehow running your browser in private/incognito mode?
posted by phunniemee at 6:34 PM on July 6, 2015 [5 favorites]


Not to alarm you, but I once had a virus that gave me this exact problem. I'd do a quick scan to be safe.
posted by EmpressCallipygos at 7:43 PM on July 6, 2015 [2 favorites]


I've fixed this problem in the past by deleting all cookies and clearing the browser cache.
posted by COD at 7:50 PM on July 6, 2015 [1 favorite]


Check the time, timezone, and date on your computer. It plays a role in the exchange of security bona fides that all your browser to make a secure connection to websites. Osx can be set to autoset the time, but only if it had the correct timezone with proper dst settings.
posted by Sunburnt at 7:55 PM on July 6, 2015 [3 favorites]


May be a bad profile. Chrome is especially bad for this.

To test Safari, log into your Mac with the Guest account and test. If you see the issue, reset Safari.

For Chrome, create a new profile and delete the old one. If you sign into Chrome on your current profile and sync, you won't lose bookmarks, cookies, etc.

Since this happening across browsers, though, you may need to nuke your OS X profile. To do that (and I just did this so these steps were handy):

* boot to single user (reboot it and hold cmd+s the moment it chimes).
* plug into Ethernet
* open Terminal and enter: mv /Users/youraccount /Users/youraccount-old
* reboot

This is essentially the nuclear option, but will get rid of any cruft screwing up your OS X profile. You can also just move content to the appropriate places (music, photos, etc).
posted by youknowwhatpart at 6:07 AM on July 7, 2015 [1 favorite]


« Older What do you serve for an evening of card games?   |   Packing for my flight Newer »
This thread is closed to new comments.