Help me fix my Firefox!
November 30, 2005 5:20 AM   Subscribe

A couple of Firefox questions, if you please... Mostly Flash-display related.

I've googled a bit, but can't seem to find the right answer. I thought v1.5 would solve it all, but nope. So, I'm turning to you, fellow MeFiers...

1/ The drop-down URL list (from the URL bar) shows the most accessed URL at the bottom, not at the top, which seems illogical, Captain. How come ? Can't find a setting for it in about:config...

2/ Why won't Flash always show ? It works for some, but not all. For instance, the menus in are replaced by an empty space (not even replaced by JavaScript menu), is just a white page, as is
OTOH, the mp3 player plays, as does the fine French equivalent DewPlayer, or yet another one from, used by robotwisdom.

My wild guess is that the the ones that work do because they would use some kind of simpler markup, maybe, but I really can't tell.

I tried removing NPSWF32.dll wherever I found it, or putting suspect files in plugins_disabled, then reinstalling from Firefox itself, to no avail (what more, it only suggests to install Flash for the SWF that worked before).
My about:plugins shows this, among others (Quicktime, Java, Acrobat, MS DRM...) :

Shockwave Flash
Nom de fichier : NPSWF32.dll
Shockwave Flash 8.0 r22

And, finally : it only does this on my work computer (Win2k, IE6 and Opera play Flash fine), not my home one.

Any idea ?
posted by XiBe to Computers & Internet (18 answers total)
I'm on 1.0.7 and the drop-down URL list simply displays in the order in which you typed them into the address bar - I lost my bookmarks the other day, and now is at the bottom of the list because that was the one I entered first...
posted by altolinguistic at 5:55 AM on November 30, 2005

Is there some sort of firewall or content-filtering mechanism at work? If you're not using an extension like Adblock, which can take a regular expression and gut websites with it if it's too broad, is there something else on the network that might be stripping content out?
posted by Dipsomaniac at 6:22 AM on November 30, 2005

I am using Firefox 1.5 and Flash 8. I can't reproduce any of your concerns: The URLs in the address bar list appear in cronological order and the Macromedia site shows as it is supposed to show - the Flash menu is there. Maybe it has something to do with your setup. You say you have already tried to uninstall and reinstall Flash. You can also uninstall Firefox and then manually delete anything it lefts behind (plugins, preferences, etc) - remember to back everything up first. Abd then maybe it has something to do with Win2K (I am using XP).
posted by nkyad at 6:37 AM on November 30, 2005

Do you have adblock installed? Try turning it off.
posted by gramcracker at 7:01 AM on November 30, 2005

Response by poster: Thanks for your answers, but still nothing.
I don't have AdBlock installed. My extensions :
DOM Inspector,
Html Validator,
GMail Notifier,
IE View,
SessionSaver .2,
JavaScript Debugger,
Nightly Tester Tools.

I'll try and uninstall it all when I get the time... Still looking for ideas... Grmbl.
posted by XiBe at 7:09 AM on November 30, 2005

I had the same problem with invisible Flash objects. I just disabled AdBlock and that solved the problem. I then updated to FireFox 1.5 and AdBlock and that seemed to bring things back to normal.
posted by picea at 7:18 AM on November 30, 2005

You don't have to uninstall them for a first check, just disable them one at a time to see if that makes a difference. I have Dom Inspector, Linkification, IE View, Bugmenot, Web Developer and Nightly Tester Tools installed and I have no trouble with Flash, so it's less likely to be those extensions.
posted by Dipsomaniac at 7:21 AM on November 30, 2005

As an aside, I saw that you don't have Adblock installed now, but if you ever did and then tried to use Adblock's own uninstaller, it could have left some cruft on your system. If that is the case, try re-installing Adblock and then un-installing through the Extension Manager.
posted by Dipsomaniac at 7:35 AM on November 30, 2005

Response by poster: Installed AdBlock, restarted, uninstalled, restarted, no luck...
posted by XiBe at 8:20 AM on November 30, 2005

the flash problem could be that your office blocks certain communication through certain ports and your FF not being able to find alternative way to download the file.
namely, port 1935 and 443.

any way you could connect via dial-up?

you might want to post the flash thing on macromedia support forum - support engineers regularly checks threads there and reply with solution if it's known.
posted by grafholic at 8:52 AM on November 30, 2005

Response by poster: Grapholic : why not, how would that explain the fact that some Flash animations play just fine, and IE & Opera can play all known Flash ?
I'll try a clean uninstall/reinstall of Firefox, I gues...
posted by XiBe at 8:55 AM on November 30, 2005

ah sorry i didn't read the part that some flash works but others don't.

i would like say that detection script on MM site isn't working or the known rendering issue with Flash 8 and Firefox (some animations don't render properly due to XHTML code in the HTML head) - then again, it seems like others with similar setup as yours as well as your home machine work fine.

it could be one of the extensions, but that's just a wild guess.
posted by grafholic at 9:03 AM on November 30, 2005

hey if you haven't uninstalled yet, on MM or hi-res site, if you right-click on the area where flash animation is supposed to be, what do you see? is it even detecting flash? or does it show like right-clicking on regular HTML page w/out flash?
posted by grafholic at 9:07 AM on November 30, 2005

XiBe: "I'll try and uninstall it all when I get the time... Still looking for ideas... Grmbl."

Don't uninstall them all. Start in safe mode by adding --safe-mode to the command line. That'll disable all extensions and start with the default skin.
posted by Plutor at 10:29 AM on November 30, 2005

Best answer: Inconsistent behavior like this points to a corrupt profile. 80% of problems with Firefox are caused by bad profiles, IME. Try creating a new profile by running and see if that new profile has the same problem. If not, move your bookmarks over and reinstall extensions one by one, checking to see if the problem reappears.
posted by dhartung at 10:51 AM on November 30, 2005

Best answer: Run the profile manager and create a new, blank profile without any of the cruft from your old one. Verify that the problem still occurs. Note this is the only way to reliably do this, you can't just uninstall/disable extensions. They will still leave behind their crud. A blank profile is the way to go. It sounds like you have some remains of an old extension, or some kind of interaction between two extensions.
posted by Rhomboid at 3:13 AM on December 1, 2005

I'm having somethinf simular... after upgrading to FF 1.5 I can't get any flash elements to load in the browser, it seems like flash is running just not getting it onscreen.
posted by edgeways at 3:31 PM on December 3, 2005

Response by poster: Yep, create a new profile did work. Browsing through my old profile, there seem to be remnants of the TabExtensions xpi...
Anyway, Flash at last works, I can dump IE usage for that, phew :)
Thank you dhartung and Rhomboid, and all the people who gave ideas.
posted by XiBe at 3:23 AM on December 5, 2005

« Older can my employer delay my raise because i'm...   |   How can I collaberate with indie musicians for my... Newer »
This thread is closed to new comments.