Gullible is not in the dictionary
November 29, 2005 8:56 PM   Subscribe

I'm using FireFox 1.07 for Windows XP. Previously, when I typed "dict [word]" into the address bar, FireFox would take me to the dictionary.com definition for [word]. Now typing in the same command just takes me to the first result of a Google search for "dict [word]," the same as if I typed anything into the address bar. Recently all my Firefox bookmarks disappeared as well. I haven't updated Firefox or changed anything that I know of. What happened, and how do I restore the old functionality?
posted by ludwig_van to Technology (10 answers total)
 
IIRC, you need to have the bookmark to the correct site with the keyword dict in the keyword box under advanced.
All you should need to do is rebookmark http://dictionary.reference.com/search?q=%s with "dict" in the keyword box.

Also you might want to try poking around in your firefox folder to see if your profile has changed. Its generally located in C:\Documents and Settings\USERNAME\Application Data\Mozilla\Firefox\Profiles and then a random string. In the random string folder, there will be a file called bookmarks.html which contains all your bookmarks.
posted by scodger at 9:03 PM on November 29, 2005


The fact that you lost bookmarks sounds like your profile could be corrupt - unless you've used something like Moz Backup, you probably won't get them back.

As for the dictionary setting, I'm not sure (it's been a while since I used Firefox). Most obscure settings can be edited by typing about:config into the address bar, so you might be able to narrow it down and change the URL that's queried. A quick search of Mozillazine Forums didn't yield anything for me.

If things are going kaput, now might be a good time to upgrade to Firefox 1.5 anyway.
posted by djgh at 9:04 PM on November 29, 2005


Thanks djgh, I didn't realize my version wasn't up to date.

scodger, I'm confused by your instructions.

you need to have the bookmark to the correct site with the keyword dict in the keyword box under advanced.

Under advanced where? Tools->options->advanced doesn't have any box like what you're describing.
posted by ludwig_van at 9:19 PM on November 29, 2005


Sorry,
If you go into the bookmark manager, right click on the bookmark, and there will be a box for keywords.

I shouldn't have without checking.
posted by scodger at 9:31 PM on November 29, 2005


Yeah, you lost your keyword search when your bookmarks went missing, since keyword searches are stored as bookmark plus a keyword, as scodger notes above. I can't help with that (other than telling you to look around for your bookmarks.html file in your firefox profiles directory) but here is how to re-set up a keyword search:

www.mozilla.org/products/firefox/smart-keywords (cached @ google cuz Mozilla's redesign seems to have lost the page in question)
posted by misterbrandt at 9:37 PM on November 29, 2005


Another easy way to set that quick search for dictionary.com again is to go to dictionary.com and then right click in the search text box on the page and choose "Add a keyword for this search" and then fill out the dialog that pops up. This can also be used to set up similar keyword quick searches for any search text box on any site.
posted by shinji_ikari at 9:40 PM on November 29, 2005


Oops, should have previewed. That's exactly what misterbrandt linked to.
posted by shinji_ikari at 9:42 PM on November 29, 2005


Of course Dave's Quick Search has similar functionality, and much more.
posted by Chuckles at 10:02 PM on November 29, 2005


Since you're using Firefox just go tot he following link and have dictionary.com search added to the search bar.

http://mycroft.mozdev.org/quick/dictionary.com.html
posted by frankie_stubbs at 11:30 PM on November 29, 2005


Recent related question
posted by Sharcho at 12:55 AM on November 30, 2005


« Older Tracking down a 'white label'   |   "Hmm, that's very interesting...or not." Newer »
This thread is closed to new comments.