My MacBook thinks I am an iPhoto library
May 6, 2015 7:50 AM   Subscribe

On my MacBook Pro: when I double click on the computer icon and it opens (to show me Applications, Library, etc) and then I double click within that to Users (which shows me Guest, Me, and Shared), if I then click on "Me" it tries to open with iPhoto, claiming I am an iPhoto Library. I just want to be a User folder again with typical subfolders like Documents, Music, Pictures. Help.

When I do typical workarounds, such as keeping my Document folder in the Dock, I can get to my stuff, but I find it really irritating that anytime I accidentally click on Me (User) it tries to open in iPhoto.

Is there some quick fix for this?
posted by rabidsegue to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
If you cant' get around iPhoto you can boot your Mac by holding down the shift key. This will stop any applications from opening so you can change settings etc.

If its iPhoto and possibly other apps that load when you open your user account you can remove them from the startup items:

User > System Preferences > Users and Groups: select your account.
You will see a list of apps that start when you open that account. Remove or add as needed.
posted by Mac-Expert at 8:06 AM on May 6, 2015


Your "me" (presumably replaced with the user name you chose) icon is meant to be a folder, not a document that an application like iPhoto can open. Click once on your "me" icon and Get Info on it (File > Get Info, or Command-I.) Does that info window show that your "me" is a folder?
posted by emelenjr at 8:10 AM on May 6, 2015


Response by poster: emelenjr: My info window shows "Me" as Kind: iPhoto Library. Not a folder. (However, it shows "Guest" and "Shared" as folders, like normal. Not sure how/when this changed for "Me."

Mac-Expert: iPhoto doesn't open automatically when using my account, only when I double click on the "Me" (user) icon--it isn't recognizing "Me" as a folder.

Hopefully what I am saying makes sense, I'm trying to clarify my question with some more details...
posted by rabidsegue at 8:35 AM on May 6, 2015


In the finder, if you select "Go > Home" (or Cmd-Shift-H), does that do the right thing? And if it does, when you Cmd-Click in the titlebar of that Finder window, what does it show you as the path to your Home folder? I wonder if somehow your home directory got moved, and an iPhoto library got put in its place. That seems super bizarre, but I've seen stranger things.
posted by primethyme at 9:13 AM on May 6, 2015


Response by poster: primethyme:
Yes, cmd-shift-H does the right thing.
The cmd-click in the title bar shows the laptop>volume>users folder>"me" path.

Maybe this is just one of those things I should shrug at and learn a new habit rather than double clicking from the icon in the users folder.

Sorry to threadsit!
posted by rabidsegue at 9:21 AM on May 6, 2015


Try rebuilding the User permissions. Boot into Recovery mode (cmd-r), and when the options come up you can of course open disk utility and do a permissions there, but you can also do a user permissions fix by opening the Terminal and typing "resetpassword" without the ". Then on the bottom of the following screen you can reset the permissions and ACLs of any chosen account. Granted this is not a permissions issue more like an attribute issue, but it may work. Onyx may help. Can't remember if it has the capability to shange the KIND attribute.
posted by Gungho at 9:39 AM on May 6, 2015


I am not a Mac guy, so take this with a grain of salt, but it seems likely to me that the only real difference between a general-purpose folder and an app-specific library has to be that the library is a folder that has some kind of magically recognizable content inside - perhaps a plist file or some other osxism - that Finder knows about, so it hands that folder off to the associated application instead of opening it itself.

If that's right, there will be various ways for that to happen by accident - perhaps the magical whateveritis accidentally got dragged and dropped somewhere it shouldn't have been, or perhaps iPhoto got inadvertently told to create a new library with the same name as your home folder, and just went ahead and did it.

A bit of digging suggests that iPhoto libraries are packages and that an OS X package is just a directory (folder) conforming to specific naming and contents conventions, so I think I'm probably on the right track here.

Try this: open a Terminal window, paste in
ls /Users
and hit Enter. If everything were normal, I'd expect to find that the resulting list of names looks something like
Guest  Me  Shared
and I'd be interested to see whether yours does in fact look like that. Could you copy it and paste it into a comment here?
posted by flabdablet at 9:52 AM on May 6, 2015


I think OSX tracks special folders via extended file attributes. Try this in Terminal:
xattr -l "$HOME"
If this shows any result, that means your home folder picked up some extended attributes somehow. If you're feeling intrepid, you can clear them with:
xattr -c "$HOME"
(On my system, running 10.9, there aren't any attributes on the home folder. I don't think it's supposed to have any normally.)
posted by neckro23 at 11:22 AM on May 6, 2015


What has most likely happened is that the Bundle Bit has been set on your user folder. It's not a common thing, but I've heard of it before.

There are a few ways it can be fixed, but the easiest might be to download Path Finder and use it to uncheck the bundle bit flag: Navigate to your user folder from within Path Finder, then File Menu -> Get Info. If the "Bundle Bit" box is checked, uncheck it.

There is an image showing what Path Finder's Get Info window looks like here and I got the details of how to do this in PathFinder from this discussion.
posted by mewsic at 11:09 PM on May 6, 2015


« Older A mob of people decorate a car - genius or scary?   |   Joe Vs. The Volcano (ambient soundtrack) Newer »
This thread is closed to new comments.