1920x1080 LCD. Laptop graphics max 1366x768. Black bars top and sides.
April 22, 2015 10:07 PM   Subscribe

New 1920x1080 HD LCD -- great. Can't wait to use it for my monitor. But -- INTEL graphics card tops out 1366x768, leaving *big* black bars top and bottom of screen, smaller black bars on sides but still annoying. Adjusted graphics using horizontal and vertical scaling from 0% out to 100%, worked great, filled the screen -- all better. Worked great, that is, until I rebooted the puter --

Worked great, that is, until I rebooted the puter -- now the bars are back and no way to get rid of them that I can find. Which is absolutely annoying to me, because I know it can be done, as it *was* done. On this laptop.

Totally frustrating. I *know* that the card can do it because it's done it. And when I go to Custom Resolutions on the graphics control panel, it gives me A Big Scary Warning which of course I blow right by, and then add in (try to add in) the resolution I want, it tells me it already exists, and do I want to apply it, and you betcha I do, and ... nothing.

Is it just time for a new laptop, or what?

Help?
posted by dancestoblue to Computers & Internet (10 answers total) 2 users marked this as a favorite
 
Do you have the display set to mirroring mode? If so, it'll mirror the resolution of your built-in display. For whatever reason, on a lot of laptops, mirroring is the default mode.
posted by destructive cactus at 10:20 PM on April 22, 2015


Response by poster: Thx for the idea, destructive cactus.

The graphics card does not have a "mirroring" button to click but it comes close with "Single Display" option, a "Clone Displays" option, and an "Extended Desktop" option. Defaults to "Clone Displays" and when I changed it to "Single Display" it gave me this neat-o love message: "This is not the optimal screen resolution for the primary display device. The optimal screen resolution is 1920 x 1080."

What a brilliant bit of detective work they've done here!

You can bet it made me happy to see that little msg!

So no dice on the Multiple Displays tab of the Graphics Properties panel -- no matter what I selected, and/or how I held my mouth *as* I selected it, no changes.
posted by dancestoblue at 11:11 PM on April 22, 2015


Best answer: You want something like this utility. Although the one i always used was powerstrip.

I have finagled many a junky laptop graphics card in to doing what i wanted with those.

1 720p display = basically 1 megapixel. 1 1080p display = 2 megapixels. 2 720p displays therefor = 2 mp as well. So, 1 720p display and 1 1080p display would be 3mp.

It wouldn't surprise me if your integrated GPU maxes out at around 2mp. That was a lot for a laptop(or onboard graphics in general) even just a few years ago, probably until 2010-11 or so even.

I definitely forced my intel 4500mhd equipped machine to drive two separate displays at separate resolutions with powerstrip though, and hacked out a solution to my nightmare setup of driving monitors AND a tv on a system with SLI without it constantly disabling SLI on reboots(UGH, i think i just had a flashback).

Set a powerstrip config that leaves it either expanded how you want, or just force it to display only on the external display at 1080p. You might even be able to force it to output 1080p with the internal display on at normal resolution, but you might create a lagfest or even a glitchfest doing so. You'll at least be able to pin display boundaries in a way that doesn't reset when you reboot, though.

OH OH, on preview, try forcing 1280x720. The tv might just go "OH!" and expand it to full screen automatically. Some TVs/displays don't play nice with the intermediate 1366x768 type resolutions by default unless they are "720p" displays and that not-freaking-actually-720p resolution is actually their panel resolution. That's mostly a problem i've had with plasmas though, for what it's worth.

This post also reminded me to reinstall switchresx on my mac, to stop the internal display from kicking down to 1080p whenever i connect my tv or external display. Annoying as hell. Anyone reading this having a similar problem on a mac though, that app is your solution. It's the OSX version of powerstrip, essentially.
posted by emptythought at 11:26 PM on April 22, 2015 [1 favorite]


what laptop are you trying to do this on?

have you tried the 'extended desktop' option?

the exciting error messages just seem to indicate that your computer had detected the native resolution (1080p) of your new monitor. however, it's possible that if you are connecting with a VGA cable that your monitor won't do 1080p over VGA.

if your laptop has HDMI or 'display port' out this may work better...
posted by ennui.bz at 12:03 AM on April 23, 2015


The definitive answer lies in knowing the model number and make of your laptop or at least more specifics about the graphics card. Even better to have the same info on the monitor.

I would check the laptop manufacturer's site for updated chipset and display drivers, and yes try HDMI or display port if you've been trying VGA so far. Make sure it's a decent non-horrifically cheap HDMI cable; you can test it with any 1080P HDTV made in the last 8-9 years you may run into and rule out the cable or the monitor as being picky / flaky / etc.

Even if your display adapter only handles a single 1080P (2MP) display, you should be able to make the monitor into your "single" and "primary" display.

I usually don't mess with the "Graphics Properties" or other control panels provided by Intel / NVIDIA / etc for simple resolution tweaks -- try it from the regular Windows control panel (right-click on wallpaper, "Screen Resolution" or "Properties" depending on Windows version).

From there you can temporarily disable your laptop's display which will only happen when the cable is connected to the monitor (click "Identify" to determine which screen is "1" and "2", select your laptop's screen which is typically "1", uncheck "Extend desktop to this monitor" or whatever it's called) and try only using the monitor.
posted by aydeejones at 12:33 AM on April 23, 2015


Whenever you disable a screen in Win 7 BTW, it automatically forces you to apply the change so that it can then determine the possible resolutions for your remaining display, for this reason.
posted by aydeejones at 12:34 AM on April 23, 2015


Yes, when it says 'this is not the optimal display resolution...', you should just be able to select the device and change it to 1920x1080 in the Display control panel (in Windows 7, go to Control Panel, then Display, then Adjust Resolution in the sidebar).
posted by destructive cactus at 7:50 AM on April 23, 2015


Response by poster: You want something like this utility. Although the one i always used was powerstrip. ...
posted by emptythought at 1:26 AM

That first utility says that it works by creating EDID overrides, then goes on to state that Intel's graphics driver does not support EDID overrides. So that's out.

I have checked out powerstrip and the amount of tweaks and adjustments it can make, in all kinds of areas I have absolutely no understanding of -- it's just all kinds of dizzying to me. (I'm pretty dizzy anyways, up all night cooking and cleaning in the kitchen, alternated with messing with a Nook HD+ tablet and also this laptop, plus a long-ass movie -- Boyhood, which sure was great to watch on this big honkin' LCD, run through that Nook HD+.)

emptythought, I absolutely appreciate the time and effort (and your obvious experience, also) you put into your response, and will install and attempt to learn something about the powerstrip utility, hopefully without burning down this condo etc.

The definitive answer lies in knowing the model number and make of your laptop or at least more specifics about the graphics card. Even better to have the same info on the monitor.
posted by aydeejones at 2:33 AM on April 23

Dell 11.6" Inspiron Model M101z (iM101z-3980BK is the full-out name)
WIN7 64 bit Home Premium 128GB SSD 8GB RAM
notebookcheck Newegg Amazon youtube unboxing video(s)
(Amazingly, somewhat stupidly, dell.com comes up empty when I searched on the model name/number there.)

VIZEO 49 Inch LED Smart TV M492I-B2 HDTV
And yes, the HDTV is connected to the lappy with a good HDMI cable.

From there you can temporarily disable your laptop's display which will only happen when the cable is connected to the monitor (click "Identify" to determine which screen is "1" and "2", select your laptop's screen which is typically "1", uncheck "Extend desktop to this monitor" or whatever it's called) and try only using the monitor.
posted by aydeejones at 2:33 AM on April 23

No cigar.

have you tried the 'extended desktop' option?
Yep.

you should just be able to select the device and change it to 1920x1080 in the Display control panel
No cigar.

~~~~~

Couple of things of import to note here: obviously, the money spent on a different computer is something I'd really rather not do, esp being as how I know this bastard is capable of doing the deal. Also, this is a really sweet little lappy, the exact perfect size for me (it's thin and it's light and it's small yet a full-sized keyboard, and it fits perfectly inside zippered leather legal pad folders, of which I own two, it's a really great machine for travel and/or coffee shops) and plus I've had it for a few years, it's all beat to shit and pretty much steampunk looking, leastwise as steampunk as an Inspiron can get. I loved it the day I unboxed it and I still do, such a sweet little puter....

~~~~~

I am crashing and burning, need to catch a few hours of sleep, look at this with a clearer head, less bleary eyes. Thanks to everyone who has contributed (so far) and to anyone who pops their head in whilst I'm resting.
posted by dancestoblue at 9:12 AM on April 23, 2015


I'd advise you reinstall your video card driver, then try some of the steps people have recommended.
posted by JauntyFedora at 11:42 PM on April 23, 2015


Response by poster: OH OH, on preview, try forcing 1280x720. The tv might just go "OH!" and expand it to full screen automatically. Some TVs/displays don't play nice with the intermediate 1366x768 type resolutions by default ...
posted by emptythought at 1:26 AM on April 23


emptythought in for the win! Downloaded, installed Powerstrip, nosed around a few minutes to see what's what inside this powerful bit of software, found where to change out resolution, and BINGO! All better now. Supercool. I now have all the screen real estate that I've paid for, it's great.

Thx to all who came in here, this one is now marked "Resolved" -- once again, MetaFilter comes to the rescue.
posted by dancestoblue at 3:57 PM on April 24, 2015


« Older Japan-filter: From Bullfighting to Kurosawa in a...   |   Empower my iPhone 5c! Newer »
This thread is closed to new comments.