File Dialog Woes
November 25, 2005 10:48 PM   Subscribe

I recently re-installed Windows XP. Whenever I open a file dialog, the folder currently selected shows in Thumbnail mode. I want it in List mode and I can't figure out how to switch it.
posted by Imperfect to Computers & Internet (11 answers total)
 
Right click + view + list. Just be sure to do it in empty space.
posted by panoptican at 10:57 PM on November 25, 2005


Oh, and to make it apply to all folders, go up to the menu "Tools + Folder Options". Click on the View tab and then click the "Apply to All Folders" button.
posted by panoptican at 10:58 PM on November 25, 2005


I've tried that (View->List). Regardless of if I open or cancel the file open/save command, the setting I chose is gone the next time I open a dialog.

And Tools->Folder Options only shows up in regular windows, not file dialogs, or I would have tried that, too. =) Actually, is there a way to get there I'm not noticing?
posted by Imperfect at 11:11 PM on November 25, 2005


To clarify, I'm trying to set the default view for File Dialogs, not folders.

In case I didn't make that clear. =(
posted by Imperfect at 11:13 PM on November 25, 2005


Nah, you were perfectly clear. I just perfectly misread your question. I'm not really sure how to customize the file dialog view. It seems that is handled on a program by program basis though. I've seen the views in many different ways on my machine, and I've never done anything to specify how it should be viewed. For instance, Photoshop always does thumbnail, Word always does list, SPSS always does detailed. Is it thumbnail view for you no matter what program you use?
posted by panoptican at 11:25 PM on November 25, 2005


You may have already stumled across this, but if you haven't, here's a very technical way to solve the problem: FileDialogExtender. Judging from the explanation of the code, there's no easy way to do what you want. But from the way you phrased the question, it sounds like at one point (before the re-install), the default view was on list. So maybe there's an easier solution. If there is, I'm sure you'll have it soon...
posted by panoptican at 11:34 PM on November 25, 2005


You can try OpenWide but it did not work for me. It looked like it was trying, because there was a quick flash when the dialog appeared, but it was the stock standard one.

You might also try file-ex but I did not try this one because it's shareware and it hasn't been updated in 3 years.

I find that the stock behavior is that all the common dialogs open in List view, except for certain directories such as "My Pictures" which always open in thumbnail mode. So it would seem that perhaps the common dialogs DLL thinks that every directory is your My Pictures directory, or else you happen to always been opening stuff in My Pictures.
posted by Rhomboid at 11:58 PM on November 25, 2005


Just open a dialog, set the view you want, then hold down ctrl when you click the X button at top-right to close the dialog. This unintuitive method will make the dialog remember your preference next time you open it.
posted by evariste at 12:07 AM on November 26, 2005


Crap. Well, that doesn't seem to work for me any more, but it used to.
posted by evariste at 12:10 AM on November 26, 2005


If it's only certain folders misbehaving, there might be something funny in the desktop.ini files inside them (these are hidden by default - turn on viewing hidden files and protected operating system files to see them). These files are what Windows uses to "bless" My Documents and My Pictures, giving them special icons, naming rules and behaviors, and I've found that OEM preinstallers will often mess them up.
posted by flabdablet at 9:40 AM on November 26, 2005


OpenWide worked perfectly, thanks Rhomboid!
posted by Imperfect at 9:53 AM on November 26, 2005


« Older Ptosis   |   Can you spin down an external hard drive? Newer »
This thread is closed to new comments.