Canon Vixia HF G20 mts file format and Mac
February 28, 2015 8:39 PM   Subscribe

I used to use Canon Vixia HF M500 and upgraded to Canon HF G20. The video format is .mts. They open in VLC player and have interlacing lines through them. Why is the quality so bad? The M500 shoots in MPEG4 HD straight from the camera and had high quality large files. Can the G20 shoot in MPEG4 format? If not, what is the best setting to use when shooting? What is the best way to convert them on a Mac quickly while maintaining quality to upload?

Is the poor quality I am seeing in VLC player the true output from the camera, or is it the limitations of the player? When I convert them using Handbrake and other free converters, they still look poor. I shoot about 40 rock n' roll performance videos in one night and need to quickly process and upload. It is even odd trying the get the videos out of the camera. I have to search for them in a stream folder nested inside so many other folders.
The G20 has a way to convert the videos to Standard quality in the camera, but then the aspect ratio gets changed and the videos looks squished and also poor quality. I am so confused and frustrated.
posted by samoa to Computers & Internet (5 answers total) 1 user marked this as a favorite
 
In VLC, you can deinterlace by going to Video -> Deinterlace -> Auto. In Handbrake you can deinterlace by clicking Picture Settings on the top toolbar -> Filters -> set Decomb: Default.

From looking at your camera's manual, it looks like it can record at either 60i or 24p. I believe this is a limitation of the MTS/AVCHD format. There is a "PF30" setting which shoot 30fps progressive but records as 60i. I'm not sure how that works out but it may be worth trying.

In any case, I think Handbrake with the Decomb setting will be the quickest way to get things converted while maintaining quality with this camera.
posted by zsazsa at 9:40 PM on February 28, 2015


Thank you for your help zsazsa. I've tried the de-interlace feature in Handbrake and it still returns the lines. I've tried the other settings you mentioned, but the video still looks poor with the lines when I watch it through the VLC player.
posted by samoa at 9:48 PM on February 28, 2015


Have you tried the free MTS MT2S Converter from the Apple App Store?
posted by blob at 7:02 AM on March 1, 2015


Thanks, I ended up returning the camera and getting a different model that shoots in MPEG4. Appreciate the answers.
posted by samoa at 8:17 PM on March 3, 2015


In case anyone finds this question in the future, another conversion solution is ClipWrap.

It will rewrap the stream into a Mac-friendly container, without a transcode, so it's as fast as your drives.
posted by tomierna at 6:40 AM on March 4, 2015


« Older A question for only children with elderly/aging...   |   Was that rotation in 1793 or 1794, rabbit? Newer »
This thread is closed to new comments.