DNS Headaches (difficulty level: D-Link)
January 4, 2015 8:27 AM   Subscribe

My parents' DIR-655 router consistently starts dropping DNS queries around 24 hours after it's been restarted. What settings should I check?

Using the router's debugging page confirms that the connection issues are solidly with the router: the router itself pings webpages just fine, so I don't think it's an issue on the ISP's end. Power cycling fixes the issue without fail, leading me to think there's some kind of ongoing caching that's failing; however, the manual and inbuilt help pages offer no advice as to how I'd turn it off.
posted by GenericUser to Computers & Internet (11 answers total) 3 users marked this as a favorite
Is the firmware up to date? That's step one before trying to debug anything else.
posted by bfranklin at 8:43 AM on January 4, 2015 [1 favorite]

If this was my parents I know my instant response would be provided its all updated and not immediately obvious (and it sounds like you are technical enough that you probably did the usual checks) that my time over the holidays is is seriously worth more than the headaches its going to cause not just to buy a new router.
posted by Another Fine Product From The Nonsense Factory at 8:48 AM on January 4, 2015 [3 favorites]

Best answer: Is the router acting as a DNS proxy/relay? If so, you might be able to turn it off; that will force clients to query DNS directly. A quick Google shows me quite a lot of results pointing to DNS relay issues with that model router.

I'm not familiar with the configuration, but maybe try turning DNS relay off if possible, and restart the clients.
posted by Dipsomaniac at 9:09 AM on January 4, 2015 [1 favorite]

I had a different model Dlink router that worked fine for about a year (maybe a little longer), and then it started getting flakey if it wasn't rebooted regularly. I had to power-cycle it about once a week, then once a day, then every few hours. I replaced it with a Buffalo router that's been rock-solid for about three years now.
posted by alex1965 at 9:55 AM on January 4, 2015 [2 favorites]

Response by poster: DNS Relay seems like what I'm looking for - I've turned it off now. I'll check in a day or two, and if that hasn't done the trick, this router is going in the bin.
posted by GenericUser at 9:58 AM on January 4, 2015

You can also just manually configure DNS on the pcs to point at (googles DNS server)
posted by empath at 10:06 AM on January 4, 2015 [4 favorites]

2nding using Google DNS server. It is an easy change, and will make sure it is definitely not the ISP. (We recently had this problem, and the ISP denied that it was the DNS. Lo-and-behold, Google fixed it)
posted by troytroy at 1:02 PM on January 4, 2015 [2 favorites]

Best answer: You probably have solved the problem already by telling the router not to act as a "DNS relay" (whatever they actually mean by that. Probably they mean acting as a forwarder or a caching-only resolver but "DNS relay" is probably not the precisely accurate term for what it is doing.)

But if the problem reoccurs, start from a PC in the house and look at the DHCP lease information that clients are getting from the router. Look particularly at the provided DNS server(s) (really there *should* be more than one..) If the listed DNS servers have addresses within the IP address block of your ISP then the router is probably not interposing itself. If, as seems likely, the router is trying to act as a forwarder or a caching-only resolver (a lot of consumer routers include dnsmasq, a simple caching resolver) then you can tell this because the suggested nameserver address will be in one of the RFC1918 private address space blocks (e.g. 10.*.*.* or 192.168.*.*) and you can probably solve the problem by avoiding its use if it is giving you problems.

If the router allows a way to simply turn it off and not use it (which it sounds like it does in this case) that's a good option. If no such configuration is available, you should be able to find a section to configure DHCP server operation, where you can specify which DNS resolvers are suggested via the DHCP lease. That's your next best bet -- set them to be the addresses of your ISP's servers or of open public resolvers such as Google's and Try to provide at least two if possible.

If you can't turn off the caching server in the router and you can't override the router from suggesting it in the DHCP lease you can tell the clients to use DNS servers you specify and not take them from the suggestions in the DHCP lease offer. This is your least good option, however, as it will sometimes cause problems on mobile devices if you try to operate them on a network where intercepting DNS traffic is part of the network operator's strategy for redirecting you to a login or authentication page. So try not to do that (on devices which roam from network to network, anyway) unless you have to.
posted by Nerd of the North at 2:54 PM on January 4, 2015 [1 favorite]

Speaking from many years of experience here, back to the days when everyone bought WRT-54g's to mod and even before, the problem is that it's a dlink. There isn't a permanent solution to this, other than to not buy anything dlink makes.

People have been having problems like this with dlink routers since consumer router review roundups still listed options for non wireless models. Seriously, i remember people complaining about problems like this with their routers back when MeFi was only maybe 2 years old. I don't understand how they've managed to consistently mess up their firmware or... something for this many years. It's like they have a special crappiness chip they install in everything they make, or some inserted bug in the software from corporate espionage. It's that consistently bad.

Buy the cheapest asus router, which is seriously $20(alternatively, a much better one for $39), and forget this ever happened.

Just changing the DNS settings on the connected computers is a non-solution. What if someone comes to visit, connects, and nothing will resolve? That's crappy. Especially if it's grandkids or friends kids who just want to play clash of clans or whatever on their phones/tablets. Doubly so if it's some friend of theres who has something weird like windows 8(which, grr, completely moved everything around from windows 7 and before) they can't make heads or tails of to guide them through. It's a junky, band aid solution.

If disabling that setting doesn't resolve it, just junk the thing.
posted by emptythought at 3:47 AM on January 5, 2015 [1 favorite]

Like everyone said, it's probably buggy firmware. DNS is particularly complicated for the router to implement so with any luck it's only DNS that's broken and if you configure the router not to do DNS, it might be OK otherwise.

Here's the manual for the router (Revision B). Looking at this around page 20, I'd disable "Advanced DNS service", and modify the Primary and Secondary DNS addresses to point to Google DNS at and Then disable "Enable DNS Relay" (page 36); that's the key setting and it sounds like you already got it.

With those settings your router won't try to do DNS itself. It will tell connecting DHCP clients to use Google DNS, so it should work for visiting guests too.
posted by Nelson at 7:32 AM on January 5, 2015 [1 favorite]

Response by poster: Turning off DNS Relay seems to have solved the issue.
posted by GenericUser at 1:32 AM on January 11, 2015

« Older Who are the best Twitter accounts for sports and...   |   How to escalate small talk to medium talk? Newer »
This thread is closed to new comments.