How to get iTunes to play tracks without gaps?
November 10, 2005 12:58 PM   Subscribe

Seamless tracks in iTunes?

When playing tracks in iTunes there's always an annoying gap between tracks while the computer catches up with the next song. Is there a plugin or hack to pre-buffer the next song so I get a seamless audio experience? I remember Winamp being able to do this.
posted by tommyc to Computers & Internet (11 answers total)
iTunes > Preferences > Audio > Crossfade Playback
posted by FreezBoy at 1:04 PM on November 10, 2005

Although that won't actually solve your problem, just conceal it in a sometimes annoying fashion. I don't think itunes does gapless playback, just as the ipod doesn't.
posted by selfnoise at 1:07 PM on November 10, 2005

I've looked into it before, and there doesn't seem to be a solution. I just use MacAmp for all my gapless audio needs (e.g., live FLAC bootlegs).
posted by danb at 1:08 PM on November 10, 2005

Response by poster: Thanks FreezBoy, but tried that - it works "too well" and cuts off the beginning of the next track, as selfnoise noted. Darn, that's a shame, someone could get rich with a seamless plugin.
posted by tommyc at 1:10 PM on November 10, 2005

This has been asked a few times before here. Maybe someone marked something as a best answer. Otherwise I suggest Googling to see if Playlist Magazine, or or or someplace has a work-around.

My personal experience is either to join the tracks or use Toast (Mac user) to burn CDs with no gaps.
posted by terrapin at 1:11 PM on November 10, 2005

Ditto. No solution. Here's hoping Apple will get around to it...
posted by cribcage at 1:21 PM on November 10, 2005

Best answer: The feedback section might be a good place to lodge a feature request. Enough people requesting it will make it that much more likely that developers will be assigned to solve this problem.
posted by Rothko at 1:30 PM on November 10, 2005

Turning on 'crossfade playback' and setting the overlap time to 0 seconds has always worked for me.
posted by chrismear at 1:38 PM on November 10, 2005

Ditto chrismear's solution. Enabling cross-fade and setting the slider to zero results in seamless playback for me.
posted by lfaren at 7:16 PM on November 10, 2005

BTW, Toast will still introduce a tiny, tiny but clearly audible bit of silence between tracks, even in "seamless" mode (zero gap). For true seamless audio cd's, Jam somehow does the trick. Completely gapless playback.
posted by Aquaman at 9:11 PM on November 10, 2005

Turning on 'crossfade playback' and setting the overlap time to 0 seconds has always worked for me.

I find that this works for live shows, but not for other things like house mixes, where the slight cutoff is noticeable.

In iTunes you can rip a CD as one complete track, so if you were never going to listen to individual tracks anyways, this might be an option.
posted by anarcation at 12:33 AM on November 11, 2005

« Older Croatian "sadrzaj" in English   |   How do I get external connections to my LAN games? Newer »
This thread is closed to new comments.