Can't get to public wifi login screen
October 14, 2014 4:27 PM   Subscribe

How can I connect to a public wifi network when the login page stubbornly refuses to appear?

Asking for my wife. We finally made it to Italy. My wife is using a research library in Rome. She was able to connect to their wireless network without a problem on her iPhone 5S, including entering the username and password they gave her on the login web page (you know, one of those web pages that comes up and you have to click through to agree to terms and conditions). On her MacBook Air (2014 running OS X 10.9.5), she was never able to get to the login page. It didn't do the expected thing of loading that page whenever she tried to go to another site--nothing would load. Network preferences says that while she's connected to the network she has a self-assigned IP and won't be able to connect to the internet.

This computer hasn't had trouble with any other networks.

Things that didn't work:
* Trying a different browser (same problem in all of Safari, Firefox and Chrome)
* Resetting Safari to clear cookies/cache
* Rebooting, shutting down
* Manually entering in the address for the login page from her phone's history (wouldn't load)
* Changing the DNS server (we were using unblock-us, she changed it back to
* Renewing the DHCP lease
* Trying to go to http://localhost,, or (which I read somewhere)

A librarian she spoke to said "oh yeah, that happens with Macs a lot" and said another staff member who wasn't there had some solution like clearing cookies/cache. Given that the problem appears in more than one browser, that doesn't seem right (and in any case didn't work for her).

Does anyone have any other tricks to make the login page appear? Or other thoughts on things we might try?
posted by rustcellar to Computers & Internet (8 answers total) 6 users marked this as a favorite
Do you have any kind of javascript-blocker or ad blocker? Try disabling that.
posted by Chocolate Pickle at 4:34 PM on October 14, 2014

Maybe temporarily disable any antivirus program that's running?
posted by alex1965 at 6:39 PM on October 14, 2014

I would first check your cookie settings. temporarily change to accept all.
posted by prk60091 at 7:01 PM on October 14, 2014

Check the security settings for the browser. For our wifi, you have to enable insecure content for the log in screen to load.
posted by amapolaroja at 7:43 PM on October 14, 2014 [1 favorite]

This StackExchange has a a few more ideas, including turning off your specified DNS preferences entirely. I don't know enough about Macs or networking to evaluate any of the suggestions, but worth a shot?
posted by BungaDunga at 8:09 PM on October 14, 2014

including turning off your specified DNS preferences entirely.

This sometimes works for me. I have a specific location set up on my older Mac that is just called nodns and the whole point of it is so those idiot login pages magically appear. You might want to try actually creating a new account and then trying virgin-Safari on that one just to see if there is some other random preference she had set that was causing problems. Also try setting your home page to something stupid simple like (not Top Sites, not your email, just some so that you know the page itself isn't trying to do some redirect that is causing problems. This way you can just click the HOME button on Safari and have it do its usual thing. Those things usually work for me in some combination. I hate to sound all "you just can't know some things..." because obviously this is just a technical issue but doing the aforementioned things usually gets me to the portal. If she knows the company that manages the portal she might have even more luck googling them specifically as well if there are known issues. Good luck.
posted by jessamyn at 9:28 PM on October 14, 2014

Yeah, my first instinct before I entered the thread was to tell you to remove any manual DNS settings and try with an incognito window.
posted by suedehead at 9:52 PM on October 14, 2014

Also try setting your home page to something stupid simple like (not Top Sites, not your email, just some so that you know the page itself isn't trying to do some redirect that is causing problems.

This was going to be my suggestion, with one caveat. Make sure it is a site that doesn't use https (at least not on the landing page). I've had issues going to, because Google's servers (or possibly my browser) immeditely redirects to, and then the wifi login page tries to redirect that. At that point, the browser (corectly) detects someone trying to hijack a secure session and refuses to honor the wifi's redirect. Going to a page that doesn't use https usually allows the redirect to work.
posted by yuwtze at 8:10 AM on October 15, 2014 [1 favorite]

« Older How durable is the birch veneer on IKEA furniture?   |   When cats fly Newer »
This thread is closed to new comments.