Why my Windows XP laptop slows down overnight
October 19, 2005 6:50 AM   Subscribe

I have been noticing a problem with my work laptop which is running XP SP2. If left up and running all night, then on most mornings i find out it is running very sluggishly with 100% CPU utilization (from the graph). First I thought may be it is firefox with its large number of open tabs. But I am not so sure anymore. killing firefox does not help. Also when I look at the CPU column in task manager i cant quite figure out what is causing that 100% utilization. None of high numbers on the CPU column look suspect. Obviously I am missing something here. One thing I am not 100% sure, and there may be something to it, is that I may have seen this problem more often when I am using wifi instead of wired LAN at home. But I need to verify this. After this happens I usually have to reboot the machine after bringing it back to work. I am able to suspend the machine and bring it to work and plug it into the work LAN. But unless I reboot it it really runs slow. Just logging out does not help.

I would like some advice on how to figure out what is causing that 100% utlization and why this strange behavior. I was suspecting some trojan activity..but I am not very sure. Of course if I suspend the machine before I go to sleep at night, everything is fine in the morning. Also i never see this kind of behavior during times when I am using the machine..from morning till i go to sleep (may be except when the virus scanner is making its weekly runs).
posted by flyby22 to Computers & Internet (18 answers total)
This is a feature of Windows, not a bug and seems to be most prevalent coming out of sleep mode. (I know someone with a recent Apple that has been running continuously for a year and only required rebooting twice in that time. Actually, I am not even sure that it required rebooting, just that it was only rebooted twice.)
posted by caddis at 7:04 AM on October 19, 2005

If you run Process Explorer, it'll give you a better idea of what's clogging up your machine.
posted by strikhedonia at 7:11 AM on October 19, 2005

It could be set to run a specific task at this time, something like defrag or the indexing service? I'd suggest googling the process in question. If you think it is a trojan, install a software firewall and you'll be able to see if packets are being sent out; Or, disconnect your internet connection at night, but leave the computer on.
posted by AllesKlar at 7:13 AM on October 19, 2005

caddis, that describes most people using OS X, especially those of us with laptops. I reboot for security updates and power failures.
posted by odinsdream at 7:19 AM on October 19, 2005

If you go to the processes tab and click on the CPU column twice, you will see the highest CPU hog at the top of the list. Are you using Norton Antivirus? I've had problems with the real time virus scanner pegging my CPU utilization in the past.
posted by SteveInMaine at 7:50 AM on October 19, 2005

This is a feature of Windows, not a bug and seems to be most prevalent coming out of sleep mode.

That describes most people using OS X, especially those of us with laptops.

That does not describe me. I have a PowerBook that I bought a year ago, and it drives me fucking bonkers. I have to reboot it at least once a week for the very problem described by flyby22 (in fact, I rebooted it fifteen minutes ago for this problem): something is sucking up all the CPU cycles. It's only started happening since the most recent OS updates, though. (I'm not running Tiger.) Whatever the case, this isn't PC-only, and it is very frustrating.

Flyby22, is your machine perhaps performing some sort of disk optimization? I once had a machine set to do that in the wee hours, and when I came in it'd be all sluggish. Other things I've seen suck CPU cycles include spyware processes that don't show up in the Task Manager. Have you checked your system lately? (You probably have, but it never hurts to check.)
posted by jdroth at 7:58 AM on October 19, 2005

I will use the Process Explorer next time this happens to see who is the hog.

I have done the sorting of CPU column. But as I mentioned earlier the numbers there did not look high enough for me to explain the 100% utilization graph. I also had the show process for all users enabled checkbox ticked.

May be I do not quite know how to interprete the CPU numbers. That is possible. I started to kill the high CPU processes one by one and yet the utilization remained 100%.
posted by flyby22 at 8:25 AM on October 19, 2005

I had a similar problem and found that my virus-scanning program was set to scan the whole system at exactly 9:00am daily.

I changed that to 2:00am and that solved my problem.

Also, WinXP has a "System Idle Process" that in effect "uses" all the available CPU resources - it's not really doing anything, it's just a placeholder for unused cycles. Check to see if this is somehow the culprit.

What "graph" are you using to measure CPU usage? Perhaps the graph is including the System Idle Process as well.
posted by mikewas at 8:35 AM on October 19, 2005

Some viruses can hide themselves from the task manager, or it could be a driver issue. I've had that happen to me before, where nothing would show up in task manager, but process explorer showed the DPCs running at 50%+... can't remember off-hand how I resolved it (or even what the DPCs do, exactly) but I'm sure someone with better google-fu (and more time) than I can figure it out.
posted by strikhedonia at 8:38 AM on October 19, 2005

I'll put my money on the driver issue. Go to the laptop mfr's Web site and make sure you have the latest version of all drivers.

Also, if you have McAffee Antivirus, that could be the culprit. My new Fujitsu laptop doesn't get along with it at all.
posted by kindall at 9:36 AM on October 19, 2005

Firefox seems to have a bad memory leak and none of the fixes I've found seem to help (it could be from a common extension, but I've seen it on multiple machines). Leaving FF open overnight will eat up memory but shouldn't use extra CPU cycles. If, however, this memory take has led to a crash, a dumprep.exe will take lots of time and energy to close. You could try changing the "write debugging info" settings in the Startup and Recovery options.

Also, I found that Google Desktop, even after completely indexing my system, ran at nearly 100% CPU usage during idle time.
posted by aaronh at 10:16 AM on October 19, 2005

Hmmm - what brand is your laptop and WiFi card?

I've seen this behaviour with Centrino-based WiFi as well as the embedded broadcom cards that come with HP Pavilions...
posted by jkaczor at 11:30 AM on October 19, 2005

jdroth, something is wrong with your powerbook. fix permissions, fsck, logout first. things like firefox have memory leaks.
posted by filmgeek at 11:52 AM on October 19, 2005

mikewas I have definitely noticed that problem with System Idle process. What is the way to rectify it though ?

The laptop is a Thinkpad T40 and it is using built in wifi. It is hard for me to update drivers on a office laptop. I do have local Admin privileges. I will check the IBM or Lenovo support site.

I will try shutting down Firefox before retiring at night for next few days and see what happens.
posted by flyby22 at 12:23 PM on October 19, 2005

I had that problem and was able to trace it (with process explorer) back to the Microsoft anti-spyware program, which runs fine in the background on 2 of our machines but totally clogs up one. I uninstalled it, and the problem went away.
posted by jasper411 at 12:28 PM on October 19, 2005

I do have MS Antispyware on this machine!
posted by flyby22 at 1:33 PM on October 19, 2005

I saw something like this as a result of AVG Antivirus's e-mail scanner and the FreePOPs POP3 server beating each other up; an obscure error condition (FreePOPs's fault) made them end up having one of those endless "That's not what I'm SAYING..." "So what's your POINT?" conversations via a localhost ( TCP connection, which ate all the CPU time without Task Manager ascribing the eaten time to any particular process.

When I reconfigured AVG to talk to FreePOPs via an external (192.168.x.x) address instead, forcing the conversation out onto the wire, it only consumed about 60% CPU (and let me packet-trace it).

Given that I have no clue what software is running on your box, this may well be irrelevant - but I know for a fact that a pair of processes hammering each other via a loopback network connection will result in the CPU usage pattern you describe.

In Task Manager on a mostly-idle XP box, you should normally see the "system idle process" allocated well over 90% of the CPU. If System Idle's CPU consumption is zero, and the remaining visible processes don't add up to 100%, it's a safe bet that it's some part of the OS kernel keeping the CPU busy.
posted by flabdablet at 9:38 PM on October 19, 2005

Oh, yeah: if you do find it's Firefox (which it might well be; if Firefox is leaky, and has eaten all your RAM, Windows might be thrashing): try visiting about:config, creating a new integer preference called browser.cache.memory.capacity and setting it to, say, 16000.
posted by flabdablet at 9:56 PM on October 19, 2005

« Older First time Paxil user experiencing nausea   |   Special purpose slideshow software... Newer »
This thread is closed to new comments.