whats up with google
October 18, 2005 1:44 PM   Subscribe

Every computer in our house will not grant us access to a select few web sites... CNN.com, and Google to name a couple. The really weird part is that anything relating to Google... any logos, Google ads... nothing containing 'Google' will run on my, or anybody else's computer in our house. Can anybody shed any light onto our problem?
posted by bamassippi to Computers & Internet (22 answers total)
 
I had this exact same problem in the past.

Try checking the MTU size (on your router if you have one). For DSL it needs to be 1492 instead of 1500.
posted by reverendX at 1:45 PM on October 18, 2005


"Try checking the MTU size"

.... :-) what's that? How do I find it/change it?
posted by bamassippi at 1:48 PM on October 18, 2005


On a linksys router, you get to the administration page by entering http://192.168.1.1

The default password is "admin". there should be an option for MTU size on the initial page that comes up. If its not on the initial page, click advanced and look there.
posted by reverendX at 1:52 PM on October 18, 2005


Maybe an overly broad adblock filter? (if you're using firefox) I've had a few confounding website problems that stemmed from this.
posted by flod at 2:11 PM on October 18, 2005


Also, if none of that works, check your hosts file (usually under windows/system32/drivers/etc) to make sure you don't see weird entries (usually only 127.0.0.1 localhost is in there). The chances of this being the problem are slim since (1) it's happening to all your computers, and (2) a hijacked hosts file usually takes the computer to pr0n/gambling sites.
posted by rolypolyman at 2:13 PM on October 18, 2005


I used to have a d-link router that would sporadically block access to a host of websites, and needed a reboot to make it go again. I sold it, as you can imagine.
posted by ascullion at 2:20 PM on October 18, 2005


(actually, i wouldn't have imagined that, ascullion. i'd have imagined that you threw it away. why would you pass on something that causes problems to someone else?)

mtu sets the size of the data packets that your computer sends out. what worries me is that in theory it shouldn't matter if your value is too large, since if a router is configured to accept smaller values it should chop your data up into smaller pieces (fragments) for you. so having the wrong size mtu may make things less efficient, but it shouldn't stop them working.
posted by andrew cooke at 2:41 PM on October 18, 2005


ah. no, i may be wrong. it looks like the router sends an icmp message in reply, telling your computer to send smaller packets. so i'd suggest looking at your router config and make sure it's not blocking icmp messages.

or maybe someone else is blocking or losing them, and so your hosed. in which case you do need to drop the mtu size manually.
posted by andrew cooke at 2:46 PM on October 18, 2005


Could be you have some spyware/malware or maybe even a virus. There are plenty of free programs available to help. MeFi, no doubt has a good list, but you can start with Ad-Aware PE at lavasoftusa.com/software/adaware and AVG at free.grisoft.com
posted by kc0dxh at 2:47 PM on October 18, 2005


My sister managed to catch a TON of spyware. One of those bits of malware prevented her from going to google.com, replacing it with their own BS. I had her download firefox, and that let her through.
posted by delmoi at 3:01 PM on October 18, 2005


"I had her download firefox, and that let her through."

Actually, it's got to Firefox, Internet Explorer, Opera, etc....
posted by bamassippi at 3:37 PM on October 18, 2005


It sounds like some sort of filter, I would recommend trying to ping websites from the command line to see if you really can't get to them, or if something is filtering out port80 traffic...

open up command line, type "ping google.com"
posted by hatsix at 4:14 PM on October 18, 2005


If all the computers have it, it seems unlikely to me to be spyware.
posted by abcde at 4:21 PM on October 18, 2005


Download drtcp: this will allow you to change your MTU setting on each computer. However, this is unlikely to be the problem. Look up another ISP's DNS server addresses and try switching them for yours manually:

Find another Broadband provider's DNS addresses by searching on the Internet.

Open Network Connections, your LAN connection, TCP/IP Properties. Manually plug in the new DNS addresses. Restart the computer. Check Google. Is the issue resolved? If so, blame your ISP.

FYI: this is currently happening with some Qwest DSL DNS servers and microsoft.com, although they refuse to admit the problem.
posted by maelanchai at 4:32 PM on October 18, 2005


open up command line, type "ping google.com"

I'm am so computer illiterate it's sad.... what/where is the command line?
posted by bamassippi at 4:40 PM on October 18, 2005


Go to start, choose run, then type cmd and hit okay.
posted by odinsdream at 4:47 PM on October 18, 2005


Your ISP's tech support should be able to help you with this. If it is the MTU settings (which it sounds like it is), it's a pretty common problem. The correct MTU setting can vary from one ISP to another so you might as well call them and get all the info you need from one place.
posted by winston at 4:54 PM on October 18, 2005


Please don't indiscriminately ping websites. The best way to accomplish a check on reachability is to telnet to port 80 of www.google.com. The Internet goes through thousands of gigabits of ICMP (ping) traffic each day. Ping is no longer the tool it really used to be, and ICMP is not always the most useful measure of site reachability in today's networks.

Start|Run|CMD (enter)
telnet www.google.com 80

Trying x.x.x.x...
Connected to x.x.x.x.
Escape character is '^]'.

^- This means your reachability is fine:

GET / HTTP/1.1
hit enter twice

if you get text, the site itself is fine as well and there is another problem.
posted by arimathea at 5:29 PM on October 18, 2005


Start|Run|CMD (enter)

Ok... when I do that, I'm getting this black box... what do I enter after that?
posted by bamassippi at 5:49 PM on October 18, 2005


It wouldn't connect
posted by bamassippi at 5:52 PM on October 18, 2005


I GOT IT!!!!!!!!!!!!!!!!!!!

Thanks for the help folks. For future reference... it does help to unplug all internet and power cords connected to the d link.
posted by bamassippi at 6:22 PM on October 18, 2005


GET / HTTP/1.1
hit enter twice
This is actually an invalid HTTP request. HTTP 1.1 requests require the Host: header, so if you're doing this manually in this way you should use "GET / HTTP/1.0" if you don't feel like typing "Host: www.website.com" as well.
posted by Rhomboid at 6:45 PM on October 18, 2005


« Older Keep me out of prison!   |   foundation or corporation? Newer »
This thread is closed to new comments.