Google Earth Wallpaper?
December 17, 2013 6:12 PM   Subscribe

I read this article that said there was a button on the Google Earth site that let you download wallpapers. The article states there's a "globe" link at the bottom of the page, however when I load the Earth page I don't see that icon. Does anyone else? Or can I get to the images somewhere else?
posted by cozenedindigo to Computers & Internet (8 answers total) 3 users marked this as a favorite
I do see the globe. It is transparent with a blue dot in the center. I am using Safari.
posted by Kitty Cornered at 6:19 PM on December 17, 2013

Yup, depending on the background image it can be very hard to see, but it's there with Chrome on Mac. Click it and it starts showing random interesting images, and there's a button in the upper left to download.
posted by McCoy Pauley at 6:20 PM on December 17, 2013

I can't see it with Firefox, but can with Chrome (on a Mac).
posted by rtha at 6:42 PM on December 17, 2013

Response by poster: Hm. I'm using Chrome (but on a PC) and I still can't seem to see it. Not even on my iPhone (using Safari).
posted by cozenedindigo at 6:42 PM on December 17, 2013

Same here as rtha: Firefox (v26) no, Chrome (v31) yes. On a PC. Not clear why; appears to be an HTML5 canvas doohickey.
posted by Emperor SnooKloze at 7:17 PM on December 17, 2013

Don't see anything. This is in Safari 7.0.1. running on Mac OS X Mavericks (10.9.1) - does anyone see the globe icon in the same version of Safari/OSX as mine?
posted by dubious_dude at 7:58 PM on December 17, 2013

Make sure that you have the Google Earth plugin turned on and enabled in Chrome. Go to the "Explore on the web" page and make sure it shows the Google Earth interface - it will also tell you if you have the right plugin and should allow you to download it if not.

Once you can see the interface and Google says you have the plugin installed (the current one is Version from what I can tell) THEN go back to the home page - it should now show the little globe with a dot in the bottom right corner.
posted by gemmy at 8:54 PM on December 17, 2013

Response by poster: Ok, it does show up now! But only if I'm in fullscreen mode. Weird!

Thanks everyone!
posted by cozenedindigo at 12:29 PM on December 18, 2013

« Older Tethering MBP to iPhone - how to seamlessly avoid...   |   Where is a good place to buy glasses in Melbourne... Newer »
This thread is closed to new comments.