How do I get mobile activesync working?
October 10, 2005 6:54 AM   Subscribe

How do I get mobile ActiveSync working with Exchange 2003 on Windows Server 2003? The "OWA" page is working and I can't for the life of me get these batch of Sprint smartphones to use the ActiveSync function when not docked.

The error I get across the board is "0x80072f17". After entering the domain and site name (exchange.server.com) the progress bar never increases and it says "Syncing folders" or something general and stays that way for a good hour before returning 0x80072f17. I was getting "Server cannot be reached" then I enable port 443 on the firewall (apparently SSL must be used, that's fine). I'm seriously out of ideas, I can't find the error code 0x80072f17 anywhere and thought I'd finally tap into the collective consciousness.
posted by geoff. to Technology (3 answers total) 1 user marked this as a favorite
 
After our network admin told me he would not get an ssl cert nor turn on active sync for me I discovered by accident that the default install of Exchange 2k3 has activesync on by default and you do not need to have ssl enabled.
It worked but the small tricks were
1) don't use your domain in your username
2) don't include http in the mail server address

The other thing is that apparently it only works with the inbox (or so say all of the forums that i went to) so i ended up having to turn off most of the rules in my outlook.

The verizon users in my office treos came with a great app that eliminates activesync entirely and allows you to choose folders but that is not too helpful for you and I...

Hope this helps.
posted by GrumpyMonkey at 7:29 AM on October 10, 2005


Thanks, as with anything as soon as I asked I got it working (though disabling SSL might have helped).

What I did was the following:

1. Under IIS there's a web site called Microsoft-Server-Activesync, a tab "Directory Security" and then click Edit under Secure Communications to disable SSL.

The weird thing is, I thought I did this before adding the 443 port to the firewall, I wonder if it still uses that 443 port but doesn't actually use SSL. We have a homegrown cert and I think that what was causing it.

Thanks GrumpyMonkey! I kept being told SSL *had* to be enabled.
posted by geoff. at 8:01 AM on October 10, 2005


go to information.ssl.com if you are having problems with you r ssl installation. They probably will have the answer to you SSL issue.
posted by nuttysqurrl at 9:14 PM on May 30, 2006


« Older Org charting?   |   Teaching Basic Excel to Adults Newer »
This thread is closed to new comments.