Why does my iPhone 4S only ring half of the time?
November 4, 2013 12:57 PM   Subscribe

I have an iPhone 4S with IOS 7.0.3 installed and my phone only rings about half of the time. The other half of the time when someone calls, it just goes straight to my voicemail and doesn't ring at all on my end. How do I fix this?

I have it turned "On" and the phone does ring sometimes, just not all of the time. I am missing very important calls. I just upgraded to IOS 7.0.3 (from the normal IOS 7 that I installed maybe a couple weeks ago) so maybe that will help??

Ever since I upgraded to IOS 7 this has been a problem so is anyone else experiencing this? My service (ATT) is always full when this happens so I don't think it's a spotty network connection. Thanks!
posted by timpanogos to Technology (7 answers total) 1 user marked this as a favorite
 
This happens to me as well (actually, less with IOS 7, now that I think about it). I'm pretty sure it's just an AT&T issue. There's no setting on the phone that will help this.
posted by Etrigan at 1:11 PM on November 4, 2013


Sometimes getting a new SIM card can help with these kinds of missed calls. It's definitely not a phone setting.
posted by muddgirl at 1:28 PM on November 4, 2013


It's most likely AT&T. The number of bars (or circles) displayed on your phone has very little to do with actual quality. The display isn't updated frequently, particularly when the cellular is not in use. And even with 5 bars calls will fail to connect, or drop, or call quality can be bad. This terrible state of cell service is common to all US carriers but is particularly bad with AT&T.
posted by Nelson at 1:29 PM on November 4, 2013 [1 favorite]


Forgive me if this is obvious, but you don't have Do Not Disturb accidentally set to turn on between certain hours, do you?
posted by jroybal at 1:45 PM on November 4, 2013


This is exactly what happened to my mother in law. The phone would ignore most calls and then ring randomly. As jroybal said, the culprit was "Do Not Disturb". Do you see a little crescent moon in the status bar?

Do Not Disturb seems to allow persistent callers through (I assume this is because the phone thinks they are important). This makes it hard to diagnose.

To turn this off, swipe up and click off the moon symbol.
posted by phatboy at 2:03 PM on November 4, 2013


Oh my goodness! The Do Not Disturb was on!!!!!!!!!

My mind is blown.

Thank you!!! JRoybal and Phatboy!!!!!
posted by timpanogos at 2:38 PM on November 4, 2013 [2 favorites]


Do Not Disturb seems to allow persistent callers through (I assume this is because the phone thinks they are important). This makes it hard to diagnose.

This is an option you can turn off, but, yeah, by default repeated callers get through.
posted by Tomorrowful at 3:55 PM on November 4, 2013


« Older I would walk 500 miles... Or would I?   |   First time Eulogist. Helpful hints? Newer »
This thread is closed to new comments.