Getting UTF-8 Characters to show in EAC?
October 3, 2005 10:18 PM   Subscribe

I'm trying to rip a CD using EAC and FreeDB for tag information. Problem is, the CD is an import (Japanese), the FreeDB tag information appears to be in UTF-8, and EAC is listing all the attributes using "non-English" characters (artist, song titles, etc.) as strings of question marks. Any idea how to fix this? Windows XP, SP2 if that's relevant.
posted by PinkStainlessTail to Computers & Internet (6 answers total)
Manually tag it.
posted by riffola at 10:20 PM on October 3, 2005

If you're lucky, EAC is smart enough to write the data even if it can't understand it. Try ripping one track and see whether it shows up right in whatever program you're going to play it in.

Assuming you want the Japanese track names...
posted by smackfu at 10:40 PM on October 3, 2005

I ripped a DJ Hasebe cd with Japanese track names using EAC and it turned them into question marks, so it looks like PST isn't lucky, smackfu :-(

PinkStainlessTail, thanks for asking this! I hope someone has an answer.
posted by evariste at 2:51 AM on October 4, 2005

I'm wondering if you have East Asian Characters installed. Control Panel --> Regional and Language Options --> Languages tab. If not, give that a go!
posted by stavrosthewonderchicken at 4:47 AM on October 4, 2005

The software itself would also need to support East Asian characters. Some do, and some don't. If installing East Asian characters doesn't work, try setting your default locale to "Japan" and restart your computer. Then try to run the software.

Control Panel --> Regional and Language Options --> Regional Options (which is the default tab.) Change the "Location" drop-down menu at the bottom of the panel.
posted by NemesisVex at 6:33 AM on October 4, 2005

Tried these, looks like EAC just doesn't support the characters. Ah well. Thanks anyway!
posted by PinkStainlessTail at 3:51 PM on October 4, 2005

« Older Broken Jetta CD Player   |   PDA to hotel broadband, how? Newer »
This thread is closed to new comments.