Why isn't my Roku XD letting me stream in Hi-Def with my new HDMI cable?
October 2, 2013 7:52 PM   Subscribe

I bought a Roku XD a couple of weeks ago. It did not come with an HDMI cable, that was sold separately. It said to purchase one if you wanted to watch "in the best picture quality". Today, I finally got around to buying a standard 3ft HDMI cable and hooking it up to my high definition TV HDMI port. I'm trying to stream Netflix or Amazon movies on it though and it's still standard definition fuzziness. The connection setting says my Wi-Fi is "Excellent" and I have high speed cable internet wi-fi at home. What gives?

I even went into the settings and changed it from "Display Type" from "standard" to "HDTV" but that has not changed anything. The HDMI ports are definitely hooked up correctly I have triple and quadruple checked them. Could the cable be faulty? Should I return it for another?

There is no place in the Netflix options to let me change an HD setting. I'm not very tech savvy. Did I get the wrong Roku or something? What am I doing wrong here I just want to binge watch It's Always Sunny In Philadelphia in HD!

Thank you.
posted by timpanogos to Technology (16 answers total) 2 users marked this as a favorite
 
If the thing you're watching isn't in HD, then your picture won't be in HD either. Just like if you watch a black and white show on netflix, your color TV can't make it color. It may be that you're watching something that isn't available in HD. Can't say for sure that this is your problem but it's worth checking. I think HD shows on netflix are annotated as being in HD.
posted by RustyBrooks at 7:55 PM on October 2, 2013


Not to threadsit but would House of Cards be in HD normally? I tried that and it was fuzzy standard def. Is there a high-def show I could test it on?
posted by timpanogos at 7:58 PM on October 2, 2013


I'm pretty sure on my Roku I had to expressly change a setting to 'HDMI 1080' in order get HD. I don't know offhand where that setting is and I'm still at work, but I'll check when I get home.
posted by trip and a half at 8:03 PM on October 2, 2013 [1 favorite]


Is the Roku UI nice and sharp? If it is then you're connected to the TV in HD but your Internet connection might just not be fast enough for HD content.

If not, did you disconnect the standard def cable from the Roku? That may be affecting things.
posted by zsazsa at 8:10 PM on October 2, 2013


There is a place to select hd on my Netflix; when you are in the process of watching there will be a gear at the lower right that lets you select quality if your buffering capacity will allow higher quality and if the video is available that way Not sure if that's your issue but it's useful for other probs.
posted by Tandem Affinity at 8:10 PM on October 2, 2013


Yeah it seems to be my internet connection. I just turned on the last episode of It's Always Sunny in Philadelphia on Netflix (HS Reunion) and it says it's in "Super HD" and it's just not. Zsazsa- the UI is nice and sharp so it is my connection. I guess there's no way to get around that. Dang. Thanks everyone for your ideas.
posted by timpanogos at 8:25 PM on October 2, 2013


Is your Roku adjacent to your modem? If so, you might consider exchanging the XD with an XS (+ $20 retail), which has an ethernet port for a direct connection. If it's nowhere near the router, consider picking up the Roku 3 with a faster processor (x5) and dual-band wifi (5Ghz vs 2.5 Ghz). If you have a dual-band router, you should see a markedly improved performance.
Also take a gander at the Roku wifi router compatibility list--if your router isn't listed, you might need to upgrade.
posted by prinado at 8:46 PM on October 2, 2013


Prinado thank you! It's right next to the modem! I will upgrade!
posted by timpanogos at 8:48 PM on October 2, 2013


Sorry for the late report, and it sounds like you might have your answer already, but for the record what I changed on my Roku was Settings > Display Type > 1080p HDTV. Probably the same thing you did.
posted by trip and a half at 11:44 PM on October 2, 2013 [1 favorite]


How long did you test out House of Cards for? When I put it on through netflix on my PS3, it takes almost all the way through the opening credits before it clicks into the HD version. And I've got fast internet and a hookup through ethernet cables.
posted by Grither at 4:08 AM on October 3, 2013 [1 favorite]


Does the XD have "Bit Rate Override" function? On the Roku3, you can manually set the bit rate. I found that changing from "Automatic" to "1.5 Mbps" worked for me. You get to this option by hitting the "Home" button 5 times, then the "rewind" button three times, then the "fast forward" button twice, all in rapid succession.
posted by Right On Red at 5:07 AM on October 3, 2013


Yeah that's true, netflix starts fuzzy and gets better after a few minutes.
posted by RustyBrooks at 6:25 AM on October 3, 2013


You get to this option by hitting the "Home" button 5 times, then the "rewind" button three times, then the "fast forward" button twice, all in rapid succession.

Jeez, really? Is there a website that documents this and other crazy settings?
posted by RustyBrooks at 6:26 AM on October 3, 2013 [1 favorite]


Looks like that is the only key combination, but it opens up a new menu of a few options. I will have to take a look tonight!
posted by wenestvedt at 6:41 AM on October 3, 2013


The Bit Rate Override is a "secret" function, I guess. I ran across it on forums, where it seems to be pretty well known, but not on the Roku site itself. Here's a thread about forcing high quality Netflix streams.

BTW, the "Bit Rate Overide" does, in fact, work on the XD - I just tested it on an old one I had. Expect much longer load times, though.
posted by Right On Red at 8:18 AM on October 3, 2013


It's right next to the modem!

Putting two wireless devices right next to eachother will actually create a shittier connection. Try moving them 5+ft apart if at all possible.

You have no idea how many times i've solved a "weird bandwidth issue" or something like this where it wasn't kicking in to a high bandwidth mode because of that.
posted by emptythought at 6:04 PM on October 3, 2013


« Older When living with others, what are unreasonable...   |   Origin of Los Angeles street names? Newer »
This thread is closed to new comments.