Spooky ghost menus in Windows~~~
October 2, 2013 10:33 AM   Subscribe

WindowsExorcismFilter: Seemingly out of the blue, I've started having an issue wherein elements from dropdown/contextual menus in Windows 7 sometimes graphically "hang around" like little Windows ghosts (see bottom right corner). I haven't been able to determine any clear pattern that explains why they sometimes appear. For some reason, they go away if I switch between my monitor and my laptop screen. I've tried installing newer graphics drivers, updating Windows, checking for viruses/trojans, et cetera, but have obviously not solved the issue yet. What's going on here, and how do I get rid of it?
posted by Keter to Computers & Internet (7 answers total) 3 users marked this as a favorite
 
This started happening to me with Word in Windows 7, as I mentioned in a recent AskMe question. In my case, Word will hang when I attempt to close it, after which any context menu will hang around. I've done much the same as you, with no luck. For reference, I'm running a Dell Optiplex 990 with 16GB RAM, Windows 7 Ultimate Service Pack 1, and an AMD Radeon 6350 video card. Maybe that will help pin down a common element with your system?
posted by schoolgirl report at 10:50 AM on October 2, 2013


I'm not sure what causes it other than the sort of senility that sets into most windows installations after a couple years. You can try forcing a screen refresh from your desktop (right-click on desktop -> refresh) or restarting Explorer.exe (Open Task manager with Ctrl-Shift-Esc, kill Explorer.exe, then File -> New Task (Run...) and type in explorer.exe).

If you know what menu generated the item, try re-opening the same context menu (exact position on the desktop or icon usually doesn't matter) and mouse-over the same items. Forcing windows to draw the windows one place may make it realize that it shouldn't keep drawing them elsewhere.
posted by Sunburnt at 10:51 AM on October 2, 2013


Does 'Esc' work? I have this problem when I'm abusing the limited resources of my computer, and 'esc' usually clears it.
posted by theora55 at 10:57 AM on October 2, 2013


This happens to me on my work install of Win7 but not my (more meticulously maintained and updated) home machine. I right-click to the upper left of the "ghost" and when the context menu appears and disappears, that usually resolves it. Sometimes left-clicking the taskbar clears it up too.

In Excel I have a similar and more annoying problem: the entire spreadsheet appears to clone itself about two pixels down and to the right, making it impossible to read or enter data. My "solution" for that is to minimize all (Windows key + m) and then re-maximize Excel. This too only happens on my work machine.

Those facts make me suspect the source of the problem has to do with specific versions of specific software. That's just my idle theory, though.
posted by Z. Aurelius Fraught at 11:00 AM on October 2, 2013


It happened to me too recently, and to fix it, I disabled "Fade out menu items after clicking". It's buried deep: under Start Menu, right click Computer \ Properties Control Panel \ Advanced System Settings \ Advanced \ Performance \ Settings \ Performance Options \ Visual Effects.

This approach was recommended in several forums (e.g., Tom's Hardware forum) and worked for me.

The problem seems associated with specific releases of drivers and/or screen resolution combination, but rather than figure out which old version worked, I used this fix - I can live without that particular visual effect.
posted by blue_wardrobe at 11:19 AM on October 2, 2013 [2 favorites]


This happened to me recently as well. Blue_wardrobe's solution worked for me (disabling "Fade out menu items after clicking").
posted by aubilenon at 12:22 PM on October 2, 2013


I've found that changing your monitor resolution and then switching it back is a decent way to clear these.
posted by sewellcm at 1:10 PM on October 2, 2013


« Older I Lack a Back Pack   |   Sync Outlook with iPhone/Gmail/iCloud. Difficulty... Newer »
This thread is closed to new comments.