Quickbooks, you need to open
September 19, 2013 9:27 AM   Subscribe

I am attempting to install Quickbooks 2012 on my work computer. It installs perfectly well, but will not open. I am going insane. Details inside.

The computer is running Windows 7, completely updated. I have:

a) rebooted
b) uninstalled/reinstalled more times than I care to count
c) run .NET repairs
d) run the Quickbooks Repair tool(s), both from the control panel and from the Intuit website

I actually got it open on Tuesday with some magical combination of the above, but this morning it's back to not opening. QB wants us to pay for tech support, and obviously I'd rather not have to do that. Google has given me lots of ideas (see C and D above) but I'm out of ideas and am hoping the hivemind can help me not only get it to open but to have it continue to open even after shutdown.
posted by altopower to Computers & Internet (7 answers total)
God, QB is the worst. I have to use it every day, which means that just about every day I rage at my computer.

What stage are you getting to in the opening process? (Or is it just completely nonresponsive?)

My thought, if you're able to click on it and it's just churning, is that there's something wrong with the files it's mapped to. Check to see where the Intuit folder lives on your computer, and see if you're able to open QB by double clicking on one of the sample company files.
posted by phunniemee at 9:34 AM on September 19, 2013

Best answer: Do you have administrative privileges on your computer? Are you running it as Administrator? It may be worth a right click, Run As Administrator and see where that gets you.
posted by deezil at 9:49 AM on September 19, 2013

Response by poster: Holy bejesus, deezil. You are hereby awarded a gold star. I don't understand why it would need to be run that way, but maybe I don't have to understand it as long as it works. Let's hope that it continues to run on other days.

Thank you! And yes, phunniemee, QB does appear to be the worst.
posted by altopower at 9:55 AM on September 19, 2013

I don't understand why it would need to be run that way

Because Windows 95 didn't make any distinction between administrative and non-administrative users and what was good enough for a Windows 95 user is good enough for you?

Because forcing you to buy broken software will make you pay for technical support?

Snark aside: it's because QuickBooks makes changes to certain files and registry keys that only administrators (on Windows NT .. XP) or administrators running with elevated permissions (on Windows Vista .. 8) can change. There is no acceptable reason why this is still an issue in 2013 (hell, there's no acceptable reason why it was an issue in 2003!) but there it is.

If you want to run Quickbooks without needing to elevate first, you need to give yourself Full Control permissions on the following folder (and its subfolders and files):

C:\Program Files\Intuit

and the following registry keys and their subkeys:


The least unsound way to get those permissions is to create a QuickBooks security group, give it the required permissions, and add your user account to that group. If you want to do these things and don't know how, post back for a walkthrough.
posted by flabdablet at 2:46 AM on September 20, 2013

Also, as it's a work computer, you might want to draw your IT support people's attention to this guide for using group policy to set QuickBooks permissions.
posted by flabdablet at 2:49 AM on September 20, 2013

I'll add that you can set a setting in your Quickbooks shortcut so it always tries to run as an elevated (admin) user. It'll save you from going through the admin menu all the time:

In Windows 7, right-click the shortcut and select properties. Choose the Shortcut tab, click the Advanced button (lower right) and you'll have a checkbox to enable the shortcut to run as administrator. You may still get the UAC (User Access Control) that pops up (and probably dims your screen) and bothers you about ensuring that you really did want to run it as an admin, at least you don't have to hit the context menu every time to run it.

Windows 8 is, I presume, very similar.
posted by Sunburnt at 6:48 AM on September 20, 2013

Response by poster: There is no IT department, just me. I'll play with the registry settings and user account control next week and see what I can come up with.

posted by altopower at 11:38 AM on September 21, 2013

« Older Good books about finding meaning and purpose in...   |   There has to be more to know besides cost and... Newer »
This thread is closed to new comments.