Ubuntu 12.04 - wireless passwords rejected. Why?
September 16, 2013 7:00 AM   Subscribe

Ubuntu 12.04 is suddenly unable to connect via two different routers. When the (correct) passwords are entered, it attempts to connect, but then brings up the pwd entry form again. This is a new problem, as of last Mon.

All software is up to date, and both routers appear to be functioning normally. Signal strength on both is moderate, but this has not been an issue in the past.

When plugged directly into either router, it's possible to connect w/no issues.

Can anyone explain what's happening here? I've seen some forum postings that indicate this is a known issue, but haven't been able to find a successful workaround yet.
posted by ryanshepard to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
Yeah I've had this issue too.

First off you'll want to debug:

- Attempt to connect
- Open a terminal and type "dmesg" [without the quotes]

You should find some lines prefixed with wlan0

In my case I was getting
wlan0: associated
wlan0: deauthenticating from router:mac:address (reason: 15)
Reason 15 turned out to be a handshake timeout, you might be getting a different reason code so you'll need to search that. Since all my other devices could connect just fine and I was sure the password was right I tried resetting the wireless connection and that worked fine:
sudo ifconfig wlan0 down
sudo ifconfig wlan0 up
Others report success by simply forgetting the network and adding it again:
Network Connections -> network_name -> Delete
Hope this helps.
posted by xqwzts at 7:27 AM on September 16, 2013


xqwzts: Thanks - I see several lines w/"iflwifi", but none with "wlan0".
posted by ryanshepard at 7:38 AM on September 16, 2013


Ah right your connection might not be named wlan0.

You can list all your connections by doing ifconfig in the terminal and seeing what adaptors/connections you have. For example my output is eth0, lo, wlan0 with details on each one.
posted by xqwzts at 7:45 AM on September 16, 2013


I assume that's actually iwlwifi? That would be the Intel driver talking to the Wifi chip. What do they say? Maybe you could copy the whole log on pastie.org or a similar site.

Generally, as to why you get the authentication pop-up - I suspect that this is just Network Manager being stupid. There are two different levels of authentication in wireless networks, a very basic one where one device says "hello network, this is me and I'd like to talk to you other devices", and another one, completely unrelated, that deals with passwords. My impressions is that Network Manager sees a deauthentication of the first type, which can occur if the signal is not good enough, and thinks it should ask for a password to re-authenticate. Which is stupid and wrong, and I can't believe they'd do this, but I've seen this happen myself.

You could try stopping Network manager, "sudo service network-manager stop", and installing wicd and wicd-gtk. If you run wicd-gtk, you get an alternative interface showing the various networks. Would be interesting to see if you get the same or a different problem.
posted by dhoe at 7:55 AM on September 16, 2013


I went through a period of time having to use wicd for this very reason about 2 years ago.
posted by srboisvert at 7:58 AM on September 16, 2013


OK - at a coffee shop now, and Ubuntu is able to connect to wifi here (pwd protected) w/no issues - so this *may* be a router issue.

Output for dmesg

Output for ifconfig
posted by ryanshepard at 8:15 AM on September 16, 2013


FWIW, I have this same problem (or at least the same symptoms) with Ubuntu 12.04, and it only crops up with some wifi networks — but that includes networks that I'm confident are properly set up and maintained because I know that hundreds of other people use them without trouble.

So I doubt that it is exclusively a router issue. Network Manager is pretty clearly part of the problem.

(Sorry I can't offer positive help.)
posted by Now there are two. There are two _______. at 9:01 AM on September 16, 2013


My immediate thought is that the computer is trying to use a different security protocol than the router. Do you know what protocol the router is using? (WEP, WPA personal/enterprise, WPA2 personal/enterprise) and if WPA/WPA2 whether it's AES/TKIP? The router should tell you if you can log in.

Whatever security it is using needs to be matched when the connection is tested. There should be settings where you can specify this.

The dmesg output doesn't help - it looks like everything is working. I assume this is from when you successfully connected at the coffee shop? We need the output from home where it's broken to troubleshoot.

Try installing wireless-tools (sudo apt-get install wireless-tools). It provides a better connection GUI.
posted by zug at 11:05 AM on September 16, 2013


FWIW I also find that the wireless appindicator/unity toolbar tool is horribly buggy. But using Network from the Dash works fine to turn off the Wireless and turn it back on again. [which is a quick and easy thing to try out].
posted by xqwzts at 2:41 PM on September 16, 2013


Reading a bit on Network Manager's bug tracker, they're aware that they're asking for passwords too often, and already have some improvements for that. But while the popups are annoying, there still is a real underlying issue that the wifi connection dropped. So you wouldn't see this when you sit in a cafe with a strong connection, but if you're home connection is already not that good and somebody else started using the same channel, or anything else interferes, you might just be seeing the effect of that.

At that point, the problem becomes how to improve your signal. Try if setting your router to a different channel improves things, if you have a smartphone there are apps that try to find the optimal channel for you (WifiAnalyzer on Android). Also, many people have seen improvements when disabling n mode on the iwlwifi driver; you can test this by running "sudo rmmod iwlwifi ; sudo modprobe iwlwifi 11n_disable=1"; this did improve things for me (but is not necessary anymore with bleeding edge kernel). You can make this persistent by doing something like "sudo echo options iwlwifi 11n_disable=1 > /etc/modprobe.d/51-disable-iwlwifi-11n.conf".
posted by dhoe at 2:36 AM on September 17, 2013


« Older Advice for first time investor   |   What's the best way to have flowers delivered in... Newer »
This thread is closed to new comments.