Why can I no longer receive iMessages on my iPhone?
May 8, 2013 5:57 PM   Subscribe

As of yesterday I no longer receive iMessages on my iPhone. I get them on my ipad and Mac, however.

I didn't change anything on the phone, but I did use the ipad for the first time in a few months and it required me to set up iMessage again for some reason. I've tried rebooting the phone, logging out of iMessage and signing back in, but nothing works. I can send messages too.

I've even tried logging out on the ipad in case it was consuming the messages for some reason. My wife sent me a message during this time and it eventually arrived on the phone as a text message.

Any ideas?
posted by krunk to Computers & Internet (9 answers total)
 
Try Settings>General>Reset>Reset Network Settings
posted by cnanderson at 6:00 PM on May 8, 2013


Datapoint: Same has been happening to me, also since yesterday.
posted by The Michael The at 6:05 PM on May 8, 2013


The network reset didn't work, alas.
posted by krunk at 6:08 PM on May 8, 2013


This was happening to me for about a week a fortnight or so back. It went away on its own after awhile.

So there's hope if you can't figure out what's happening, but yeah, couldn't ever figure out an explanation.
posted by dismas at 6:14 PM on May 8, 2013


This happened with my wife's iPhone, on Verizon. The problem was an apple/verizon issue. Give your service provider a call.
posted by HuronBob at 7:04 PM on May 8, 2013


Can you send regular text messages, just not iMessages? If so, have you tried the additional keyboard trick? If you don't know what it is, I can explain in more detail.
posted by barnone at 9:50 PM on May 8, 2013


Something similar happened to me before when I got a new iMac.

Go to settings -> messages -> Send & Receive and check if your phone number is selected for the send and receive sections as well as just your appleID email address.
posted by TwoWordReview at 9:50 PM on May 8, 2013


Did you turn off iMessages altogether (not just signing out, but actually turning it off - it's the big slider on top in Messages settings)?

I know it may suck, but if this doesn't work, try resetting all settings. Go to Settings>General>Reset>Reset all Settings. (DO NOT reset all contents and settings - this will erase your phone! Instead, just reset settings.)

This will cause you to lose all personalization (wallpaper, sound settings, etc) but may clear up an internal bug that's causing you this pain with iMessages. Your contacts, photos, music, etc. will be kept. Sometimes weird issues like this can only be solved by resetting settings, and ultimately, worst case scenario, having to restore your phone to factory defaults.

Hope this helps!
posted by dubious_dude at 11:07 PM on May 8, 2013


I don't know if it magically resolved itself or if it was dubious_dude's advice, but I went into the iMessage settings and turned iMessage off and on again, and got a friend to send me a message... and it worked!

Thanks for all the tips.
posted by krunk at 9:05 AM on May 9, 2013


« Older Looking for (non booze) gift ideas to bring to a...   |   My pain in the ass, I mean lower back Newer »
This thread is closed to new comments.