Why is my wireless router so slow, and how can I make it faster?
April 12, 2013 10:06 AM   Subscribe

My Wi-Fi is slow, and it seems to be the fault of the router. How can I make it faster? Barring that, is there a better router I could buy? Details inside.

My wireless router is a Netgear WNR2000 model, and it is slow. When my computer's plugged in to the router by a physical ethernet cable, I have the following results from SpeedTest.com:

12ms ping
14.59 Mbps download
.99 Mbps upload

But over the air, the results are:

20 ms ping
2.62 Mbps download
.97 Mbps upload

I feel like it didn't used to be this slow, but maybe I'm wrong? Is it possible for a router to get slower over time? I've had it for about three years now.

I have checked the channel it's on, and it seems to be the only router in the vicinity on its channel, so I don't think that's creating interference. The router is also about a foot away from the wall, so I don't think that's interfering with it (plus, the speed is the same when my computer's right next to the router).

Is there anything I can do to speed it up? Is this just the maximum speed for this type of router? (my guess is no, given the puported specs from Netgear) Would I be better off buying a different router?

Possibly-relevant details: WEP encryption is being used on the wi-fi, and my computer's a MacBook using an AirPort to receive the signal.
posted by Greg Nog to Computers & Internet (22 answers total) 8 users marked this as a favorite
 
I have checked the channel it's on, and it seems to be the only router in the vicinity on its channel, so I don't think that's creating interference.

Wireless channels overlap, so when you check that you're the only one on your channel, you should also ensure that there aren't a butt-ton of other folks on adjacent channels.

(I doubt this will solve your issue, but it's a thing.)
posted by shakespeherian at 10:14 AM on April 12, 2013


Can you confirm which wireless mode the router is set to? Options are b/g/n, or a combination thereof. It would be best to set this to Only N.
posted by odinsdream at 10:15 AM on April 12, 2013


Wireless should be able to saturate an internet connection without much problem, so something is very wrong.

How far are you from the router? What is the signal strength like? Do you have any smart devices that can connect to this router and how do they do? When you say you are using an AirPort, you mean an AirPort card, right?

Those speeds indicate 802.11b to me (although they are slow even for that). Can you check these settings from your Mac? You should be using 802.11n.
posted by It's Never Lurgi at 10:23 AM on April 12, 2013


Can you confirm which wireless mode the router is set to?

Using the routerlogin.com management page, I can't seem to find anywhere that refers to the b/g/n settings. It does list three different "modes": "up to 54 Mbps," "up to 145 Mbps," and "up to 300 Mbps." Is that mode thing the same as the b/g/n? It's currently set to the Mode "up to 300 Mbps."
posted by Greg Nog at 10:24 AM on April 12, 2013


Yeah, that sounds equivalent to b/g/n. It sounds like you're in "n-only" mode, which is good.

Can you do a speed test between two computers on your network? Copying a file back and forth should give you a ballpark idea without special tools.
posted by odinsdream at 10:31 AM on April 12, 2013


How far are you from the router?

About three feet away, though the distance from the router doesn't seem to make it drop or rise much (it's a reasonably small apartment).

What is the signal strength like?

All them little signal bars are lit up!

Do you have any smart devices that can connect to this router and how do they do?

Not at the moment, but it's just as slow on my ladyfriend's laptop, in general.

When you say you are using an AirPort, you mean an AirPort card, right?

Yep! Airport Extreme, with Supported PHY Modes: 802.11 a/b/g/n

But WAIT: under the airport description in "About This Mac", it says my wifi network is using PHY mode 802.11g!

Could that be the issue? If so, how do I change this to n?

It also says "Security: none", which seems troublesome, as I thought I was using WEP encryption.
posted by Greg Nog at 10:33 AM on April 12, 2013


This is the full list of what it's saying about my network at the moment:

Current Network Information:
PHY Mode: 802.11g
BSSID: 0:24:b2:50:1d:bc
Channel: 6
Country Code: US
Network Type: Infrastructure
Security: None
Signal / Noise: -27 dBm / -90 dBm
Transmit Rate: 11
posted by Greg Nog at 10:34 AM on April 12, 2013


If you're using WEP on the router, and your computer is connecting with NONE, then I think you're using your neighbor's WIFI. When you physically connect your computer to the router via ethernet, and go to http://whatsmyip.org/ do you get a different result from doing that immediately after unplugging the ethernet cable and connecting via wifi?

The BSSID matches netgear, but that's not really a rare brand of routers.

Change the SSID if your router; then reconnect, making sure that security, etc match. While changing your SSID, use WPA or WPA2 ; not WEP.
posted by nobeagle at 10:44 AM on April 12, 2013


I think you're using your neighbor's WIFI.

It seems to be my own! The name of this network is the one that I named it, and the IP address is the same whether I'm using the ethernet cable or wifi.
posted by Greg Nog at 10:47 AM on April 12, 2013


I just ran a similar speedtest comparison on my computer, an old ass Dell, and got substantially the same results via gigabit ethernet versus wireless n. On a $29 Belkin wireless access point.

So I can tell you that you are right, it shouldn't make a difference.

And see why your client is connecting in g mode. Also, the transmit rate of 11 indicates that while it is connected in g mode, it is only transmitting a b speeds. G should give you a transmit rate of 54.

So you probably have a noisy environment. See if you can change the wireless channel on the router to 11 or 1.

Another thing to try is to restart the Mac and see what it connects at right off the bat. It might be connecting at N speeds, and then failing back to lower speeds for some reason. Which would again indicate noise.

The router setting of "up to 300" just indicates that it has all three modes of operation available, not that it is set to N only.


As an aside: You should be using more than WEP, that is old and easily breakable. You should be using WPA or WPA2.

Nobeagle makes a good point: see if the bssid your PC lists matches the mac address printed on your router. If you do whatever apple's version of ifconfig is, you will see your default gateway. Enter that IP into your browser while connected wirelessly and make sure you are connecting to your router. It's probably not likely, but it is possible someone nearby has the same hardware and took the same name to be funny.

A sure test would be to pull the plug on your cable or dsl modem and verify that your clients can no longer see the internet. If they can still see the internet, you are connecting to something else.
posted by gjc at 10:53 AM on April 12, 2013


802.11n compliant devices limit you to 802.11g speeds when using WEP, which is at least part of your problem.
posted by Good Brain at 11:19 AM on April 12, 2013 [2 favorites]


See if there's an option to set the channel to automatic. Most N routers are pretty great at detecting and switching away from interference. Should be on the same page as the "up to 300"(I own a similar netgear router, and upgraded from another similar one).

Also, upgrade the firmware. That solved similar issues to this randomly popping up.

My other suggestion was switching to WPA to enable N, but that's already been covered. Wireless N is, in general, VASTLY better at routing around interference. End of story. Automatic channel and that may end the problem in a s of itself.
posted by emptythought at 11:47 AM on April 12, 2013


Okay, so I just switched to WPA2, and my computer has now apparently switched to n, but it seems to be about the same rate.

The new network info is:

PHY Mode: 802.11n
BSSID: 0:24:b2:50:1d:bc
Channel: 6
Country Code: US
Network Type: Infrastructure
Security: WPA2 Personal
Signal / Noise: -32 dBm / -92 dBm
Transmit Rate: 5

And the new speedtest.com info is:

17 ms ping
3.35 Mbps download
.98 Mbps upload

I'm going to see if I can update the firmware, and perhaps that'll make a difference.

Incidentally, though this problem is not yet solved to my satisfaction, you've all been very nice, and very helpful! Thanks so much!
posted by Greg Nog at 1:04 PM on April 12, 2013


Okay, I just upgraded the firmware, and now:

18 ms ping
3.57 Mbps download
.98 Mbps upload

So, still kinda slow. hm.
posted by Greg Nog at 1:19 PM on April 12, 2013


Oh, and channel is set to automatic, which it also was before.
posted by Greg Nog at 1:21 PM on April 12, 2013


do you live in an apartment building? with lots of other wifi networks? i ask because i recently moved to a new building where i am surrounded by tons of other apartments and buildings, and there are like a kajillion other networks i could connect to. and my wifi is slow as balllls. when i asked my computer nerd friend (you know, the one we all have) he said it was probably because there are too many wifis and not enough channels to spread them all out.

unsure if this is actually an issue or if he just said so that i would stop complaining. perhaps other people can confirm. i tried setting the channel to one that didn't look as populated but then my laptop stopped recognizing my wifi network so finally i was just like screw it, i'll deal with slow internet. but it sucks, and i feel your pain.
posted by kerning at 2:17 PM on April 12, 2013 [1 favorite]


I had the same problem so I asked the tech guy at work. This is my non-techy translation of the reason and the solution that worked for us. Our router has been chugging along just fine but recently slowed downed significantly, probably due to two iPhones, two iPads, two laptops, and a desktop connecting at the speed of whichever device has the slowest capability. Basically, we needed a new router with dual channels. $80 later we are zooming right along.
posted by tamitang at 2:29 PM on April 12, 2013


do you live in an apartment building? with lots of other wifi networks?

I do; there's like 15 other networks listed in my AirPort pane. But it seems like there's gotta be some kind of solution, especially given that my lady's old place had blazing fast internet in like a 100-person building.
posted by Greg Nog at 2:42 PM on April 12, 2013


Greg, can you run something like Inssider? It's really simple to use and it will graphically show you what channels are being overused, and maybe point you to a lesser used channel.

My guess is that channel 6 is being bombarded. Try 11, or if you are willing to throw caution to the wind and your router can handle it, broadcast outside of the specified channels. Sure, your technically breaking the law, but I doubt the FCC is gonna come after you.
posted by Sphinx at 6:07 PM on April 12, 2013


You might be able to do the same thing just with the Macbook's built in wireless connection thing. On some computers, when you want to connect to a network, it shows you the available ones, what their signal strength is and what channels they are on. 1 and 11 are optimal.

If you can't force the router to be in N mode, maybe you can force the clients to only connect in 5ghz mode.

That, or buy a 802.11a WAP. Nobody has those in their houses.
posted by gjc at 7:02 PM on April 12, 2013


Anything in your settings about Wireless QoS (Quality of Service), Wireless Multimedia Extensions (WME), or Wi-Fi Multimedia (WMM)? If so, turn it off!

The idea is that it tries to prioritize and give more bandwidth to video, audio, and other time sensitive data streams. But it does this at the expense of downloads. Speed test sites are basically doing a simple download.

When I have QoS turn on for my router I get speeds at about 5Mbps. But when I turn it off, I'm around 50Mbps!
posted by sbutler at 11:46 PM on April 12, 2013


I bought a new router, after trying various other options, none of which worked. The new router (a Cisco-branded Linksys N600) just gave me wi-fi speeds of:

13.60 Mbps download
.98 Mbps upload

which are pretty close to ethernet-cabled speeds. So: future questioners: buying a new router seemed to be the solution!
posted by Greg Nog at 6:51 PM on May 29, 2013


« Older Use of The City as a metaphor for the Internet/Web   |   Your recommendations for cheap, slim/straight... Newer »
This thread is closed to new comments.