Can I access my mp3s remotely?
September 10, 2005 10:28 AM   Subscribe

Can I access my files on a Window 2000 machine (at home) from my iBook when travelling?

I have a Windows 2000 desktop at home. I store my MP3 collection on it. Usually when doing day-to-day computing, I use my iBook laptop. At home, I can easily access the files on the Win2K box over my local network. However, I do travel from time to time, and I'd like it if I could mount the remote computer as a hard drive when I am away from home (whether across the country or at my university).

Is there any simple way to do this? If it works okay, I'll just tell iTunes that the library is in a new location and then keep it all the time. It'd be nice to be able to move files back to the Win2K machine, too.

I've seen somebody do something similar but they were running Linux, which I am not too proficient with.

I have Win2K Pro, updated to whatever they're at now, on the desktop where the fiels are, and OSX Tiger on the iBook.
posted by synecdoche to Computers & Internet (17 answers total)
 
You'll need to set up your machine as a form of server. There will be two main things required:

1) Select the type of server, be it ftp or streaming audio or Virtual Private Network.

2) establishing a means of identifying your server from others over the net. For that you could simply keep track of the IP address (and hope it doesn't change if it isn't static) or you could run one of the freely available dynamic IP software out there such as dynu or No-IP, or if you already have a domain name registered with your server then just use that.

Good luck.
posted by furtive at 11:24 AM on September 10, 2005


Not sure how you access Windows PC from a Mac, but if it's a similar type of procedure, IE: you navigate to a \\windowspc\mymusic folder and go from there, you might be able to replace the machine's local name with it's external IP, IE: \\xxx.xxx.xxx.xxx\mymusic\ , enter your username and password and play it directly over the interweb. Presuming there are no firewalls in the way and Macs support this networking-over-the-internet type of thing.

Use furtive's method for the dynamic IP hostname.
posted by ed\26h at 12:22 PM on September 10, 2005


Lifehacker just ran two articles that have tackled a similar problem for me (getting documents at school from the home computer): setting up a personal web server and setting up a domain name for your server.
posted by The Bishop of Turkey at 1:16 PM on September 10, 2005


If you're requirements are only to be able to listen to the music (and not be able to access the hard drive/transfer files back and forth). I'd suggest setting up a streaming server using slimserver. It's created by slim devices, who have a piece of hardware that they have for sale to connect to your stereo, but the software is free and doesn't require the hardware to do some really cool stuff.

This will allow you to stream audio (by default over port 9000) to any modern mp3 player (including itunes), and you can control it using a web browser interface. It's actually pretty slick.

If you're looking for a full blown way to transfer files back and forth, the most secure way to do it is probably by installing an ssh server on your windows 2000 box (there's a nice install guide for using freeware cygwin here).

This installs ssh (so you can have command line access to the machine) as well as an sftp server, so you can securely transfer files back and forth.

Then you can use a SFTP client (I'd recommend Filezilla) to transfer files back and forth.

If you want to get really fancy, you can set up something called "port forwarding" with ssh. (nice instructions here, free for individual use, though you could also set this up using cygwin ssh) This allows you to connect to your machine with ssh and use windows file sharing just like you were on the same network as the computer.
posted by freshgroundpepper at 3:14 PM on September 10, 2005


Whoops, I forgot that you've got an iBook as your client, so Filezilla won't work for you (windows only). I know that there are good sftp clients out there for apple, but I'm not familiar with any so can't recommend one.

Your iBook (assuming it's running OSX) will come with ssh by default, so you shouldn't need to install anything extra for basic connectivity between the two.

If you do the last option, you should be able to set up a samba share (If I remember right, it's the "connect to server" option, and then use smb://127.0.0.1/sharename once you have port forwarding set up).
posted by freshgroundpepper at 3:19 PM on September 10, 2005


Thanks for the replies. ssh sounds good.

pepper, if I manage this port forwarding stuff (which I have done with my router and bittorrent, though I am a bit lost with what to do for it here), will this allow me to access the shared drive on the windows machine from OSX as though it were a locally networked drive?

I am downloading cygwin right now, and am trying to figure out what to do from the iBook to get at everything.
posted by synecdoche at 4:21 PM on September 10, 2005


Yep, it should. You'll have to use port forwarding to forward the appropriate ports for windows share (it should be port 139 that you'll have to forward).


So from an apple terminal window, you'll want to test that ssh is working by just typing:

ssh [your machine ip/dns] -l[your win2000 login name]

(you might need to open up port 22 on your router if you have one)

If you can connect successfully, then you should be able to do port forwarding of port 139 using the command:

ssh -L 139:localhost:139 [win200 ip] -l[win2000 username]

Then create an smb share on your ibook using "connect to server" then entering:

smb://127.0.0.1/sharename

Where "sharename" is the name of the shared directory. Using 127.0.0.1 should correct as you're forwarding calls to your local machine (localhost = 127.0.0.1) on port 139 (the smb port) through the ssh tunnel to the windows machine.

This is all from the top of my head, but I believe it's correct. I'm just about to head out the door, but if you run into problems feel free to post a follow up or e-mail me (should be in my profile).
posted by freshgroundpepper at 5:04 PM on September 10, 2005


Thanks for all your help. Things still aren't going my way, though.

The initial ssh command worked without an error, but as I started to browse around (using my limited unix knowledge which consists of ls and cd ..) it appears it hasn't connected me to the remote computer at all, but is instead letting me browse the iBook's hard drive (which I could already do, heh heh). I continued on with the steps, but when I mounted the samba share it was once again just mounting my iBook's drive.

I am wondering what I did wrong. I tried to use the external IP (As reported by whatismyip.com) as well but the connection was refused. I've used my router configuration to forward ports 22 and 139 to the windows machine (I think it worked, at least), but still no luck.
posted by synecdoche at 6:32 PM on September 10, 2005


You might also try this:

http://www.gnu.org/software/gnump3d/download.html

It's meant for exactly what you're trying to do. I've only tried on Mac OS X and Linux, but you can also run it as a service under Windows.
posted by hellomynameisphil at 10:35 PM on September 10, 2005


It mounts the iBook drive? Hmmm....

When you are connecting with ssh, are you using the "port forward" version, where its of the form:

ssh -L139:[win2k local IP]:139 [windows 2k remote IP] -l[win2k logon name]

I did a little testing on my winXP laptop (I don't have access right now to an OSX box, sorry), and was able to get it to work and connect to a win2k box that my work has a cygwin ssh client on. The only change I needed to make from my instructions in my previous message is that it wasn't working properly unless I used the win2k local IP (probably 192.168.1.X) instead of "localhost" in the -L part of the command. An example command would be:

ssh -L 139:192.168.1.104:139 mybox.myhost.com -lsynecdoche

Once this is active and while it's running, any samba commands (which all go through port 139) should be forwarded through the ssh tunnel.

If I remember correctly, on OSX port 139 is a restricted port, so you'll have to be executing the command as the root user (either prefix "sudo" on the command, or type "su -" and log in with the root password at the terminal prompt before issuing the ssh command).

If you use the "-v" option on the ssh command it will give verbose informaton and should let you know when the ssh port is being exercised. That might help you figure out if its connecting properly.

You shouldn't need to open up port 139 on your router (actually this is a bad idea as it's a potential security hole) only port 22 that ssh is running on.

I also did a little searching around and it appears that people have done this successfully on OSX using these commands before (see here, here (under SSH Tunneling: Mac OS X), and here (under Advanced Instructions)
posted by freshgroundpepper at 11:50 PM on September 10, 2005


Oh! I misread your last message, so you're saying that the initial ssh is connecting you to your iBook, rather than to the win2k machine.

Are they both behind the same firewall while you're doing this?

Your firewall should have port 22 (the ssh port) open and pointing at the windows 2k box, not the iBook (as it sounds is happening).

Then you should be able to (from the ibook) execute the test command:

ssh [external network ip] -l[win2k username]

Where the "external network ip" is the ip that's being assigned to your router by your isp (you should be able to log into your routers admin panel and go to "status" to see what the external IP is (depending on the model).

If the test ssh command isn't getting you into the win2k box, the rest of the stuff isn't going to work as we've got somethign screwed up in the basic connectivity.

Make sure that the firewall is pointing port 22 at your win2k box and not your ibook.
posted by freshgroundpepper at 11:59 PM on September 10, 2005


I'm also remembering that I've had some problems in the past when I've had 2 machines inside the same firewall and I try to talk to machine A from machine B while using the external IP. You could try doing the initial ssh command test using the internal IP address of your win2k box and then go to a coffee shop or something and see if you can get in from the outside that way (which is how you'll be accessing it on the road anyway).
posted by freshgroundpepper at 12:07 AM on September 11, 2005


I don't think they are on the same firewall. I haven't done anything with the router firewall, and on the Windows machine I am running Sygate, and on the Mac, the built-in OSX firewall.

When I try to use the external IP, I get this message back:
ssh: connect to host [external ip] port 22: connection refused.

It must be some firewall issue. I tried to open the ports in sygate to see if that helped, but so far nothing.
posted by synecdoche at 9:37 AM on September 11, 2005


Okay, after looking at it, port 22 is open for the router, but it still can't get through at the Windows machine in spite of making a rule to allow it on sygate. Hrm.
posted by synecdoche at 9:59 AM on September 11, 2005


So are you using the external IP (the one assigned to the router) or the internal IP (the one the router is assigning to the win2k machine, you can find it out using "ipconfig" at a windows command prompts) when trying to ssh to the box for the test?

Would it be possible to turn off sygate temporarily just to test to see if it's the problem?
posted by freshgroundpepper at 1:10 PM on September 11, 2005


Sygate doesn't seem to be the problem. I shut it down temporarily and it didn't help. I have tried with both the external IP and the internal one.
posted by synecdoche at 7:10 PM on September 11, 2005


Did you install the cygwin ssh server according to the directions that I referenced in my first message above? (start at #5 if you've downloaded cygwin with ssh, but didn't install the sshd server). Is the "CYGWIN sshd" service "started" in your services control panel?
posted by freshgroundpepper at 12:03 AM on September 12, 2005


« Older Tokyo tattoos   |   How do I gain weight(fat) while remaining healthy? Newer »
This thread is closed to new comments.