Chrome, you are getting on my nerves.
April 4, 2013 7:29 PM   Subscribe

Why has Chrome decided to suddenly space out my bookmarks and context menus so much? How do I return to the proper spacing?

This is driving me absolutely crazy and I am seriously considering a return to Firefox because it is just that annoying. My wife's bookmarks and context menus look like this. My bookmarks and context menus look like this. Mine looks awful and I have to do a lot of scrolling now, even on a 1080p display.

I'm certain my menus didn't look like this yesterday. I haven't installed any new extensions in weeks. How the hell did I do this to my browser, and how do I fix it? I thought maybe it was from ctrl+scrolling to zoom in but I'm not sure.
posted by Sternmeyer to Computers & Internet (24 answers total) 2 users marked this as a favorite
Honestly, I looked at the two pictures and didn't see much difference between them - but I just looked at my own bookmarks just now and the spacing has changed for me too. I wonder if Chrome just did a new update?
posted by EmpressCallipygos at 7:44 PM on April 4, 2013 [1 favorite]

This happened to me about three weeks ago. I hate it too. I have not found a setting or a way to change it. It was like when they changed GMail without giving the option to leave well enough alone. It could be for people who are logged in to CHrome? I am.
posted by JohnnyGunn at 7:50 PM on April 4, 2013

There was a new update for Google Chrome today.
posted by QueenHawkeye at 7:58 PM on April 4, 2013 [2 favorites]

I was going to tell you to go into the flags and change things, but the flags aren't working anymore...

Disclaimer, this may still work, but it also may not.

In the address bar, type about:flags and hit Enter .

Find one called Touch Optimized UI, and set it to Disabled.
posted by deezil at 8:47 PM on April 4, 2013

Just because you haven't installed any new extensions doesn't mean an extension hasn't updated in the background to a new version. I'd try disabling them all and see if that fixes it.
posted by sbutler at 11:57 PM on April 4, 2013

Yup, looks like Chrome updated. I didn't really notice before, but it looks like they did change the bookmark style -- mine looks like yours. And bookmark submenus now overlap their parent. Eugh.

Chrome does automatically update itself (without telling you!), so that's how it got changed.
posted by neckro23 at 12:06 AM on April 5, 2013

Hmm... my Chrome says it is up to date, but I don't see ay change in bookmark menus or submenus.
posted by sbutler at 12:13 AM on April 5, 2013

Find one called Touch Optimized UI, and set it to Disabled.

I have tested this just now; it doesn't work.
posted by EmpressCallipygos at 4:15 AM on April 5, 2013

But I must say I feel tremendously encouraged that Deezil is on the job.

For the OP - there are a lot of angry people discussing this on Google's support forums, so may be worth getting an account and signing in and adding your voice to the people telling Chrome "fuck this noise".
posted by EmpressCallipygos at 4:17 AM on April 5, 2013

Ewww... mine just updated to look like this too. Not happy :(
posted by reptile at 4:40 AM on April 5, 2013

Down in Empress' link, a Google employee links to the following page, which you can star (upper left) to vote for the issue.

(And, yeah, this is a terrible change. Chrome already lacked bookmark separators, but now the UI is really barely usable. Why do UI designers assume we don't want to see as much as possible!?)
posted by Wulfhere at 4:48 AM on April 5, 2013

Best answer: Found a workaround that works for me. Add --disable-new-menu-style to the command line for your chrome.exe shortcut.
posted by reptile at 4:54 AM on April 5, 2013 [8 favorites]

According to the thread Empress linked to, this is an issue trying to optimize the UI for touchscreen usage. This should either detect what you are using, touch or mouse, or be configurable by the user. It is things like this that make me lose more love for Google every day. I HATE that they want to determine what is the best UI for me whether it is in this instance or with GMail etc.
posted by JohnnyGunn at 4:55 AM on April 5, 2013 [1 favorite]

--disable-new-menu-style to the command line for your chrome.exe shortcut

Just tried this, and it works for me, too. Thanks for figuring it out. I have lots of bookmarks that fit just fine on my big screen, and having to suddenly scroll all the time was going to drive me right back to Firefox.
posted by AMyNameIs at 5:28 AM on April 5, 2013 [2 favorites]

Reptile, can you Memail me a "for dummies" walkthrough for how to do that exactly? Thanks.
posted by EmpressCallipygos at 6:01 AM on April 5, 2013

Response by poster: Thanks all, and reptile, you are the king.
posted by Sternmeyer at 6:10 AM on April 5, 2013

Response by poster: You can of course opt to be the queen, should it suit your fancy.
posted by Sternmeyer at 6:14 AM on April 5, 2013 [2 favorites]

EmpressCallipygos, and anyone else that needs it:

1. Right-click the Chrome icon on your desktop/start menu/wherever, and choose Properties
2. You should get a screen like this.
3. Where it says target, add " --disable-new-menu-style" (without the quotes) to the end, after where it says chrome.exe
4. Click Apply, then OK
5. Close down any open Chrome windows, and restart Chrome with your shortcut

Screenshot/instructions above are on Windows 7, other versions of windows should be similar.
posted by reptile at 7:25 AM on April 5, 2013 [5 favorites]

That didn't work for me. Lemme try again.
posted by EmpressCallipygos at 3:01 PM on April 5, 2013

And now it did! perfect.
posted by EmpressCallipygos at 3:04 PM on April 5, 2013

Reptile, THANK YOU! Just tried it and it works perfectly. It was a small issue that was REALLY bugging me.

Sternmeyer thank you for asking the question!
posted by JohnnyGunn at 10:56 PM on April 6, 2013

Thank you Reptile! This had been bugging me, mentioned it to my wife, who in turn mentioned this AskMe thread. Love when Mefites like you solve all my problems.
posted by reader-writer at 4:44 PM on April 7, 2013

One detail for reptile's step 3 above-- if what you see in that field is within double quotes, add the --disable-new-menu-style *outside* of the final double quote.

So much better now...
posted by travertina at 9:09 AM on April 8, 2013

I was using this workaround and now it no longer works. Spaces are back. Any ideas?
posted by JohnnyGunn at 7:40 AM on May 24, 2013

« Older Explain recent Jon Stewart Pope Joke Please   |   Canadian family member transferring car to US... Newer »
This thread is closed to new comments.