How can I improve the quality of my wireless connection?
September 1, 2005 8:41 PM   Subscribe

Wireless troubles- I have a Belkin wireless router at home hooked up to a cable connection. Most of the time the system works great, but every couple of hours (approximately-it's unpredictable) the network will just disappear; no internet connection, and the network is not visible in my internet connect utility. This happens with my Mac Powerbook as well as my wife's PC. The connection returns after a while- maybe 5-10 minutes or so. Sometimes I try unplugging then re-plugging in the cable modem and the router. This seems to work sometimes, but sometimes not. How can I fix this?

Some additional info: I live in downtown Chicago in a high rise building, so I suspect there may be considerable interference. My apartment is not very large so I'm never more than 30 or so feet from the router. Also (maybe irrelevant) I previously had a Linksys wireless router that just plain stopped working. I couldn't even get connectivity via a cable connected to it!

Any suggestions for solving this are appreciated. Could this just be my ISP? Is this par for the course with wireless routers? This is very frustrating and annoying.
posted by jeff-o-matic to Computers & Internet (15 answers total)
 
In the 802.11b days I had a cordless phone that would kill my wireless connection every time it rang. I got a new phone and it worked fine ever since. What you describe is not par for the course; in my current setup I never have any troubles at all both at work and at home. It's either a bum wireless access point or interference. Can you change the transmission channel in the settings? Are there microwaves/cordless phones nearby?

If the wireless goes out (i.e. through some measure of signal strength it goes from full to nothing at all without you moving) it's not your ISP, it's your access point. You can easily test that by plugging your powerbook into the router directly over ethernet the next time the wireless goes out. Internet should still work.
posted by neustile at 8:53 PM on September 1, 2005


Response by poster: There does not seem to be any obvious correlation between the dropped signal and say, the phone ringing/being used, the microwave, etc. I do indeed have a 2.4 Ghz phone located near the router, however. I can't really move either devices, as they are located in a busy home office with very limited space.
posted by jeff-o-matic at 9:20 PM on September 1, 2005


You can change the frequency your router uses so the phone doesn't interfere with it. At least on my linksys, you can. :)
posted by callmejay at 9:39 PM on September 1, 2005


I used to have exactly the same problem with a 2.4 GHz cordless phone...I swapped with my stepfather for an 800 MHz phone, and the problem went away.
posted by Vidiot at 9:50 PM on September 1, 2005


Ihave a 2.4ghz phone, but the same thing happens (and just happened) even when it is not ringing. My isp is a wireless provider that installed an antenna on the roof.
posted by craniac at 9:53 PM on September 1, 2005


You must get 5.8ghz phones... they are not that expensive.. I think I saw some under $50.00

This is must for any wireless network...

Your neghibor's 2.8ghz phone maybe the cause also...

I have Belkin Router and adapter also.. had very same problem... change of phone took care of the problem... but i do notice that when my neghibor's phone rings.. I sometimes have disconnection... but it is not that often so.. its o.k...
posted by curiousleo at 9:54 PM on September 1, 2005


What you describe is not par for the course

Seriously, it's not?? No sarcasm; you've gotten me genuinely curious whether jeff-o-matic's experience is considered abnormal because it's always been mine too. Across 3 different apartments, 3 brands of base station, 3 computers, no microwave or cordless phones in sight (though who knows what the neighbors have), channel set to auto-select. The wifi network constantly has brief interruptions of service. Disappearing for a minute or more at a time, usually several times a day. It comes back when it wants to come back, regardless of what I do and what settings the base station uses.

I've learned to just wait it out, 'cuz most of the time it'll fix itself relatively quickly though it's a nuisance having to re-mount network shares so often.

If none of this is not normal, I'd love to piggyback on this question and ask what an Airport Extreme owner can do it. The AEBS doesn't seem to have any option for changing the frequency.
posted by nakedcodemonkey at 11:25 PM on September 1, 2005


I have a Belkin too, and although I've never nailed it down, my suspicion is that the router does not handle nasty probing from the outside world gracefully. I used to have to power-cycle it every few days, but ever since I went into the firewall config in the router and enabled WAN Ping Blocking it seems to be much better (I rarely reboot it now). With pings blocked, h4xx0rs and network scanners are less likely to think there's a live piece of equipment there and thus less likely to attempt to crack or perturb the box (which usually results in the box freezing/not responding). Also upgrade your firmware if your Belkin has newer firmware available.

I have never noticed any correlation between the unit freezing and wireless phone activity nearby.
posted by ldenneau at 2:05 AM on September 2, 2005


I was having trouble with my wireless network just yesterday. The problem was solved with a change in channel. Our router was apparently interfering with a neighbor's.

For what it's worth, at another wireless setup, I have a 2.whatever (same frequency as the router is using -- whatever that is) Ghz Panasonic phone set that does not interfere with our Belkin router. Go figure.
posted by Dick Paris at 3:06 AM on September 2, 2005


If the phone thing doesn't pan out, I'd suspect the cable modem.
posted by Kirth Gerson at 4:48 AM on September 2, 2005


Firmware, firmware, firmware.
posted by creeront at 6:33 AM on September 2, 2005


Response by poster: Thanks for all the help. I have tried changing the channel on the router, and this did not seem to affect the performance one way or the other. I'm guessing it's either my 2.4 Ghz phone, or one of the many others likely in the vicinity of my apartment. One downside to living in a densely populated area, I guess.
posted by jeff-o-matic at 7:21 AM on September 2, 2005


How many channels did you try? How far away from each other where they? My impression is that there's a lot of bleed through between channels that are very close to each other. Get as much separation as you can.

I moved down to channel 1 because I have neighbors taking up some of the middle channels. I started getting exactly the kinds of dropped signal you're reporting.

I moved up to 11 and don't have any problem at all. I suspect that in my case it probably was a neighbors 2.4 Ghz phone.
posted by willnot at 8:03 AM on September 2, 2005


I would highly recommend setting up a reflector such as the one shown here. I printed out the template on some brochure paper (card stock) and glues some aluminum foil to the back. Works like a charm for my WRT54G. (I used two, one for each antenna)
posted by soundslikeobiwan at 8:50 AM on September 2, 2005


I had the same problem with a Belkin 54g Wireless Gateway router, a new G4 Powerbook and a PC. There was also another Powerbook on my network. The 2.4 GHz phone was a huge problem. It could throw the whole network off in a asecond and it would take hours of re-adjusting and checking to get it working again. However, I bought the 5.8GHz phone but that didn't solve the problem, it just made it less bad. Belkin's tech support are very good--call them and you'll learn a lot. The following are some of their most common suggestions: Try changing the channel of the router (and make sure there aren't other routers in your immediate area that are on the same channel--if so, change it to be as far from their's as possible); clone the MAC address of the lead computer (in the router setup page online) and more than once if necessary; check to make sure you're set for dynamic v. static IP on the router setup; do the whole power cycle on/off and leave all devices (including all computers) off for at least 15 minutes before restarting (and follow the correct order of turning everything on and off); bear in mind with respect to the PC that Linksys wireless cards are hard to use with Belkin routers; AND FINALLY after 8 months of this problem, I realized and got Belkin to admit that their products, in the end, are not really that compatible with Apple computers and it would always be a struggle to hold the network together. They refunded my money (they're a good company) and I bought an AirPort Extreme Base Station and have never had a network problem again. Hope this helps--I lost months wasting time with that network.
posted by Toolshed at 10:38 AM on September 2, 2005


« Older Portuguese translator for Palm OS   |   Do I have to pay for something I bought through... Newer »
This thread is closed to new comments.