Pinning Excel docs to the taskbar doesn't work with Office upgrade
January 26, 2013 4:23 PM   Subscribe

So I upgraded from Microsoft Office Starter 2010 to Microsoft Office 2010. I uninstalled the Office Starter program. Then things went wrong. Please help!

This is Windows 7 Home on a PC.

If I double click an Excel file it opens dutifully in Office 2010.

If I drag the same icon to the taskbar so that it's available to open from there it shows "Pin To Office Starter 2010" and a shortcut to Excel Starter is added to the taskbar. If I right click on that link to get to the list of documents pinned to that taskbar icon it lists the program as Microsoft Excel Starter 2010 but if I choose my recently added document from that same list it opens in Excel 2010 (not Starter) This is good.

If I then click the Excel icon on the taskbar to open Excel, I get a message that says "Click-2-Run Configuration Failure" which suggests that the icon is looking for the starter version which is uninstalled. This is bad.

If I pin Excel 2010 to the taskbar and then try to drag the document onto that icon it shows "Pin To Microsoft Excel 2010" but then doesn't show up in the shortcut list when I right click the Excel icon. Right clicking on this icon however shows that it is the correct version of Excel (not Starter) and clicking on the Excel icon on the taskbar opens Excel normally.

Errr Help? How do I get a working Excel icon on my taskbar that'll both open my installed Excel program when clicked and show my shortcuts to individual documents when right clicked?
posted by merocet to Computers & Internet (3 answers total)
This thread seems to address similar problems to yours. The keyword you want to be searching on is "jump list" - that's the list of spreadsheets you get when right-clicking. So, for example, you'd search on "broken jump lists after upgrading from Starter to full Office."

Hopefully this helps. Sorry 'bout that.
posted by kthxbi at 8:51 PM on January 26, 2013

I would also check what your default applications are for xl file types. You can go here to learn how to do that. Specifically, you want the "associate a file type or protocol with a program" part.
posted by kthxbi at 8:54 PM on January 26, 2013 [1 favorite]

Thanks kthxbi, one of the first things I did was check the default applications for xl files. It does look like that link you found is likely an answer (if a bit of a long convoluted one!) I'll report back when I get brave enough to try hacking my way through the registry as suggested.

Thanks a lot
posted by merocet at 7:00 AM on January 27, 2013

« Older Housecleaning in Beaverton   |   Diodes, transistors, resistors, oh my! Newer »
This thread is closed to new comments.