router
August 23, 2005 4:43 PM   Subscribe

New laptop running Windows XP SP2; can't connect to my desktop PC's wifi router. Any reason why?

It detects the router within range, but when I try to connect, it stops at the "Detecting network type" step with a simple error saying that it's unable to connect to the selected network. I'm sorry I can't provide much more detail, but I really have no clue what the problem possibly could be. I'm sure it's something incredibly obvious that I just don't know about.
posted by jimmy to Computers & Internet (19 answers total) 1 user marked this as a favorite
 
Router is a Netgear WGT624.
posted by jimmy at 4:51 PM on August 23, 2005


Have you tried turning off DHCP in your laptop and using a static IP?
posted by evariste at 5:00 PM on August 23, 2005


No. Sorry, how would I go about doing that?
posted by jimmy at 5:02 PM on August 23, 2005


I'm no techy, but when I have similar problems, sometimes unplugging the modem and router, and turning everything on in the correct order works for me.
posted by Mroz at 5:04 PM on August 23, 2005


From here:
If a computer's wireless adapter does not support 108 Mbps, the SSID of a 108 Mbps mode router will not show in the Available Network list. Using a 108 Mbps wireless adapter such as the WG511T, the router will display.
are you using some integrated wifi chipset, or a wireless card? If a wireless card, which one? Have you tried switching the router to normal speed and seeing if that lets your laptop connect?
posted by evariste at 5:05 PM on August 23, 2005


Broadcom 802.11b/g WLAN. The router shows up in my Available Network list, I just can't connect to it.
posted by jimmy at 5:07 PM on August 23, 2005


It could be a firewall problem...
either XP's Firewall or ZoneAlarm... Turn it off and see what happens...
Also UnPP could be the cause.... you may want to go to control panel... add/remove program... remove XP component .. choose UnPP.. remove it and see.....
posted by curiousleo at 5:11 PM on August 23, 2005


Stupid question, but I gotta ask -- do you have encryption/security set up? If so, have you set the right authentication credentials on the new machine?
posted by TonyRobots at 5:11 PM on August 23, 2005


How to turn off DHCP in your laptop:

1. connect to your router's admin interface from your desktop computer, and find out the range of IP addresses it's using for DHCP. You want something outside this range (either before it or after it).

So if your router's using 192.168.1.50 thru 192.168.0.150 (for instance), you'll want anything from 192.168.0.2 thru 192.168.0.49, or anything from 192.168.0.151 thru 192.168.0.255.

Don't know how to connect to your router's admin interface? Luckily this default passwords page tells you: put 192.168.0.1 in your browser's address bar, and when it asks for user/password, use admin and password.

2. open Control Panel -> Network Connections, on your laptop. Right click your wireless connection and click properties. Now click "Internet Protocol (TCP/IP)", and click properties. Change it to use the IP address you just chose. The default subnet is usually 255.255.255.0 and the default gateway means your router's IP address, which according to what I just looked up is 192.168.0.1.
posted by evariste at 5:13 PM on August 23, 2005


OK, that worked. Thanks a lot, evariste.
posted by jimmy at 5:18 PM on August 23, 2005


While you're messing with your TCP/IP settings, it's a good idea not to use your ISP's DNS servers too. Try 4.2.2.1 and 4.2.2.2 for those, they're more reliable and speedy than most crappy ISP DNS.
posted by evariste at 5:19 PM on August 23, 2005


Sweet! :-)
posted by evariste at 5:20 PM on August 23, 2005


Be ready to turn DHCP back on if you use your laptop on any other networks.

You should put the ip address from evariste's solution in the "alternate configuration" tab in the "Internet Protocol (TCP/IP)" properties window. Then it will only use that address when it needs it.
posted by tresbizzare at 5:28 PM on August 23, 2005


I normally try to stick to the question asked, but I feel the need to step in and counteract what evariste advised -- don't use random DNS servers! (Not to mention that I find it pretty random for someone to state that ISPs mostly have crappy DNS servers running; that's certainly not been my experience.)

The number of hostname lookups your machine has to do during a regular session of surfing the web is generally pretty high, and sending those lookups out over the internet at large is a silly waste of bandwidth (and of your time, since querying a DNS server a dozen or two hops away from you is usually much slower than querying one on your ISP's network). Use your ISP's DNS servers; that's what they're there for. And if your ISP's DNS servers suck, you should look into finding a new ISP; if that isn't an option, only then seek out other DNS solutions, but do so knowing what your ISP's connections to the internet at large are, and find DNS servers that are as local to you as possible. (For reference, both 4.2.2.1 and 4.2.2.2 are located on the BBN Genuity Level 3 network in Providence, RI; if you're in California and choose to use these DNS servers, you're making your life harder for no reason at all.
posted by delfuego at 7:13 PM on August 23, 2005


You may run into problems with windows xp's built in wireless thingy. If your wireless adaptor comes with its own connection software, try disabling the Wireless Zero Configuration service and using the adaptor's software.
posted by philscience at 7:58 PM on August 23, 2005


One follow-up question, in line with what TonyRobots was thinking about. Did you know how to log in to your wireless router's admin interface, or did you follow Evarista's suggested IP address and user/pass?

If you did log in using the default IP address and password, I would recommend that you read up a bit on securing your wireless network by changing the password for the router, turning off SSID broadcasting, and enabling some sort of encryption.

If you have questions on how to do that, post again. It's a good idea to do so, if you haven't already.
posted by gemmy at 8:04 PM on August 23, 2005


What I am thinking here, is why should this person need to switch their configuration settings around for the router. It would be smoother in the long run to set up the router to be able to give all wifi devices a non static IP address, don't you think?
posted by Dean Keaton at 11:53 PM on August 23, 2005


delfuego-great point about # of hops, which I didn't think about. I first found myself ditching my ISP's DNS when it went down every day for a week, infuriatingly. In the course of Googling about this, I found out that a lot of others recommended Level3's DNS, which is why I started using them. I haven't experienced any subjective slowdowns, and I feel safe from Bellsouth's abysmal service, so it works for me. Still, what you say makes sense. Maybe I should look into a different ISP.

Dean Keaton-a lot of wifi routers have buggy DHCP implementations, in my experience, which is why turning off DHCP was the first thing that occurred to me.
posted by evariste at 2:15 AM on August 24, 2005


Thanks, evariste, that's really useful. *bookmarks*
posted by corvine at 4:44 AM on August 24, 2005


« Older How do I protect myself and my apartment?   |   Newbie wants to learn about Danish Modern... Newer »
This thread is closed to new comments.