Google calendar sync help
November 28, 2012 8:34 AM   Subscribe

Google calendar idiot here. How do I sync iPhone to google calendar, not the other way around and why is someone else's calendar appearing in my google calendar online?

1: So I've never bothered to use google calendar via my gmail account - I always just plug events into my iPhone. But now I need to use it via gmail - how do I sync them without losing the two years of calendar I have on my iPhone?

2: But when I am in gmail, and click on calendar - there's already another calendar in use there. My email is This calendar email is I also often get emails meant for this latter account. I thought that periods were irrelevant in gmail addresses, but apparently not.

Long story short: How do I get rid of this other calendar and then sync my gmail and iPhone calendar without losing data on my iPhone? Thanks!
posted by meerkatty to Computers & Internet (6 answers total) 3 users marked this as a favorite
Can't help with (1), but dots really are irrelevant in gmail addresses, which makes (2) expected behavior; I don't see how you get to "apparently not".
posted by flabdablet at 8:48 AM on November 28, 2012 [2 favorites]

Yeah, dots are irrelevant. Send an email to to test this. You are probably seeing the default calendar.
posted by desjardins at 8:55 AM on November 28, 2012

Best answer: re: #1 - on your phone, go to settings > mail, contacts, calendars and scroll down to calendar. Click on Sync and choose whatever you're comfortable with (say, Events 2 Weeks Back). Then when you sync to Google, only those will be synced and the rest should remain on your phone (all of them should actually). If you're still scared, make sure to back your calendar up to iCloud (settings > mail, contacts, calendars > iCloud).
posted by desjardins at 9:02 AM on November 28, 2012

Response by poster: Good tip desjardiins - thanks. What does the default calendar look like? Right now they are all events created by one of three different email addresses that I cannot adjust or delete.
posted by meerkatty at 9:25 AM on November 28, 2012

Best answer: If you go to Google Calendar settings (the gear icon at the top right, then the Calendars tab), the first one listed will be the default. It has a grayed out checkbox under the Show in List column. Can you delete the other calendars that appear? Did you accidentally subscribe to someone else's public events? In that case, they'll be under "other calendars" at the bottom of that settings page. For example, I'm subscribed to a sports team's schedule and US Holidays.
posted by desjardins at 9:46 AM on November 28, 2012

Events that belong to other people's calendars show up in different colors to yours, too.
posted by flabdablet at 6:21 AM on November 30, 2012

« Older Wayback Machine isn't far enough   |   Political affiliations of MPs Newer »
This thread is closed to new comments.