I've locked my keys in my hard drive
October 16, 2012 1:33 PM   Subscribe

I've locked myself out of my external hard drive! Halp!

Win7 laptop with a usb external drive. I was starting to consolidate several hard drives onto a single 2TB drive, as well as setting up SMB access for my Boxee Box. Somehow, I managed to change the security access on an external drive such that no one can access it. I can't seem to take back permission as my primary login (an admin account), the admin group, or the account I created for Boxee. Those are the only accounts.

I tried the registry hack that adds "take ownership" to the context menu, but that only works for directories, not at the root level of a drive.
posted by bluejayway to Computers & Internet (6 answers total)
 
What version of Windows 7 are you using? If you're on Pro, Enterprise, or Ultimate you don't really need to use the registry hack. You can right-click on the drive directly and modify ownership via "properties/security tab/advanced/owner" and then have it apply recursively.

If you're on a more basic version of windows, you might be able to use takeown/cacls/icacls from a command prompt.
posted by samsara at 1:45 PM on October 16, 2012


I have Home premium. Properties//security/advanced/owner shows: Unable to display current owner, and gives me an option to change the owner. When I do that, I get a pop-up error saying: Unable to set new owner. Access is denied.
posted by bluejayway at 1:51 PM on October 16, 2012


See if the following command works:
icacls drive-letter /grant administrators:F

You can also type:
icacls drive-letter

This will display a report of what it thinks the permissions are for the drive.

If the problem persists, see if safe mode produces different results (or another computer). See if you can also check the disk for any errors.
posted by samsara at 1:56 PM on October 16, 2012


Thanks, but that didn't work either. "Successfully processed 0 files; failed processing 1 file.
icacls 'drive letter' just says "Access Denied"
posted by bluejayway at 2:12 PM on October 16, 2012


You need to enable the administrator account and then log in as that, not just using an account in the administrator's group.
posted by mhoye at 2:22 PM on October 16, 2012


I got the administrator account to make it work. I'm not sure what happened, but it appears that whatever it was the drive is also failing. The administrator trick and a few minutes in the freezer seems to have helped. I'm copying over everything now, and hoping for the best. Thank you all!
posted by bluejayway at 3:12 PM on October 16, 2012 [2 favorites]


« Older Can you help me think of creepy clown tricks?   |   Roommate's GF has effectively moved in... what to... Newer »
This thread is closed to new comments.