usb drive not recognized
August 16, 2005 3:44 PM   Subscribe

I have a Kingston USB drive that I cannot access from my work machine, it functions fine on other machines.

The machine is XP pro. In device manager a USB mass storage device shows up and is said to be working properly. I have disabled and enabled. I have uninstalled. I have booted machine with the drive in place. I have tried to update the driver, window says that the one I have is best. I have booted in safe mode. I have had no success. when I double click on my computer the drive does not show up and when I have a file open that drive is not listed as an option to save to. help please
posted by busboy789 to Computers & Internet (9 answers total) 2 users marked this as a favorite
Response by poster: oh, a bit more... I am able to log in at my machine with a different login and have access to the drive, but I don't have access to my files on the network. My login is listed as an administrator if this means anything.
posted by busboy789 at 3:47 PM on August 16, 2005

Best answer: I had a similar problem. It is listed as drive G, but the machine is already using drive G. You need to rename the USB drive.

Control Panel: Administrative Tools: Computer Management: Disk Management: find the USB drive and rename it.
posted by Classic Diner at 4:33 PM on August 16, 2005

Best answer: I would guess this is a neat glitch in XP seeing as you mentioned network drives. For whatever reason, XP doesn't seem to recognize network drives in the 'hunt order' when it assigns a drive letter to a USB flashdrive. Therefore you end up with two drives with the 'same' letter and Windows just appears to ignore which ever one showed up last. try going into the 'Disk Management' section of the control panel and manually assigning a different drive letter to the flash drive by right-clicking on the drive name and choosing that option. I'm not in front of a windows PC right now but the easiest way i've found to poke about at the windows settings is to right-click on the 'My Computer' icon and choose 'Manage'.
this one drove me batty the first time i ran across it, thankfully windows seems to remember (mostly) what letter you assigned to that flash drive then next time you try to use it.
posted by skatz at 4:36 PM on August 16, 2005

Also, if your computer is "managed" (ie, there is an IT department or "guy") and you're in a Windows Active Directory (or even not), the mounting of USB drives could be disabled via group policy.

Note: This requires a pretty competent IT person or department.
posted by chota at 4:55 PM on August 16, 2005

Best answer: I'm having a deja vu. USB not recognized on XP... I just answered a question exactly like that earlier today, or maybe yesterday, I didn't sleep: try if this works for you too
posted by easternblot at 5:43 PM on August 16, 2005

Obviously, where it says "iPod", replace with "Kingston USB drive"
posted by easternblot at 5:44 PM on August 16, 2005

I have to agree with the guess that the machine has been locked down. There are lots of corporate CIOs that are worried these days about employees taking home data (on accident or on purpose) and I believe this was a heavily requested feature of Windows - the ability for the admin to not allow external/removable storage devices to be mounted.
posted by Rhomboid at 8:04 PM on August 16, 2005

I'll vote with Classic Diner - I ran into the same problem with a USB card reader. Connected to my work machine it didn't appear unless I pulled the network connection and rebooted. The card reader wanted to be drive X but X already was an assigned network drive.
posted by skyscraper at 10:20 PM on August 16, 2005

Response by poster: many thanks!! it worked like a charm. behold the power of askmetafilter
posted by busboy789 at 5:24 AM on August 17, 2005

« Older Who has a clue?   |   Is it my camcorder, or me? Newer »
This thread is closed to new comments.