My Mac Mini wants to be an extreme right winger
July 11, 2012 8:07 PM   Subscribe

Please help me diagnose an annoying issue with the sound output in my Mac Mini. Upon every system bootup, the sound output manages to set itself 100% to the right channel. So far, I've not managed to find any search results for this issue. It's a simple fix to move the balance slider to the middle, but I shouldn't have to do this every time I turn on the bleedin' thing.

So, system details: 2010 era Mac Mini, OS X 10.7.4. Sound is usually set to output to my 27" Apple Cinema display, but also can be sent through HDMI to the connected TV (which actually goes through an HDMI speaker bar). I noticed this happening a few weeks ago, but can't pinpoint if a system update caused it. Any ideas? Thanks!
posted by Burhanistan to Computers & Internet (8 answers total) 3 users marked this as a favorite
If you don't find the cause, you could put this AppleScript in your login items list (System Preferences > Users & Groups). Then, on login, the balance is centered.
posted by Blazecock Pileon at 8:17 PM on July 11, 2012 [2 favorites]

Looking around it seems like this is similar to a known pre-10.5 OS X issue. No idea why it's happening, but if you want you can hack a fix - I found a post on a forum suggesting an applescript to center the balance:

Applescript here

If you make an application out of it, then put the application on the startup list, it should automatically center your balance after startup.
posted by Salvor Hardin at 8:18 PM on July 11, 2012

Here's a compiled app equivalent of the script I posted.
posted by Blazecock Pileon at 8:19 PM on July 11, 2012

This thread points to a couple of prefs files that contain initial audio settings. It looks like Audio/ maps your user number to some device-settings names, and Audio/ holds those, including volume levels. It should be safe to delete both of those and let the system re-create them with default contents, I think.
posted by hattifattener at 8:31 PM on July 11, 2012

(Oh, and you can look at them with a command like defaults read /Library/Preferences/Audio/ (no .plist extension for that command), or analogously for SystemSettings. The format of the contents is not especially human-friendly though.)
posted by hattifattener at 8:34 PM on July 11, 2012

This sometimes happens to me on my laptop. Do you by any chance run Soundflower?
posted by zippy at 9:04 PM on July 11, 2012

Sorry if this is outdated advice, but have you tried re-setting the PRAM? This is always my go-to move for odd monitor/sound/networking/mojo issues on my Macs. The Mac PRAM holds a lot of environmental settings, and it's possible for it to become corrupt or just...wrong. Might be worth a try.
posted by mosk at 9:37 PM on July 11, 2012

Update: Actually, nothing here worked, sorry. Something pernicious kept moving that damned slider all the way to the right, no matter what. After some more extensive googling it seems that this is an issue that many have that never really got addressed by Apple.

However, upgrading to Mountain Lion seems to have fixed it. So, um...ok.

Thanks for your time, though! These little things can be maddening.
posted by Burhanistan at 2:46 PM on August 1, 2012

« Older Not having much sex - is this bad?   |   Sitting on a gold mine Newer »
This thread is closed to new comments.