Why does Mac Pro get half the wifi speed of MacBook Air?
January 27, 2012 1:40 PM   Subscribe

Why does my Mac Pro (desktop) get half the the wireless Internet speed of my MacBook Air, on the same network?

Both computers are using wifi over the same network (coming from wireless Verizon router using DSL).

Both computers are located in the same location (actually I have the MacBook Air sitting directly on top of the Mac Pro).

According to speedtest.net...

- Mac Pro gets 2.63 Mbps
- MacBook Air gets 6.20 Mbps

It's really annoying because the Mac Pro is my primary machine and slows down or times out on major sites (Twitter, NYT, even Mefi). Seems to come in waves - sometimes the Pro is perfectly zippy online, and other times it slows to a crawl.

I found other AskMeFi threads on speed - 1, 2, 3 - but still can't figure out why two machines with the same setup would get such different results.

If it helps, Mac Pro is running OSX Lion 10.7.2... while the MacBook Air is running 10.6.8. Otherwise I can't think of any significant differences between the two machines: same network, same distance from the router, same speedtest on the same browser.

Thanks for any help...
posted by mark7570 to Computers & Internet (13 answers total) 8 users marked this as a favorite
 
Do you have an external antenna for the Mac Pro? The case is significantly thicker than the shell of the Air.

I didn't install an Airport card in my Mac Pro for precisely this reason...
posted by Admiral Haddock at 1:48 PM on January 27, 2012


How many antennas does your Mac Pro have? Your MBA may have 2, while your Mac Pro may only have one.

Also, if you option-click on the airport icon in the menu bar, what does the greyish extended info text say about your connection on each machine?
posted by strangecargo at 1:58 PM on January 27, 2012


Do they both use the same wireless standard? ("N", "G", "B", or "A")

What direction is the antenna pointing? (It should be pointing up.)

Beyond that, you'd need to run whatever OSX's version of ifconfig is and see if there are packet losses and retransmits and whatnot.
posted by gjc at 2:00 PM on January 27, 2012 [1 favorite]


Another thing to check is what channel each is on. It sounds ridiculous, but in my apartment complex the usual "automatic" channels for 802.11g (1,6,13) are massively overused. I found that I could switch to channel 9 or 3 and double my speed easily. (I eventually bought a newer, more powerful wireless router and now it's not as important.)

Note: You'd think most routers would be smart enough when Channel is set to "Auto" to use the least used channel, but many I've used just randomly pick between 1, 6, and 13.
posted by Fortran at 3:07 PM on January 27, 2012 [1 favorite]


How old are they/what are the serial numbers? Like gjc, I'm willing to bet they have different speed Airport cards. Check by running System Profiler ( logo upper left corner, About This Mac, More Info) and seeing what's reported in the Network section.

For as equal a comparison as possible, make sure both computers are running the same version of Flash. But they have different antennas, so any comparison is going to be flawed
posted by now i'm piste at 4:07 PM on January 27, 2012


MacBooks/Airs/Pros have either one, two, or — if they're very recent — three antennas. Each of these adds another 150mbps to the speed of their wireless connection. Now, this shouldn't affect your internet speed, and may have nothing to do with it, but the wireless reception on Mac Pros is notoriously sucky. What wireless router are you using?
posted by jaffacakerhubarb at 4:18 PM on January 27, 2012


In general laptops have excellent wifi reception because of the antenna design (often wrapped along the edges of the screen). Desktops need to make more compromises. Based on the horror stories I've heard about Mac Pro bluetooth reception, their case design may be particularly challenging for wireless signals.
posted by The Lamplighter at 5:10 PM on January 27, 2012


Hi! My sympathies, network (especially wireless) problems are the worst to troubleshoot. But let's take a crack anyways.

0 - Have you power-cycled your router and modem? I'm sure you have, because everyone in the world told you to when you asked them about this problem, but for the hell of it just do it again real quick before we start. Leave them both unplugged for a minute or two before plugging either in again. Just so we can say we've tried that. Plug the modem in first and wait a minute before you plug in the router.

1 - Do you have one of these sticking out of the back of your Mac Pro's chassis? If not, you will need one there or wireless is always going to be what technicians refer to as "horrible dogshit". If you don't, then you need to get that antenna piece — or, preferably, switch to Ethernet. Assuming your Mac Pro isn't moving around a whole lot, it'll probably make your life easier.

2 - Are you dropping packets between the Pro and the router? If you're not sure how to check, try this:
... 2a - visit your top-leftmost  menu from the menubar, and choose "System Preferences", then "Network" (right there in the middle, with the grey globe)
... 2b - select Wi-Fi from the list of interfaces on the left and click the "Advanced" button in the bottom-right, then choose the "TCP/IP" tab from across the top of the window
... 2c - note (or select and copy) the IP address next to "Router:"
... 2d - open Network Utility, either from Spotlight or by visiting Macintosh HD/Applications/Utilities/ and finding it there. Hit the "Ping" tab in Network Utility
... 2e - stick the IP address of your Router in there and make it ping, say, 40 times
... 2f - once that finishes, do you see anything anomalous? Anything over 0.0% packet loss might be a problem, or more than one or two pings with a "time" =5+ milliseconds

3 - Since you're already here in Network Utility, are you dropping packets on outbound traffic? Try replacing your router's IP address with "www.google.com" and see if you're getting any packet loss.

4 - Does it happen under other user accounts? If you're like me, you might have more stuff installed/running than you can 100% keep track of, but this can be a good way to isolate that. If you don't already have "Guest" login enabled, it's a pretty good troubleshooting tool. (It's a totally vanilla user account that's built from scratch each time you log into it and totally deleted each time you log out of it.) Anyways, visit System Preferences and hit "Users and Groups" (first one on the left under "System"), unlock the pane (lock icon in the bottom-left), select the Guest user from the left column and check "Allow guests to log into this computer". Then log out (hit ⌘-⇧-Q – or else choose"Log Out Name" from the  menu) and log in as the Guest. See if that makes a difference, maybe have another run at speedtest.net, although note that lots of factors can influence your number there. If this solves it, it's time to get cracking on what network-active applications or other processes are running on your main account.

5 - Failing all of that, here's a good way to test your machine with a "fresh" set of network settings/caches/whatever without permanently losing any custom network settings. In System Preferences, go again to "Network" and hit the pop-up menu at the top for "Location". A "Location" in this parlance is just a saved group of network settings. So we're able to both not fuck with anything and also get a fresh start, choose "Edit Locations..." then hit the [+] in the corner of the sheet and name your new location "Test" or something. Hit "Done" and it'll be chosen, but you still have to hit "Apply" in the bottom-right of your System Preferences window. This way you're operating with a new, unmolested set of network settings. If this fixes it, I say roll with it. If not, you can roll back by choosing "Automatic" or whatever was originally selected from the "Location" pop-up.

It's a sonofabitch because there's so many environmental/uncontrollable factors that go into wireless networking that it's impossible to control for just one. If you want to memail me with your Pro's serial number I can check its warranty status, and see if there happens to be any bulletins on wireless issues for your model – though I'd be surprised.

Worst comes to worst, you can always lug the thing to another place with another network and compare it to your Air there, or lug it to your Genius Bar and have them run AST against it, and go from there.

Cheers and good luck!
posted by churl at 11:31 PM on January 27, 2012 [136 favorites]


Those haven't been used since the early PowerMac G5s. The antenna on Mac Pros are built in, using a long plastic bit on the bottom of the case. Reception is fine; nothing extra is needed.
posted by los pantalones del muerte at 8:19 PM on January 29, 2012 [2 favorites]


You're right, of course. My mistake.
posted by churl at 8:34 PM on January 29, 2012 [1 favorite]


In some older Mac Pros (circa 2006-7), there was a common manufacturing defect where the connection that was supposed to go to the Wifi antenna went to the bluetooth antenna, and vice versa, resulting in poor performance for both bluetooth and Wifi.

I had this problem, and I found instructions on the web for swapping the wires back to where they were supposed to go, and it made a big difference. Instructions are here.
posted by yankeefog at 9:15 AM on February 1, 2012


Also get a Windows laptop from somewhere, put InSSIDer on it, and find a channel that all the neighbours aren't using.
posted by GallonOfAlan at 12:16 PM on February 7, 2012


> Also get a Windows laptop from somewhere, put InSSIDer on it, and find a channel that all the neighbours aren't using.

For this you could also use a Mac tool like iStumbler.
posted by churl at 6:23 PM on February 7, 2012


« Older What to do [next] Friday night in Charlotte, NC?   |   My house is growing cold, please hope me! Newer »
This thread is closed to new comments.