How do I disable the media buttons on my Dell Studio XPS 1645
January 20, 2012 12:41 PM   Subscribe

How do I disable the media buttons on my Dell Studio XPS 1645 notebook?

I spilled soymilk on my laptop, and dried it with a blow dryer. Everything is now working fine except for the media buttons on the top/front of the keyboard frequently go on and off, or get stuck flickering back and forth between on and off. These buttons include the wifi key, eject key, volume keys etc...

I want to completely disable these. I went to bios as recommended by some websites, but that supposedly only works for wifi, and didn't even do that for me!

I have tried some random website guides that didn't work...

I un-installed quickset, but all that did was prevent the icons from displaying on the screen when I click it.

How can I completely disable the Media buttons???

(this is especially bad for me because I play internet poker professionally, and I just lost a 200 dollar hand because my wifi got switched off all the sudden)
posted by crawltopslow to Computers & Internet (7 answers total)
On my Asus computers, there's a helper app which loads at boot time and stays in the background, which controls those keys. If you find that app and remove it, the keys no longer do anything useful.

The easiest way to find and remove it is with "Autoruns". But be careful: you can royally screw up your computer if you get rid of something else which isn't dispensible.
posted by Chocolate Pickle at 1:30 PM on January 20, 2012

Apologies if you tried this already, but this is what you have to do for my Dell Studio 1555:

1. go into the bios
2. go to the "advanced" page
3. on the "function key behavior" item, change "multimedia key first" to "function key first"

This will make it so that so you you have to press the "Fn" key in conjunction with the multimedia keys to use them for their multimedia functions.

This could actually make your problem worse, however, since it may mean that it's F1-F12 that are on the fritz instead of the multimedia keys.

You may also have luck with AutoHotkey, which should be able to grab (and disable, if you set it right) the keystrokes before they screw things up.

Your other option would be to try cleaning the keyboard out. Which takes a bit of work.
posted by ropeladder at 1:38 PM on January 20, 2012

I've got a couple of Latitudes so I don't know how relevant this advice will be, especially as I was unable to pinpoint the part I expect your computer has that will be operating the extra multimedia keys. But, with that in mind:

You will need to be comfortable opening up your laptop. If you are slow and methodical with it, this procedure isn't very hard or dangerous to your machine's health. Take notes or pictures with a digital camera when removing screws/parts if this will help re-assembly later.

This is the service manual for the Dell Studio XPS 164x series of laptop computers. Judging by pictures of the machine and this schematic, the multimedia keys are a separate entity to the keyboard but are attached to the same interface via the SMBus.

The service manual does not show if, like my Latitudes, the keys are mounted to a thin bezel that can be prized up and away from the machine. On my D620 to the right there is small indentation that a small flathead screwdriver can be used to pop this bezel up and out, exposing the multimedia button assembly and screen hinges. As the service manual does not show any close-ups of this part of the machine you will have to have a good look to see if this part is either removable or you are able to get access to the rear of it where the key module is located.

Going back to my D620, my power button is also mounted with the multimedia keys, so disabling these keys may be more permanent/destructive than simply disconnecting a cable as you'll want the power button to still work afterwards.

If your machine has a bezel to remove or you've been able to get to the rear of the key assembly another way, take a look at how the keys are connected to the rest of the computer. It is likely to be a ribbon cable or a thin wire with a plastic connector on the end. If it is a ribbon cable, there will likely be a plastic lock holding it on to the mainboard. Carefully disconnect this cable. If you are brave (foolhardy?) enough, you might want to try powering on the machine in this state to see if the power button still functions if it is close by, and then to see if the spurious key-press events have stopped. If all is well, tuck the cable away and re-assemble. You're done!

If the power button is contained within the same assembly, you're going to have to do a little surgery. It is unlikely the power function is multiplexed with the rest of the keys, so cutting part of the cable that carries the multimedia key-press signals will disable them without stopping you from powering up the machine. Obviously, this method is more likely to be permanent and more fraught with the possibly of screwing something up that stops you from being able to use the computer entirely. If this sort of surgery is necessary, I'd bust out a multimeter to test signalling before making any cuts.

Of course, if it is possible to get to the multimedia key module in the way I've described, you may want to try cleaning it up some more to see if you can return it to working order.

Finally, as your income depends on this machine functioning properly (and as a fixer, it really pains me to suggest this!), you may want to investigate the purchase of a new machine anyway - it sounds like it would only take a short amount of time before the cost of a new computer (or new to you - I don't think you'd need the latest all-singing and dancing machine to play poker on) is overshadowed by losses incurred by your current machine's malfunction.

Sorry that so much of my advice is "try it and see", but judicious use of Google isn't giving me any hard and fast information about how these keys are attached, but I hope it is of use to you.
posted by NordyneDefenceDynamics at 2:19 PM on January 20, 2012

rope ladder, I have attached a screenshot of my bios screen, I don't think I have "function key behavior". is my screen shot

NordyneDefenceDynamics: thanks i'll try that as my last resort, but I feel bad buying a new computer since i bought this once 1 month ago..

A software fix would be ideal.. so far nothing is working..
posted by crawltopslow at 2:36 PM on January 20, 2012

Yeah, I don't see anything in that bios menu that looks like it would help. I'd look through the rest of the bios for anything mentioning function keys.

Did you buy the computer new, then? If you got it second hand, you could try updating the bios, but if it's new, then that option is probably gone for good.

Here's another thing to try: (found in this manual, section 1 page 38) On my computer if I open "Windows Mobility Center" using [windows key]+X, it brings up a menu that has the same functionality as the multimedia keys. If you "launch" "radio control options", you can uncheck the box that says "Use the wireless switch to control the following radios". If this works this is probably your best solution.
posted by ropeladder at 4:34 PM on January 20, 2012

It would probably be wrong to make a warranty claim since you did the damage yourself, but Dell usually doesn't ask for the keyboard back when you do a warranty claim on a keyboard if you do a parts-only claim. Changing a keyboard is super easy, and the last one I did for my Dell, the part even came with a little screwdriver.

Similarly, keyboards are cheap.

My experience with keyboards is that once they start going bad like this, it is going to keep getting worse. That's because keyboards are usually two thin sheets of plastic with contacts, sandwiched together with a third piece of plastic to keep the contacts from touching unless the key is pressed. Once liquid gets into there, it takes forever to dry since there is no airflow, and the liquid tends to migrate around and affect other keys.

For the wireless one, I believe it is handled outside the purview of the OS. If the BIOS options don't solve the problem, you are probably out of luck.
posted by gjc at 8:06 AM on January 21, 2012

Alt X brought up windows mobility center, and I turned radio control options, wifi off.

It is currectly switched off, i've double checked, but the screwy keyboard still somehow has access to it and turns it on and off back and forth.

I will try to open my laptop and cut the cables... if it doesn't work, i'll buy a new laptop..
posted by crawltopslow at 10:23 AM on January 21, 2012

« Older Help me with my networking skills--I need to get...   |   There's no way Zara and H&M have wiped out the... Newer »
This thread is closed to new comments.