p2p web access dominance
June 30, 2005 6:29 PM   Subscribe

p2p kills my browser

and my email client. anything that needs to connect to the web. it just times out. this occurs when using bearshare or emule. i've only just jumped on the bittorrent bandwagon (using azureus), and it also exhibits the same effect.
i've run the patch at http://www.lvllord.de/?lang=en&url=tools#4226patch, and am no longer getting the Event ID 4226 warning, but i'm still unable to connect to anything else whilst using p2p.
the timeout problem doesn't occur immediately, i may get an hours use out of my browser before it dies, but once it does i can't get it to work again, even after shutting down the p2p application. i have to reboot to get browser capability back.
running xp pro service pack 2, with all the updates.
ideas?
posted by hayeled to Computers & Internet (10 answers total)
 
Your ISP could be using a packet shaper. P2P protocols saturate networks with data. As soon as you use P2P protocols, traffic for the rest of the protocols can get cut down by the shaper. Save for tunneling your P2P stuff through another protocol I'm not sure what you'd do.
posted by Rothko at 6:36 PM on June 30, 2005


More likely, your P2P clients are saturating your upstream and starving all your other apps.

Figure out what your upstream cap is, and then limit your P2P app to about 5k below that, and you'll be fine.

Because the bandwidth limits are P2P-client specific, you'll have to run only one P2P client at a time. Otherwise they'll each limit their upstream bandwidth, but the aggregate upstream will still exceed your cap.
posted by nmiell at 7:11 PM on June 30, 2005


Rothko's answer is probably only true if you're at a university, while nmiell is most likely correct if you're just at home on a normal residential line.
posted by angry modem at 7:43 PM on June 30, 2005


Your p2p is killing my server backup.
posted by realcountrymusic at 8:58 PM on June 30, 2005


This is a weird problem because it goes away when you reboot but not when you quit your P2P software. This means it's not your ISP throttling you, it's not your router, and it's not outbound bandwidth starvation. It's some kind of weirdness in your machine's TCP/IP stack, probably caused by software or configuration.

Unless of course you're using some kind of P2P software that doesn't REALLY quit when you think you've closed it. I recall some clients are like that -- they have a background daemon that keeps sharing files after you shut down the UI. In that case it's probably outbound bandwidth starvation. For that, I recommend a router that lets you assign priorities to different kinds of traffic, such as the D-Link DGL-4300. I got one of these recently and it's simply awesome. I've been able to prioritize my network to basically five tiers, in roughly this priority: VOIP traffic; DNS queries and ICMP traffic; TCP/IP traffic out of my Mac to ports 1-1024 (i.e., ACKs and small outbound bursts like POP/IMAP commands and HTTP requests), responses to inbound SSH traffic TO my Mac, anything outbound from my mail/Web server box, and everything else (including P2P apps on the Mac). The capability is known generically as "quality of service" (QoS); Linksys also has a router with the feature, the RT042, although I disliked that product passionately. (It's also available in the Sveasoft firmware for the Linksys WRT54G.)
posted by kindall at 9:10 PM on June 30, 2005


You never mentioned what OS you're running. If you're running 95, 98, or ME, you may be exceeding the maximum number of allowed connections (there's an internal limit). Solution: Get a real OS. ;)
posted by neckro23 at 9:25 PM on June 30, 2005


I had something similar happen when I switched to SBC dsl. I could surf the internet just fine, but anything that required more than a little uploading (such as posting a comment to MetaFilter or sending an email) just timed out. Like you, shutting down P2P didn't do it - I had to reboot my router. I also use XP sp2.

Here's the bad news: I still have no idea what the problem was. Here's the good news: it seems to have gone away on it's own.

So: is your internet connection new? Is it SBC?

I don't know if any of that helps, but it's such a strange problem that I thought I'd throw it out there.
posted by gd779 at 11:43 PM on June 30, 2005


it's a home residential line.
i don't know what sbc is.
i'd already tried altering the upload limit of bear, so i had a go with azureus aswell, but no joy.
(i only ever run one p2p at a time)
um, i might give the router one a look in later.
how would i tell if the p2p doesn't REALLY quit? (nothing shows up in task manager)

anyway, thanks for the suggestions people. for the time being i'll just have to be satisfied with limitting my p2p dls to whilst i'm sleeping. and continue to whinge about it to everyone i meet.
posted by hayeled at 2:04 AM on July 1, 2005


gd799 - That's a classic symptom of a too-large MTU setting. Default on a lot of DSL routers is 1500, which is OK for ethernet, but generally a little too large for a PPPoA/PPPoE DSL link. Dropping to 1492, or a little below, usually fixes it. Google +"MTU" +"upload" for more info.

It may also be hayeled's problem, but that sounds more like a saturated uplink or adaptive blocking by the ISP. Backing off the upload bandwidth, or opening up a (few || lot) more outgoing ports in the P2P app may fix it.

(I'm in danger of becoming the weird guy who sits in the corner mumbling "MTU, MTU, MTU ..." to everybody near him ;-)
posted by Pinback at 5:49 AM on July 1, 2005


Thanks Pinback! Nobody could ever answer that for me - I'll look into what you've suggested.
posted by gd779 at 8:46 AM on July 1, 2005


« Older You probably think this song is about you? Don't...   |   Cleaning silk shoes Newer »
This thread is closed to new comments.