How can I get my Android tablet to stop popping up the soft keyboard when using a Bluetooth keyboard?
January 13, 2012 12:17 AM   Subscribe

I've got a Galaxy Tab Android tablet and an Apple bluetooth keyboard. Whenever I'm using the keyboard, the onscreen soft keyboard still keeps popping up and it's sodding annoying. Is there any way to make the soft keyboard get gone and stay gone while the bluetooth keyboard is active?

No fancy setup or anything. The bluetooth keyboard is tethered and works just fine. But every time I touch a new text field to type, the soft keyboard appears. I can dismiss it (or not) and type with the bluetooth keyboard either way, but without fail, every time I touch a new field, it pops back up.

I only use the bluetooth keyboard sometimes though, I still want the soft keyboard to come up when the bluetooth isn't active. So completely nuking the keyboard software is less than ideal.

Is there some setting I'm not seeing? Some incantations to chant and candles to burn? I'm otherwise really happy with the tablet and the tablet + keyboard as a writing setup, but having half my screen turning into an unnecessary keyboard constantly is quite lame.
posted by Nelsormensch to Computers & Internet (2 answers total) 1 user marked this as a favorite
Best answer: The Null Keyboard app in the market will prevent this from happening.
posted by blue_beetle at 5:15 AM on January 13, 2012

Best answer: Combine the Null Keyboard app with a Tasker profile to switch keyboards when bluetooth is enabled. If you use bluetooth for other peripherals, add an extra condition to the profile (ie when WiFi = home network).
posted by Akeem at 7:09 AM on January 13, 2012

« Older Thinking about coming out as trans at work.   |   Water proofing metal Newer »
This thread is closed to new comments.