help me stop my XP folders from opening in new windows.
June 26, 2005 12:48 PM   Subscribe

How do I get my XP folder windows to stop opening in their own window? I'm aware of the "open in new window" option in Control Panel > Folder Options and that's not it.

I was playing around with the file types settings in the Folder Options and somehow I set the file type "folder" and (maybe) "file folder" to open into the Find mode instead of exploring the folder (so I'd get the left pane with the search field and the name of the folder I just clicked in the text field.).

I changed the actions to open with explorer.exe because I couldn't think of anything else that would work. Now it explores the folder, but opens a new window each time. It's awful and it makes it almost impossible to work.

What should these be set to? I checked another pc and folders have the actions explore and open, but neither is editable, so I can't see what app they associate with.
posted by miniape to Computers & Internet (8 answers total)
 
I'm not 100% sure, but the way I have mine set up is that for "folder" (in file types) I have it's default action set to "explore". That works for me.
posted by vernondalhart at 1:02 PM on June 26, 2005


In Folder Options, on the General Tab, there is a setting for Browse Folders:
(x)Open each folder in the same window
( )Open each folder in its own window
posted by borkencode at 1:10 PM on June 26, 2005


From the original post: I'm aware of the "open in new window" option in Control Panel > Folder Options and that's not it.
posted by grouse at 1:23 PM on June 26, 2005


I changed the actions to open with explorer.exe because I couldn't think of anything else that would work. Now it explores the folder, but opens a new window each time. It's awful and it makes it almost impossible to work.

How did you do this? Windows should be pretty protective of the associations for folders/ file folders, and you should only be able to change their actions through the GUI.

I think you've set up a new action (under the Advanced button in File types) using explorer as the default action for folders. This means that explorer doesn't recognize opening a folder as its own internal action, and tells it to open the folder with an external program (which happens to be explorer). So you're spawning a brand new copy of explorer when you double-click a folder. Look in the advanced options, and make sure you only have 'explore' and 'open' as options.
posted by boo_radley at 1:38 PM on June 26, 2005


boo_radley is correct about how this happened. But in the advanced settings, it asks for a name and a program. Can I just type in "open" and "explore" and leave the program part empty?
Here is the advanced tab (Note that this is on a different computer. Not the one with the problem)



In the 'edit' dialogue it asked for a name/description and then it let me browse for an app. Should I just leave the application blank?
posted by miniape at 2:27 PM on June 26, 2005




This is what the open action should look like...
I don't know if just recreating the action will fix your problem though.
    The entries from top to bottom are:
  • open
  • %SystemRoot%\Explorer.exe /idlist,%I,%L
  • [ViewFolder("%l", %I, %S)]
  • Folders
  • []
  • AppProperties
explore is the same, except that the application is
%SystemRoot%\Explorer.exe /e,/idlist,%I,%L

I have a feeling there there are also registry values that might need to be changed...
posted by yeoz at 3:13 PM on June 26, 2005


Don't you have to also hit the "apply settings to all folders" button, in addition to checking "open each folder in same window'?

Mine have always opened in the same window, and think that's all I did. Not sure though.
posted by -harlequin- at 6:24 PM on June 26, 2005


There is also a known XP bug that prevents you from fixing this on some systems and requires some registry hacking to fix. Which is why I'm running a different OS now.
posted by yerfatma at 6:18 AM on June 27, 2005


« Older What to use to clean a computer?   |   Up the Creek w/o a T-Mobile Brand Paddle Newer »
This thread is closed to new comments.