Help me retake control of my bookmarks.
November 11, 2011 2:42 PM   Subscribe

Since upgrading from Firefox 4 to 8, the dropdown menu on my bookmarks is too wide to use.

Instead of a uniform length with long titles ending in ellipses, the menu widens to accommodate the longest title in the list. This makes navigating the menu impossible.

I tried looking through mozilla's own help forums, and the advice is universally "just go through each of your bookmarks and truncate the title." I have hundreds of bookmarks. I don't have that kind of time. Furthermore, I don't have the mental energy to remember to truncate every time I make a bookmark.

Is there a Greasemonkey script or something I can install to get my bookmarks menu width back to something uniform? I'm not a coder, but I can follow instructions.
posted by The demon that lives in the air to Computers & Internet (7 answers total)
Weird. My Firefox 8 shortens long titles in bookmarks menus with ellipses just as it always has. What OS are you using?
posted by zsazsa at 3:22 PM on November 11, 2011

This has been affecting some people since FF4. Back then it seems to have been the default theme in 64 bit builds causing problems - changing to a 32 bit build or using a custom theme seemed to cure most cases. I haven't kept up with the issue, so I don't know the state of things now.

FWIW, it's fine for me with FF8 64 bit on OS X.
posted by Pinback at 3:49 PM on November 11, 2011

I'm running OS X 10.5.8. My macbook is definitely showing its age.
posted by The demon that lives in the air at 4:02 PM on November 11, 2011

Are you:
  • using the default theme? (check under "Tools -> Add-ons -> Appearance")
  • running a 32 or 64 bit build? (run OS X's Activity Monitor, find Firefox in the "Process Name" column, and look across to the "Type" column - should say either "Intel", or "Intel (64 bit)")
What about the basic troubleshooting steps Mozilla suggests?
  • Have you tried disabling all your extensions? ("Tools -> Add-ons -> Extensions", disable everything, and restart FF).
  • Have you tried logging in as a different user in OS X and running Firefox?
  • Have you started Firefox with a new profile? (instructions here)
(Those last 2 will start Firefox with an empty bookmarks file; you'll have to find a page with a long title and bookmark it to see if it's had any effect).
posted by Pinback at 8:40 PM on November 11, 2011

Running FF(64) 7.0.1 on a 10.6.8 iMac and I definitely have to manually trim bookmark names in order to keep the drop-down to a reasonable width. A bit irritating. FWIW, I didn't even realize I was running 64-bit FF.
posted by Thorzdad at 6:11 AM on November 12, 2011

You can edit the names of your bookmarks to shorten the longer ones.
posted by willnot at 7:33 AM on November 12, 2011

Sorry - I see you said you didn't have time to do that for all your bookmarks. Not sure How I missed that the first time.
posted by willnot at 7:48 AM on November 12, 2011

« Older How do I deal with limerence for a total stranger?   |   Milk first or cereal first? Newer »
This thread is closed to new comments.