This makes alot of sense
September 10, 2011 7:54 AM   Subscribe

Another InDesign question. You know that thing InDesign does? Let's say you just placed a Word doc into your InDesign doc and now you're applying your paragraph styles, heading styles, etc. You remove an extraneous paragraph break (because authors love their extraneous paragraph breaks and have about 100 in each article) and InDesign sees that and says, "Hey, in some universe, the last line of a paragraph has a different leading value than the other lines in the paragraph, even though it's dictated to me by the paragraph style. So I'll just go ahead and fix that for you by making this line of text a different leading value than the others. Then I'll make it not so easy to fix. You're welcome!"

I'm sorry for my unprofessional tone. This has just been making me crazy for a few weeks. This is in InDesign CS5 but I remember it from when I used CS4 as well.

I've figured out how to fix it but it's kind of awkward to explain written out and annoying to do repeatedly. I'm going to have to create a written procedure manual for this document going forward so I'm hoping there's an easier way to fix it, or a definitive method to avoid it.

From googling, I figured out that you can select all the lines of text around the misbehaving one, change that to some other value, then remove the style modification from the style window (the + sign) and that fixes it. This is a pain. Applying the styles starting from the end of the document and working backwards works too, but not completely.

I guess another way to avoid it would be to go through the original Word docs and remove them there first. I would like to know if there's an easily-explainable trick to it first.
posted by bleep to Technology (10 answers total) 1 user marked this as a favorite
Best answer: This may not be the answer you want, but locking your text to the baseline grid fixes this. Unfortunately, it requires a little tinkering, works best in more rigid layouts, and you of course have to modify the baseline grid to reflect what you want your leading to be.
posted by pullayup at 8:06 AM on September 10, 2011 [1 favorite]

Response by poster: Hmm weird. That sounded really attractive, so I looked into it. I set the baseline at 12pt in the preferences, changed all my styes to align to grid (all lines), placed a new word doc, zoomed in to see my grid and my paragraphs real big and started assigning styles and removing paragraph marks and... it's still doing it. Everything is lined up nicely in the grid except there's clearly an extra gridded line there at the end of the abstract. Blurg!
posted by bleep at 8:24 AM on September 10, 2011

I get that a lot too. The way I fix it: Select Type, then Show Hidden Characters (bottom of the list). You'll probably see a different looking paragraph character near the wonky sections - for me it looks like an upside down "L" or a triangle, or combination thereof. Highlight that paragraph character(s) and ctrl-c to copy. Ctrl-A to select all text in the article. Ctrl-F to open find/replace. Ctrl-v to paste those characters in the "find what" box. In the "change to" box, click the dropdown icon in the right, choose "end of paragraph." In Search, dropdown & choose "selection." Then hit Change All. It should fix all the wonky bits in that story. I got used to doing this so it's pretty intuitive and only takes a second. Probably not the only way to fix it, but works for me. I think those oddball spacings are some artifact of whatever arcane settings the originating person had in their Word software.
posted by cuddles.mcsnuggy at 8:37 AM on September 10, 2011 [1 favorite]

I should mention that I do the above directly in Indesign, not Word.
posted by cuddles.mcsnuggy at 8:40 AM on September 10, 2011

Best answer: Maybe I'm not understanding this correctly, but could it be fixed by making sure that your 'Paragraph' paragraph style has "Next Style" defined as the *same* style (i.e. Paragraph style)?

Also, sometimes what I do when I import a doc that I know will be wonky is Select All and set the entire thing to the Paragraph Style. Then create keyboard shortcuts for the other styles (with those styles' 'Next Style' set to Paragraph Style) and assign all the heads and subheads manually. That way you KNOW that the entire document is set to the correct baseline style (Paragraph Style).

But before all that, I'd probably use InDesign's Find/Replace (with grep capabilities) to remove all the offending breaks.

Also make sure that Paragraph Style is 'Based On' nothing, and that all the other styles are 'Based On' Paragraph Style. Now you've set your baseline, and all the other styles are variations on the main theme. You can easily alter Paragraph Style and then all the other styles that don't have style-specific overrides get the changes cascaded down to them. This is another nice thing about the Select All and setting the entire doc to Paragraph Style ... you know you've assigned and captured everything to your main theme.
posted by iamkimiam at 9:05 AM on September 10, 2011 [1 favorite]

Response by poster: Weirdly in mine the paragraph symbols are all just regular paragraph symbols.

The baseline thing does work if you change the whole thing to the paragraph style and remove all style modifications (+) before removing the paragraph breaks. I also had the bright idea to preserve italics by finding/replacing the Word-formatted italics to my never-delete-italics-character-style.
I hope this keeps working! Thanks for your help!
posted by bleep at 9:12 AM on September 10, 2011

I also might be misunderstanding, but try selecting the text you want to set and alt-click the style in the paragraph styles menu (it sort of force-reboots the style allocation).

Also, I've noticed a tendency to automatically assign character styles without asking.
posted by Grangousier at 9:22 AM on September 10, 2011

Prefereces>Type>Apply Leading to Entire Paragraph. Is that option checked in the document you're working on?

I also might be misunderstanding, but try selecting the text you want to set and alt-click the style in the paragraph styles menu (it sort of force-reboots the style allocation).

Before doing this if you're applying tweaks in Indesign. If you've italicized a word and that's different from the style, alt-clicking will remove the italicization, 'cause it's not part of the style.

An alternative is to Alt Click those extra paragraph breaks and apply the style to them. As you delete them, it shouldn't present a problem, 'cause the styles match.

The best thing would be for authors to next include all that crap, but that will never ever happen.
posted by Brandon Blatcher at 9:43 AM on September 10, 2011

Sometimes it can help to set the character style to None, then apply your paragraph style.
posted by Fleebnork at 10:47 AM on September 10, 2011

I never, ever import a Word file directly into InDesign for this kind of reason.

Print out a hard copy from Word, dump the text into TextWrangler or BBEdit to "bleach" the Word junk out of it, then place it in ID and apply styles there created *in* ID. Delete any Word styles in the document now. In fact, start a virgin file and don't let any actual Word code get anywhere near it.

It will be far easier to work with and stop reverting to styles that tag along from Word just to fuck you up.
posted by zadcat at 6:28 PM on September 10, 2011

« Older Health Check my laptop   |   Ask me about my crippling shyness... at my wedding... Newer »
This thread is closed to new comments.