How can I make iTunes delete songs again?
May 15, 2005 3:46 AM   Subscribe

How can I make iTunes delete songs again?

At one point when I fist started using iTunes when I pressed "delete" it would ask me if I wanted to physically delete the file. I said no and checked the box for never asking me that question again. But now I want that function back and I can't find how.

Bonus question: is there a way to have iTunes NOT add a song I play (by double clicking it in my file manager) to the library? Sometimes I just want to listen to it before deciding if I want to keep it.
posted by Skyanth to Computers & Internet (13 answers total)
 
On the first question, I believe the keyboard shortcut Option-delete will physically delete the song.

For the bonus question, you can always highlight the song file (the actual file, not the iTunes listing) and control-click to get the contextual menu. Then select "Open with..." and select whatever other player you might have that will play the file...QuickTime, for instance.

I am assuming you're using a Mac for this, of course.
posted by Thorzdad at 3:58 AM on May 15, 2005


Windows, but I get your drift.

Still, shift-delete only asks to delete from the library, and ctrl-delete and alt-delete doesn't seem to do anything special.
posted by Skyanth at 4:51 AM on May 15, 2005


Hmmm...I've never seen the Windows version of iTunes. In the Mac version, there is a Keyboard Shortcut list under the Help menu.
posted by Thorzdad at 5:24 AM on May 15, 2005


Have you tried right-click and selecting "clear"?
posted by grapefruitmoon at 6:01 AM on May 15, 2005


Clear doesn't do it.

It's not in the keyboard shortcut list either. Did this option ever exist or am I making it up?
posted by Skyanth at 7:41 AM on May 15, 2005


If the actual file is located in your iTunes folder, you should get the "do you want to delete this from your hard drive" option, if you use the Delete key.

If the file is not in your iTunes folder, you need to go into whatever folder it's in (through the desktop) and delete it from that.
posted by jlkr at 7:55 AM on May 15, 2005


jikr,
Skyanth selected the "Don't show this again" box on the delete dialog. Thus, he isn't getting the message anymore. And, apparently, the actual files are not getting moved to the trash.
posted by Thorzdad at 8:45 AM on May 15, 2005


On my mac (which is where I have my music) I opne quicktime when I want to 'audition' music, rather than double clicking on it.

Truthfully, I drag them to quicktime's icon on my desktop.

iTunes will delete ONLY from the library - and not from the playlists. The playlists are just accumulation of songs pointing to the library. I bet you've been deleting songs from playlists. I bet it deletes music, but only when you use the library and you just aren't seeing it. Is it in your computers trash?

Double check this - if you have iTunes set to organize your music (and you should! It's the default)...it will make a copy of any music you double click or drag & drop. Go look inside of the iTunes Music folder and you can check if it deleted the music.

If you've chosen in iTunes NOT to have iTunes organize your music, all it's doing is making a link on your drive to where the music is (this is the same to "Add to library" as an option rather than Import.) When you hit delete under this circumstance, it just breaks the link.
posted by filmgeek at 9:32 AM on May 15, 2005


To reset the warning dialogs on the Mac, you delete the files:
~/Library/Preferences/com.apple.iTunes.plist and
~/Library/Preferences/ByHost/com.apple.iTunes.[a number].plist
which will reset all your preferences, but leave your library and playlists untouched. I'm sorry I don't know where they'll be on Windows, but if there's a common preferences folder, try there.

On deleting though: If you press delete on a song when you have "Library" selected in your source pane, on the Mac at least, it will *always* ask you if you want to move the song to the trash or keep the file. There is no "don't ask" checkbox for this.

If you have a playlist selected in the source pane, pressing delete will remove that song from that playlist. If it's a smart playlist, pressing delete won't do anything. However: Press alt-delete in a playlist or smart playlist to remove the actual file from disk. (In the library pressing alt makes no difference, of course.)

For auditioning, what I do is have a smart playlist showing only songs added that day, and then just alt-delete them as I go.
posted by bonaldi at 8:57 PM on May 15, 2005 [1 favorite]


Thorzdad- I know that. But it doesn't matter. If the file isn't in the iTunes folder, iTunes doesn't ask you if you really want to to delete the file. If it's in the iTunes folder, iTunes will ask you if you want to actually delete the file even if you've got the "click to confirm" box turned off. (Those are my settings, and the only time iTunes asks if I want to actually delete the file is when it's a file in the iTunes folder. The rest of the time it just deletes the library pointer but leaves the file alone.)
posted by jlkr at 7:20 AM on May 16, 2005


Tangentially related question: Why can I not Party Shuffle the contents of a remote drive (listed under Shared Music)?
posted by erebora at 2:13 PM on May 16, 2005


Sorry to raise this again but I've found an answer.

I had the exact same issue (it's nowt to do with WHERE your music is stored, or HOW, it's about getting prompted again).

Apple don't give you a way to 'undo' that little checkbox decision, so you have to delete your preferences file.

For Windows XP users you'll find this under:
C:\Documents and Settings\[OSUSERNAME]\Application Data\Apple Computer\iTunes

The file is called iTunes.pref.

Stop iTunes, delete that file, start iTunes. You'll know it's worked because you'll get prompt to agree to the legal stuff again.

Note: this resets ALL your preferences.
posted by snowgoon at 1:19 AM on November 14, 2005 [1 favorite]


Oops - meant to say - this is basically what bonaldi said but for Windows users.
posted by snowgoon at 1:20 AM on November 14, 2005


« Older I keep having recurring deja vu.   |   story Newer »
This thread is closed to new comments.