In photoshop, when I run batch actions it breaks at the "JPEG Options" prompt. How do I override this?? It's really annoying
May 15, 2011 10:28 PM   Subscribe

In photoshop, when I run batch actions it breaks at the "JPEG Options" prompt. How do I override this?? It's really annoying

I really hate this program right now ;P

I'm using Photoshop CS.. so it's an older version. Don't remember having this prob before.

I made an action to resize. Go to run the batch action on a bunch of files, at each one it stops and brings up the JPEG Options prompt, where you do the image quality when saving jpegs.

I just want it at the same quality as when I created the action.. so why doesn't it just use that value and remember it??

Does anyone know how to just do bulk saves in older Photoshop CS using batch with actions so it doesn't stop and prompt me to dabble with the image quality prompt at each file?

Thanks!~
posted by Like its 1997 to Computers & Internet (4 answers total) 2 users marked this as a favorite
 
I don't have my computer handy.

I've had this problem before.

I kinda remember it involves either not checking the box you think you should check or vice versa. I think there is a box that says something like "override save" something. And you don't check that box.

You have to record the whole action all the way through, and don't check that box.

Sorry, this answer is lame, it's 3 AM but I think I got that to work.

The actions command is pretty lame. There are a number of bugs with it.
posted by sully75 at 11:58 PM on May 15, 2011


I *think* this will work... I'm on CS5 and haven't used CS for a while, and this advice sort of contradicts the above :\
... but here goes...

1. Make sure that when you record the action, you're still recording when you select jpg quality. Don't stop the recording until you've selected Save and Close. Only then should you stop recording.

2. Once you start the batch, make sure you select "Override Save As"

3... looking on the google, it also sounds like it helps if all the files you're processing are in the same folder.

Let me know if any of this works.
posted by MaddyRex at 2:28 AM on May 16, 2011


Did you save the image as part of the action? In other words, when recording the action, did you perform the resize, then save the file, and then close the file (optional but if you do a big batch you'll crash PS if you don't close the file at the end of the action)?

My process for batch resizing actions:

1. Open dummy image to record with
2. Press "record action"
3. Click File > Automate Fit Image and set the dimension bounds (longest edge for portait or landscape orientations)
4. Click File > Save. Assuming I opened the same type image that I'll actually be working with (JPG) it will simply save the file without prompting me
5. Close the image
6. Stop the action
7. Perform the batch by clicking File > Automate > Batch. Select my resize action, choose the source Folder of my images, and leave everything else unchecked. Leave destination set to None and it will simply resize/overwrite the old ones. If I want to keep the originals I make a copy outside of PS before running the script.
posted by sprocket87 at 6:18 AM on May 16, 2011 [1 favorite]


Yeah sprock I included the save as part of the action, including where I set jpeg options.

I also removed them and used the "close and save" option in batch controls.


I have to try unchecking 'override', maybe sully's solution works. I'll dabble with all options but, I thought it was a bug cause it only does it on pictures that are horizontal (landscape) out of the camera, but the vertical ones goes through just fine.


I'll see if any of these work and post back. thanks!
posted by Like its 1997 at 5:42 PM on May 16, 2011


« Older Can I buy a plastic removable bubble window to...   |   Rules regarding sale of items with ivory trim in... Newer »
This thread is closed to new comments.