File sharing problem in XP
May 9, 2005 12:27 AM   Subscribe

File sharing problem in XP.. I can access my laptop files from my desktop but not the other way around.

Laptop is XP home and desktop is XP Pro. Both connect fine to internet and both are wireless. Both have same workgroup name and I've set files on each to be shared. As I mentioned, laptop files show up fine in My Network Places on desktop but not the other way around. In View Workgroup computers (on the laptop), my Desktop shows up but when I click on it, I get an access denied error. IP addresses of each computer are set as "trusted" in firewall settings and I've also tried turning firewalls off.

Am I missing something here? This is driving me a bit crazy.. thanks.
posted by gfrobe to Computers & Internet (13 answers total)
 
Run the file sharing wizard on the Laptop (search local windows help)-

then the 2 will see each other "peer to peer"....

fyi- you'll want to wipe the laptop someday to get XP pro on it, much easier to network.
posted by stevejensen at 4:06 AM on May 9, 2005


I had a hellish time getting an XP Home and XP Pro computer to talk. however, turning off Zone Alarm worked for me (after everything else failed).

and, yes, make sure you pick the right type of network during sharing setup -- try a couple versions.

the only other thing I can think of, is that I made the c drive sharable, however, that just meant the c drive. I also had to designate the specific folders to share, too, which seemed counterintuitive. so maybe that is your problem -- make sure you individually designate folders to share.

good luck! I know it is a pain in the ass, but it is doable.
posted by evening at 5:25 AM on May 9, 2005


Same scenario, evening's folder answer works, mostly.
We lose it once in a while and have to re-share to get it back.
posted by unrepentanthippie at 5:35 AM on May 9, 2005


Thanks for the suggestions but unfortunately no luck. Still getting a message saying "you don't have permission to access this network source". This was after running the wizard on each computer and making sure workgroup name is the same.

I've also designated a bunch of individual folders as "shared" on each computer so that's not the problem.

Any other suggestions? Thanks.
posted by gfrobe at 6:47 AM on May 9, 2005


evening: Turning off Zone Alarm shouldn't be necessary if you add your LAN subnet to ZA's Trusted Zone.

Right-click on the system tray connection icon for your LAN connection, select Status and look at the Support tab - that has all the dotted-number goodness you need for this.

Add subnet 127.0.0.0, mask 255.0.0.0 (name it "Local loopback") and IP address 255.255.255.255 (name that "Global broadcast") to the Trusted zone as well.

gfrobe: be aware that XP Home doesn't understand Windows domains, and will never hand off the job of authenticating your logon to a domain controller (which XP Pro will probably elect itself to be in your situation). An XP Pro domain controller will, however, treat a non-domain user as equivalent to a domain user, for access to shared resources ON ITSELF ONLY, if that user has the same username AND PASSWORD on the accessing workstation as on the DC.

To find out whether this is a user authentication issue, go to your XP Pro box, bring up the Security tab on one of the folders you're trying to share and give Full Control permission to Everyone (don't leave it like that - only do that for testing).

And never never never share your whole C: drive. Ever. Just don't.

If all else fails: install WinPcap 3.1 beta and Ethereal from here on one of the computers, run a trace, attempt file access from both sides, and see what's different.
posted by flabdablet at 6:55 AM on May 9, 2005


Flabdablet, on my XP pro box, if I right click on a folder I see a tab for "sharing and security". Opening that there is an option that says "share this folder on the network". There is nothing about Full Control permission though. Am I missing something?
posted by gfrobe at 7:29 AM on May 9, 2005


If you used passwords on the XP Pro system (and you should, passwords are a good thing) you'll have a hell of a time getting the Home machine to work correctly. You need to 1) locate the Pro system on the network, 2) connect to it, 3) supply user name and password (enter name as "PROCOMPUTERNAME\User") before ANY shared folders will work correctly. You will need to do this even if the laptop and desktop are both logging on using the exact same user name and password. You will need to do this every time you need to connect, because Home refuses to remember logon user names, let alone passwords. Microsoft appears to have made it difficult to implement any sort of security on a home network, the only way around this that I know of is to remove all passwords from both computers (a really dumb thing to do, as far as I'm concerned. Not every yahoo using a computer at home is behind a secure NAT firewall, and it's stupid of Microsoft to assume otherwise.)

Second, make sure "simple file sharing" is off. If it is turned on, you either share with everyone or with nobody, no in betweens. Turning it off requires to you set two things prior to sharing: Sharing itself (which determines who has permission to read/write files over the network) and Security (which determines which local users & groups have permission to do anything to those files from anywhere, locally or network). You'll need to configure both settings to have any sort of control over who can access shared files.

Also, are you running SP2 on both systems? MS made changes to the firewall in SP2; if one system is not running the newer service pack it might cause some issues. Turning on file sharing in the original Windows firewall didn't actually allow files to be shared, if I remember correctly. If you're running the Windows firewall plus a second firewall, you need to turn off one or the other - running two at once will definitely screw up your networking.

Last but not least, if you do go Pro on the laptop, don't wipe XP Home first. You can just stick an XP Pro disk in the drive and install it as an upgrade. That way you won't lose any of your installed programs or settings; I've done this on several systems (including my own laptop) and have so far experienced no problems with it. Good idea to slipstream SP2 into your install disk before running it though, it will save you some download & security patching headaches in the long run.
posted by caution live frogs at 7:39 AM on May 9, 2005


gfrobe: if you don't see separate Sharing and Security tabs, you have Simple File Sharing turned on. You can turn it off under My Computer->Tools->Folder Options->View; it's the bottom item in the bottom scrollbox, IIRC.

SFS is on by default in a non-domain environment, so your XP Pro box is clearly not operating as a DC, which means you won't get the helpful foreign-user-accepting behavior.

To supply the appropriate username and password to the Pro box when accessing a share, you'll need to do Connect As A Different User and enter the username in the form CLF describes above.

If you want to avoid having to do this a lot, create a .BAT file on your laptop full of commands like

net use \\servername\sharename /user:servername\username

(you may care to try this out by hand at a command prompt to see if it works before putting bunches of them in a .BAT).

You can also map drive letters with the "net use" command, like this:

net use Y: \\servername\sharename /user:servername\username

If you do choose to map drive letters over your shares, start at Y: and work backwards through the alphabet. If you start near the beginning of the alphabet, you'll mysteriously lose access to any USB storage devices you might plug in (memory keys, hard drives, cameras...)
posted by flabdablet at 7:57 AM on May 9, 2005


So I've now upgraded the laptop to XP Pro and thought that would solve the problem. No luck. This is strange because this is a new laptop that has replaced an older one and with the older one (also XP Pro), I never had to do anything other than match the workgroup names to share files in both directions. Why would I have to do anything differently now?

Do all the above suggestions still apply if both computers are now XP Pro?

Thanks again.
posted by gfrobe at 8:37 AM on May 9, 2005


Firewall redundancy issues and simple file sharing still apply - the hassle with user names and passwords is easier. In your User Account window there should be a small "manage network passwords" link in the top left. You can check to see on both machines if the computer is trying to connect using the wrong credentials; once these have been "remembered" there is no other way I am aware of to clear them and enter new ones. As long as both Pro boxes are using the same account name and password access between the two should be transparent (we do this with our lab computers, and have very few sharing difficulties).

Having said all of this, sharing in Windows is tricky. The basic heriarchy is "allow everything, but deny these specific things". You can actually allow sharing in one spot but deny access by changing another setting.

In your Security tabs, uncheck boxes (IE, don't choose "allow" or "deny", just remove all checkmarks) for accounts that should not be allowed to access folders. Remember that rules are coumpounded - that is, allowing a specific user access, and then denying access to all users, will still deny access to the specifically allowed user. It's a major headache at times... Just be glad none of the computers are running older versions of Windows, because the networking there becomes an absolute nightmare.
posted by caution live frogs at 9:47 AM on May 9, 2005


This is kind of a weird thing, but it happened to me. When setting up a home network, everything would set up okay, then when I logged off and back on, the internet would work but I couldn't share any files.

I finally went into Windows Setup and discovered that the Networking support boxes weren't checked. I checked them and everything worked fine thereafter.

If you've tried everything else, this is worth a shot (and it's quick to do).
posted by Doohickie at 10:16 AM on May 9, 2005


I'm really confused now. I don't have passwords on either computer and so don't have a log on screen. So I also don't think I have User Account windows.

CLF, what security boxes are you talking about? For individual folders?

And Doohickie, what is Windows Setup and how do I reach that?

Sorry but I'm a layman on all the technical stuff..
posted by gfrobe at 11:33 AM on May 9, 2005


Sorry I didn't answer earlier: Start > Set Program Access and Defaults > Add/Remove Windows Components > Networking Services.
posted by Doohickie at 5:07 PM on May 11, 2005


« Older What are some alternative treatments for cancer?   |   The Right Honorable Lord Mayor? Newer »
This thread is closed to new comments.