Configuring a Zoom X3 5660A router/modem for Bit Torrent
May 8, 2005 7:25 AM   Subscribe

I recently bought a Zoom X3 5660A DSL router/modem/all-in-one to use with my Apple Airport Extreme Base Station for internet. Everything's working fine, except Azureus (Bit Torrent).

Although I can download/share torrents, they've all got yellow smilies - and the configuration wizard shows a NAT Error when I test port 16881 (which I've configured Az. to use).

This, obviously, means that port forwarding isn't happening correctly. These are the things I've done so far:

1) I turned off Azureus' UPNP auto option, as suggested.

2) I changed my Azureus port to 16881, in case my ISP was blocking the default (6881).

3) Confirmed that the firewalls are off on the Airport and Modem/router.

4) I set up a static IP address by doing following some online instructions and doing this:

System Pref -) Network -) Airport -) TCP/IP
Configure: Manually
IP Address:
Subnet Mask:
DNS Servers:

5) I configured my Airport's Port Mapping by adding a bunch of entries (16881-16889) like this:

Public Port: 16881
Private IP Address:
Private Port: 16881

6) I reset the airport.

Most of the forum-post support for configuring the Zoom X3 for BT is based on the 5660 modem, which has a "Virtual Server" button on the control panel which you can use to configure port forwarding. The 5660A does not have this feature. Sooo... I tried adapting these instructions, which are for another modem but were translatable.

8) I added IP Filtering rules, as here. (On my setup, unlike theirs, there were already many IP Filtering rules. Azureus didn't work any better with the existing ones + my new ones, the existing ones + only the BT-related one, or everything deleted except my three new rules.)

9) I added the NAT rule as here.

Anyway - no dice. Yellow smilies and NAT Errors.

At this point I've reset the modem/router to its default settings.

Some suspicions about things which still may be wrong:

A) On the IP Filtering page of my control panel, if I click the "Session" button, it states "IP Filter not enabled". I can't find anywhere that says "Enable IP Filter", though.

B) One of the problems may just be the interaction between my airport and the router side of the Zoom... Maybe I need to turn off its router features? I don't really know how to do this... I read somewhere that this was effected by "enabling Bridging", which I did, but that sort of broke everything and it's what spurred the hard-reset to defaults.

Sorry for all the complicated explanation - hopefully it's enough background that the problem can be solved by someone brilliant and insightful out there. Metafilter - please help me!
posted by Marquis to Technology (7 answers total)
What version of Azureus are you using? (the new one) didnt work for me - I reinstalled and everything is hunky dory now.
posted by the cuban at 8:41 AM on May 8, 2005

Response by poster: It's version; gave me yellow smilies as well. :(
posted by Marquis at 8:53 AM on May 8, 2005

When you "adapted" the port forwarding settings on your modem, what exactly did you do?

In the web interface for the modem, you should be mapping each of the Desired Ports to forward to the IP address that the modem is giving to your Base Station (so that the base station can then follow your rules and forward them on to your computer). It's not 100% clear from your (otherwise perfectly detailed) description.
posted by bcwinters at 8:54 AM on May 8, 2005

It sounds like your basic problem is that you have both devices trying to handle the routing and NAT. You only want one of them to do that. So, yeah, you want to set one or the other of them to bridging mode.

I might consider returning this Zoom thing, selling the Airport, and getting a single device that does everything, like this: D-Link DSL-G604T. That would make things a lot less confusing.

I could probably get what you have to work if I had it in front me of, but I'm getting a little bogged down in all the details here.
posted by mcguirk at 8:55 AM on May 8, 2005

you know... "in front of me"

Also, it may be easier to put the Airport into bridging mode than the Zoom.

I suppose it might even work with double NAT and double port-forwarding. Seems a bit messy though.
posted by mcguirk at 9:06 AM on May 8, 2005

Response by poster: bcwinters - Hmm... I added Port Forwarding on the modem by adding new IP Filter rules - and I pointed to the computer's IP address, not to the Airport's. (I'm not 100% sure how to find the Airport's IP... but I'll assume it's the one listed on the Internet panel of the Airport Configuration page.)

If I redo this to point the modem's IP Rules to the Airport, should I delete the other IP Rules that have been created (automatically) in the modem's settings? I'm worried that things will conflict with each other, but on the other hand, I'm worried about deleting something I shouldn't.

Also, should I worry about the "IP Filtering not enabled" thing? And do you have any ideas about where it might be enabled?

mcguirk - I can't see a place to make the Airport bridge, and when I tried doing it with the modem, nothing changed. :(
posted by Marquis at 9:09 AM on May 8, 2005

If you can't figure out how to re-enable IP Filtering on the Zoom, then just go and return it now; you'll need that to get BT to work.

Otherwise, your best bet for network harmony is to switch the Airport to acting like a pure Wireless Access Point. First, disable the DHCP server in the Airport*, then switch the cable connecting to the Zoom from the WAN port to the LAN port, set up your computer with a manual IP address on the Zoom's subnet, and set the Zoom to forward the proper ports to that address.

* While not strictly necessary with your setup, competing DHCP servers on a LAN is almost guaranteed to cause problems down the line.

On preview: switching from the WAN to the LAN port will make it bridge rather than route your traffic.
posted by boaz at 9:16 AM on May 8, 2005

« Older Are British Lobbysts better than their American...   |   How do I hide stuff in HTML? Newer »
This thread is closed to new comments.