How to access other drive's contents on startup in Ubuntu?
April 10, 2011 10:51 AM   Subscribe

How to access other drive's contents on startup in Ubuntu?

I dualboot Ubuntu and Windows 7. I have 2 drives and each OS sits on a different hard drive. Most of my media is on the windows drive.

From ubuntu I can click on Places, select the Windows drive and it will open up and then rhythmbox etc can then access the music.

What command is run when the drive is clicked on in Places and how can I make this happen automatically on boot up?
posted by quaisi to Computers & Internet (13 answers total) 1 user marked this as a favorite
you need to edit /etc/fstab
posted by sanko at 10:53 AM on April 10, 2011

Sanko is correct.
posted by Space_Lady at 11:03 AM on April 10, 2011

You asked, "What command is run when the drive is clicked on in Places and how can I make this happen automatically on boot up?"

Answer: mount
posted by nogero at 11:36 AM on April 10, 2011

Ok I've read through the link and I'm a little bit confused.

According to gparted, the drive's status is "mounted on /media/ACB6A12EB6A0FA4A" which is /dev/sda2. Is it not then already mounted?

If not could somebody please tell me what to put in /etc/fstab?

posted by quaisi at 11:36 AM on April 10, 2011

no i'm an idiot. I've mounted it already by clicking on Places. Apologies!

In that case could somebody let me know what to put in /etc/fstab please?
posted by quaisi at 11:39 AM on April 10, 2011

type 'man fstab' at a terminal prompt for lots of info about fstab. fstab is the table with all things that should be mounted on startup. You can edit it with a text editor.
posted by nogero at 11:43 AM on April 10, 2011

Current versions of Ubuntu also come with pysdm (Administration > Storage Device Manager) which is a GUI-based way to handle fstab and udev related stuff.

(In practice, I've never managed to find an ideal fstab equivalent to Ubuntu's manual mount, especially with NTFS drives and fuseblk where permissions are an issue, but that's probably my own incompetence.)
posted by holgate at 12:01 PM on April 10, 2011

You might try ntfs-config. It's in Synaptic. I believe it mounts ntfs partitions on startup and it's a GUI app.
posted by artof.mulata at 12:19 PM on April 10, 2011

This is a relevant page from the Ubuntu Guide that explains how to edit fstab for NTFS drives:

It should be pretty clear...
posted by artof.mulata at 12:39 PM on April 10, 2011

Open a Terminal. Become root. Run some commands. Make a mount point, edit /etc/fstab. In the Terminal you can either type 'sudo' in front of each command, or type 'sudo -i' once to get a root prompt.
zen@zim:~$ sudo -i
root@zim:~# blkid -o value -s UUID /dev/sda2

# that should be: ACB6A12EB6A0FA4A in your case.  it's the unique ID of the partition.
# make a directory to mount it on, you can use the long UUID like it does automagically,
# or choose a better name.  and give it open permissions because we're lazy

root@zim:~# mkdir /media/ntfs
root@zim:~# chmod go+w media/ntfs

# edit /etc/fstab with your favorite editor, probaby 'gedit', add the following line.

UUID=584C51344C510DDE /media/ntfs ntfs defaults 0 0

# it should look mostly like the other lines for / and /home, just with a shorter UUID and ntfs

# now mount it

root@zim:~# mount /media/ntfs

# check it out

root@zim:~# ls /media/ntfs

AUTOEXEC.BAT  Documents and Settings  IO.SYS         RECYCLER
boot.ini      drivers                 Log.txt        System Volume Information
Config.Msi    hiberfil.sys            MSDOS.SYS      WINDOWS
CONFIG.SYS    i386                    NTDETECT.COM
dell          INFCACHE.1              ntldr
dell.sdr      Intel                   Program Files

# your done.  get out of here
root@zim:~# exit
ze@zim:~$ exit

posted by zengargoyle at 12:41 PM on April 10, 2011 [1 favorite]

Thanks for all of your help. I've got it working now!
posted by quaisi at 12:55 PM on April 10, 2011

I see that it's working now, which is good. For Ubuntu help in general, I recommend Ubuntu Forums - usually somebody has already had your issue and somebody else has already solved it, just a bit of searching is needed.
posted by number9dream at 6:29 PM on April 10, 2011

I've found the speed of response and knowledge to be better here than in ubuntu forums.
posted by quaisi at 2:09 PM on April 11, 2011

« Older Remember when you'd skip your early classes, and...   |   Meta-book-ID please! Newer »
This thread is closed to new comments.