Ctrl-s should be save, not save as, please help!
April 6, 2011 6:34 PM   Subscribe

how on earth to I assign shortcut keys in windows 7?

For some reason, it appears that ctrl-s in word has been assigned "save as". I'm a compulsive saver; this is very annoying. I want it to just be "save" without opening the dialogue box. I am sure this is easy to do, but I am at a loss and Google is not helping me.
posted by dpx.mfx to Computers & Internet (12 answers total) 1 user marked this as a favorite
 
This is a Word shortcut issue, not a Windows 7 one -- what version of word are you using?
posted by brainmouse at 6:36 PM on April 6, 2011


Word 2007 - the one with the dreaded ribbon.
posted by dpx.mfx at 6:40 PM on April 6, 2011


Well, I'll assume it's office 2007 -- click the big circle office button in the upper left of word and go to "Word options" in the bottom right of that window -- then Customize, then at the bottom next to keyboard shortcuts hit customize. You're looking to assign the command "FileSave", which is in the Office Menu category, to ctrl-s
posted by brainmouse at 6:40 PM on April 6, 2011


huh. It appears that it is set properly after all. So I have no idea why it's taking me to the "save as" box. Clicking on the save button does not do the same thing.
posted by dpx.mfx at 6:45 PM on April 6, 2011


(but that is the perfect answer to the question I actually asked, so, thanks brainmouse!)
posted by dpx.mfx at 6:45 PM on April 6, 2011


Are you sure you're not inadvertently opening your documents in read-only mode? This can lead to the save-as-instead-of-save issue IME.
posted by patronuscharms at 6:47 PM on April 6, 2011


patronuscharms, no. Although could it have something to do with the docx extension? (I swear i used to not be this clueless).

And it doesn't happen every time. For instance, I just ctrl-s saved a document; no box. type type type; ctrl-s again, and up comes the dialog box. It sort of makes me feel like I'm nuts.
posted by dpx.mfx at 6:49 PM on April 6, 2011


Did you check what the FileSaveAs command is assigned to? Or one of the other FileSaveEtc options? Maybe they're double assigned somehow?
posted by brainmouse at 6:50 PM on April 6, 2011


brainmouse, I did check all of them. I actually reset them for normal.dat and for the file i was working in. No luck. i might have to retrain myself to hit shift+f12.
posted by dpx.mfx at 6:54 PM on April 6, 2011


My next suggestion is that you reset all the keyboard commands from that menu -- it'll be grayed out unless you assign something or have in the past, so make up some random keyboard command, and assign it, and then hit Reset All.

Or make up some other shortcut for save... shift+ctrl+s?
posted by brainmouse at 6:59 PM on April 6, 2011


If it's a new document ctrl s will open the save as dialog. Could that be it?
posted by The Lamplighter at 7:41 PM on April 6, 2011


Laplighter, no - it does it even after I've already saved it. So strange. Thanks for the suggestions!
posted by dpx.mfx at 6:00 AM on April 7, 2011


« Older Let's have some fun! Interview questions for...   |   Where to donate a cool bicycle fixer-upper in NYC? Newer »
This thread is closed to new comments.