Why doesn't imgur work for me?
February 26, 2011 9:56 AM   Subscribe

Images hosted by imgur won't load for me.

The the past year or so, images hosted on imgur.com would go through fifteen to twenty minute on/off periods for me, where for a long time Google Chrome (or Firefox or Camino) would look like it was trying to load the page, and then I'd get a message that said "This webpage is not available". I'd wait fifteen minutes (reloading occasionally along the way) and then suddenly the images would load.

Now, they won't load at all—they always produce the page that says "This webpage is not available". This happens on my 2010 iMac that's running Snow Leopard, and it happens on my old iBook that's running Tiger. It happens across all browsers.

At work, where we have the same internet service but the computer has XP on it, imgur loads just fine, with no weird waits.

I've flushed the cache on my computer. My router has been restarted many times in the period where this has been happening. I have disabled adblock for any images on imgur.com. Googling isn't finding me anything, which makes me feel like I'm the only person in the world who's having this problem. What can possibly be the reason? Thank you!
posted by interrobang to Computers & Internet (29 answers total) 1 user marked this as a favorite
 
And here is the error Chrome is giving me right now:

Error 105 (net::ERR_NAME_NOT_RESOLVED): The server could not be found.
posted by interrobang at 9:57 AM on February 26, 2011


And I should add that imgur.com itself does load for me, just not any of the images on it.
posted by interrobang at 10:02 AM on February 26, 2011


What response do you get when you type the following into the Mac OS X command line (use Terminal.app)?
dig A i.imgur.com
posted by RichardP at 10:09 AM on February 26, 2011


;; Truncated, retrying in TCP mode.
;; Connection to 192.168.1.1#53(192.168.1.1) for i.imgur.com failed: connection refused.
posted by interrobang at 10:12 AM on February 26, 2011


Check your C:\windows\system32\drivers\etc\hosts file. It looks like the address is redirecting to your local machine
posted by pyro979 at 10:19 AM on February 26, 2011


Both the computers this his happening to are running OSX.
posted by interrobang at 10:20 AM on February 26, 2011


The DNS reply for "i.imgur.com" is quite a bit larger than most DNS lookups. Something is truncating UDP packets (either your Mac, your router, or your ISP). Have you set your MTU low somewhere? What kind of internet connection do you have?

Ignore pyro979, he's wrong (that hosts file location is for Windows and presumably 192.168.1.1 is your router not your local machine).
posted by RichardP at 10:21 AM on February 26, 2011


Sorry, bad reading comprehension. Don't know enough about Macs, but it's clearly redirecing to your local machine on some level (192.168.x.x is local network address)
posted by pyro979 at 10:23 AM on February 26, 2011


I don't know what MTU is. This is happening on my PPC iBook too, and I get the same exact message on Terminal.app:

;; Truncated, retrying in TCP mode.
;; Connection to 192.168.1.1#53(192.168.1.1) for i.imgur.com failed: connection refused.

The iBook has a wireless connection; the iMac is plugged into the router by the ethernet cable. I have "highspeed" cable internet.
posted by interrobang at 10:24 AM on February 26, 2011


A MTU is "maximum transmission unit", the size of the largest packet that a network protocol can transmit.

Basically, if you think of what you get from the Internet as a ton of different little "packets", the MTU is a limit on how big those packets can be.

If the Internet's mail, then MTU's the size of your mailbox.
posted by WCityMike at 10:31 AM on February 26, 2011


192.168.1.1 is going to be your router address.

53 is the DNS port. It looks like your router is acting as a DNS proxy, and doing it badly.

Try changing the DNS servers on your computer to 4.2.2.2 (level 3's public DNS) and 8.8.8.8 (google's DNS servers).
posted by empath at 10:32 AM on February 26, 2011


Please try the following two commands and let me know if they work:
ping -D -s 1000 www.apple.com
ping -D -s 100 www.apple.com
Also, what kind of router do you have?
posted by RichardP at 10:32 AM on February 26, 2011


pyro979 may well have got the wrong OS but Mac does have a hosts file. Here is how to edit it.
posted by TheRaven at 10:32 AM on February 26, 2011


The router is a "TP Link Wireless N Router".

The pinging is resulting in line after line like this:

1008 bytes from 184.24.93.15: icmp_seq=134 ttl=55 time=46.321 ms

...the first one you wrote is still going right now, RichardP.
posted by interrobang at 10:38 AM on February 26, 2011


In the DNS servers settings, the only DNS Server listed there is 192.168.1.1. I'm assuming this is a bad thing. This page says to use something else. Should I change it?

If this is a bad thing, how did this happen? I've never edited the hosts file on my iBook.
posted by interrobang at 10:40 AM on February 26, 2011


You can cancel the ping with a Control-C. Since the first command succeeded you don't appear to have a problem with a small MTU setting somewhere. The next thing to try is checking if the DNS proxy in your router doesn't correctly handle larger sized requests (same as empath's suggestion). Normally 192.168.1.1 would be OK for a DNS Server setting if your router correctly proxies DNS, try using 8.8.8.8 instead.

Also, the hosts file is not your problem, don't follow the instructions on editing your hosts file at TheRaven's link.
posted by RichardP at 10:42 AM on February 26, 2011


Well, I changed the DNS servers to what empath said, and now imgur seems to work! Thank you all for your help! But I still need to know how this happened. Does anyone know?
posted by interrobang at 10:43 AM on February 26, 2011


interrobang, the DNS proxy in your router is defective. It's truncating longer DNS replies. You can verify this by trying the following two commands:
dig @8.8.8.8 A i.imgur.com
dig @192.168.1.1 A i.imgur.com
You should see that the first works but the second fails. You might see if there is a firmware upgrade available for your router.
posted by RichardP at 10:47 AM on February 26, 2011


I should also mention, that 192.168.1.1 was the DNS server on my iPod Touch, too! Why?
posted by interrobang at 10:48 AM on February 26, 2011


It's not bad. Your computer's DNS gets assigned via Dynamic Host Configuration Protocol. Some routers will just pass on your ISP's DNS servers to your computer, some of them run a DNS proxy and send tell your computer to send DNS requests to it instead of your ISP. It caches DNS requests locally, which theoretically makes DNS requests faster and saves bandwidth, but in practice most of them are buggy and cause random problems like this.

You should probably really use your ISP's local DNS servers instead of the big public ones. Personally, I use my ISP's DNS as the primary and 8.8.8.8 as secondary.
posted by empath at 10:48 AM on February 26, 2011


Yep, the first one worked, but the second one failed, RichardP. As for the firmware for the router, I have no idea how to upgrade that.
posted by interrobang at 10:49 AM on February 26, 2011


I wouldn't bother. There's no real reason to use the DNS proxy on your router. You may even be able to just turn it off, and then it should pass on the ISP's DNS to your computers.
posted by empath at 10:50 AM on February 26, 2011


(Turn it off in the router's web interface, that is)
posted by empath at 10:51 AM on February 26, 2011


I wouldn't bother. There's no real reason to use the DNS proxy on your router. You may even be able to just turn it off, and then it should pass on the ISP's DNS to your computers.

Does this mean that next time I have to restart my router, I'm going to have to go in and change the DNS stuff on my computers again?
posted by interrobang at 10:53 AM on February 26, 2011


Does this mean that next time I have to restart my router, I'm going to have to go in and change the DNS stuff on my computers again?
No. If you manually set your DNS server settings on your Mac or iPod touch they will override the default settings your router sends to them when they ask for an IP address (via DHCP).

Looking at TP Link's web site, I don't think you their is a DHCP option in your router for passing through the ISP's DNS server settings. However it does appear you can configure the DHCP server in the router to set the DNS server to whatever you want (it defaults to using itself). If I were you I'd put your ISP's DNS server there or Google's public DNS server (8.8.8.8) and then remove the manual override of the DNS server in your Macs and iPod touch. I think it is best to be set in just one place rather than three.

If you wish I can walk you through the steps if you tell me the model number of your router and the software version (you should be able to get this information from the label at the back of the device).
posted by RichardP at 11:04 AM on February 26, 2011


I'm in the router's settings right now. I'll mefi mail you more details. Thank you!
posted by interrobang at 11:10 AM on February 26, 2011


For those following along, after a brief conversation, interrobang has successfully configured his TP Link wireless router to have the router's DHCP server instruct clients to directly use his ISP's primary and secondary DNS servers, thereby bypassing TP Link's broken DNS proxy implementation.

My recommendation to future readers of this thread: consider avoiding TP Link's routers. There is no excuse for this sort of broken behavior in a router.
posted by RichardP at 12:07 PM on February 26, 2011 [2 favorites]


Excellent!
Now, can someone tell me what a good resource is for learning this stuff?
I always get stuck.
posted by Drasher at 3:44 PM on February 26, 2011


Spend a few years doing tech support for a living :)
posted by empath at 4:44 PM on February 26, 2011


« Older It's not a zero-sum game, guys.   |   Where to Read Steve Ditko's "Mr. A"? Newer »
This thread is closed to new comments.