What have I messed up on Hotmail via FireFox?
December 24, 2010 12:51 PM   Subscribe

I have been using Hotmail for e-mail, and getting it via IMac on FireFox. I cleaned the machine etc and now find I am not able to get Hotmail. [more]

Oddly, though, I can get it with no trouble if I switch to Safari, where it comes through as it used to. What did I mess up that needs restoration?
Ps: I am using https rather than http for hotmail connection
posted by Postroad to Computers & Internet (6 answers total)
 
You're probably going to have to give us more info:

What do you mean by "cleaned the machine etc"? Physically cleaned dust out of it or did you run daily/weekly/monthly cron scripts?
What do you mean "you're not able to get Hotmail"? What do you see in Firefox?
What version of OS X are you running?
Are you fully updated?
Is Firefox up to date?
Are you connecting through a router?
Wifi or ethernet?
Have you tried restarting the computer (surprisingly, this solves a lot of issues)?
Have you tried flushing the DNS? (go--> Utilities --> Terminal --> dscacheutil -flushcache)
posted by sharkfu at 1:02 PM on December 24, 2010


cleaned: used MacKeeper. updated in all things, have router etc , restarted, flushed.
I get it as it should be when I switch to Safari.But when I go to FireFox, I get this:
ndows Live™

* Home
* Devices
* SkyDrive
* Mobile
* Downloads
* All services

* Hotmail (2)
* Messenger
* Office
* Photos
* MSN


fred lapides

* Sign in to Messenger
* Pop out Messenger
* Messenger isn't available now.
* Reconnecting in {0}:{1}...
* NETWORK_NAME
* Available Available
* Busy Busy
* Away Away
* Appear offline Appear offline
* Sign out of Messenger
*
* More themes
* Privacy settings
* Account
etc and can do nothing with it. All works fine in Safari. But nothing works in FireFox, though all else works for me in Firefox, all sites come up etc.
posted by Postroad at 2:01 PM on December 24, 2010


In addition: I note that when I go to Preferences, cookies, Hotmail cookie does not show up. When I add the hotmail address and hit allow, it still does not work or cookie show up.
In sum: I am getting cookie enabled Hotmail in Safari and a minute later, same machine, unable to get Hotmail via FireFox.
posted by Postroad at 2:11 PM on December 24, 2010


Does your "I cleaned the machine etc and now..." involve installing NoScript?
posted by rhizome at 2:11 PM on December 24, 2010


It sounds like you've set your content policy too strict on cookies. I'd set temporarily set it to allow all cookies to see if there's a MSN / Hotmail cookie you need that you've inadvertently locked out.
posted by sharkfu at 2:19 PM on December 24, 2010 [1 favorite]


Last time anybody I knew had trouble with Hotmail, it was because Hotmail was stupidly mis-detecting their browser and redirecting them unavoidably to its mobile site; it seems to do that for any browser it doesn't explicitly recognize. So try installing the User Agent Switcher extension in your Firefox and seeing whether lying to Hotmail about who you are gets you where you want to go.
posted by flabdablet at 5:47 AM on December 25, 2010


« Older Can I restore this stencil?   |   No, really, I'm better but did my brain trick me? Newer »
This thread is closed to new comments.