How do I convince my Mac to ignore all the wireless networks around it that aren't my own?
April 10, 2005 9:16 AM   Subscribe

How do I convince my Mac to ignore all the wireless networks around it that aren't my own?

My roommate and I live in a building with a *lot* of wireless networks in it. My room is near the exterior wall, and I pick up at least four during any given computing session; my roommate's room is near the building's interior hall and she picks up about *nine*. Unfortunately, some people are stupid and don't password-protect their networks, so our computers occasionally, with mounting frequency as of late, log onto theirs instead of our own, and then we can't connect to the internet and it takes a lot of swearing and quitting/restarting Airport in order to convince our computers that yes, now they are on a network that works. It's a huge PITA, and I want to know if there's any way to convince our Macs to ignore all of the other wireless networks and only log on to our own at startup. We're both running the newest version of Panther and our network is broadcast over an Airport Express, and our signal strength is very good while the networks we get logged onto often aren't, so it can't just be a question of needing to overpower the other signals, right? (Or is it? Would an antenna solve this problem?)
posted by logovisual to Computers & Internet (6 answers total)
 
You can tell your mac to connect to a specific network in the Airport preferences in the Network preferences pane.

Go, System Preferences -> Network -> Airport

Then click on the Airport tab, and in the dropdown menu, select 'By default, join a specific network' and put your network details in.
posted by gaby at 9:23 AM on April 10, 2005


That's already enabled, actually, and we're still having this problem... perhaps it's because the computer has a few seconds' lag in which it doesn't find our network and it does find the other one(s)?
posted by logovisual at 11:01 AM on April 10, 2005


That is very unusual. I keep about a dozen location profiles, and my wireless will fail to work if I forget to switch profiles. If you have a prefered set then it shouldn't join other networks.

You can switch networks on demand, there's no reason to stop/start until it randomly picks the right one. Click "Show AirPort status in menu bar". From there you can select any available network (that's broadcasting its SSID), or you can force it to join a specific one (by choosing "Other...").

If there are a lot of networks around you might want to check and make sure that your channel is different from the others. I've had problems before where two relatively strong base stations are on the same channel and my AirPort refuses to join either. I use KisMAC to sniff that information.
posted by sbutler at 11:31 AM on April 10, 2005


It sounds like it's remembering those SSIDs from previous associations and trying to re-associate with them every time it seems them. Try following these instructions to reset the list of known wireless networks.
posted by bac at 11:32 AM on April 10, 2005


There used to be an option to associate with the last used access point but I've just checked for it and it's gone. This must have been removed in a recent upgrade. Anyone know where this has gone?
posted by gaby at 11:43 AM on April 10, 2005


What bac said. It should not be connecting automatically to a network that you haven't manually selected in the past. Reset the list and don't choose a foreign network manually, and you should be fine.

Keeping your own network visible all the time when you have 4-9 other networks in the same airspace is an entirely different problem, and one I wish you luck with...
posted by trevyn at 10:59 PM on April 10, 2005


« Older Old issues of TPUG Magazine   |   if a purebread dog is impregnated by a mutt, is it... Newer »
This thread is closed to new comments.