Rarely is the questioned asked: Is our Mail clients learning?
December 9, 2010 6:49 AM   Subscribe

Why doesn't my Apple Mail junk filter learn?

I've tried three times by resetting the filter and yet it doesn't seem to learn a single thing. The problem isn't that it's not filtering enough, the problem lies in the number of false positives. Things that it thinks are junk that are not. These are email I get from colleagues who are in my address book, that I get frequently, and which I unmarked as junk mail and moved to my main mail box. I have reset the filter three times and the results are the same. No learning is occurring.

I suspect this may have something to do with a problem that occurred when I first migrated my work user to this new computer. After that, spotlight stopped working. It also wouldn't re-index. I used the utility ONYX to discover the problem was that the index file seemed to have disappeared. So I created a new one, told it to re-index the contents of my home folder, and spotlight has been working ever since.

Is there a similar file for the junk filters? Any other ideas?
posted by Toekneesan to Computers & Internet (5 answers total)
I share your suspicion that Apple's junk-mail filter sucks. I tried training it and never got good results.

For a while I used SpamSieve, which is fine as far as it goes, but eventually I did what all the other smart people seem to be doing: I started using Gmail (or in my case, Google Apps for Your Domain), which has an excellent spam filter. I see maybe one false-negative a month.
posted by adamrice at 9:59 AM on December 9, 2010

You can make a rule (in the Preferences window, under the Mail menu) that specifies that mail from anyone in your address book should go into your inbox and not be evaluated as junk mail.
posted by Ery at 12:23 PM on December 9, 2010

Look in Mail, Preferences, Junk Mail, custom actions, Advanced...
posted by Lanark at 1:48 PM on December 9, 2010

Response by poster: Yes, anyone in your address book is a default rule for junk mail and already exists and is check in preferences, and yet it seems to be ignoring it. As are previous recipients, but both of those criteria are being ignored.
posted by Toekneesan at 6:36 AM on December 10, 2010

Do you have "Trust junk mail headers set by my isp" ticked? if so try untickiing it.
posted by Lanark at 2:19 AM on December 11, 2010

« Older UK in NL? in HD ?   |   Former owners were idiots, help me avoid the same... Newer »
This thread is closed to new comments.